OCamllabs icon Home|Differences with the last checks|Previous runs


Building on hipp.ocamllabs.io

(from ocaml/opam:debian-unstable)
2021-11-10 04:20.17 ---> using "0acd5aeaa8f7bc314514d9795d14a7f12ec72a6a5b11c5904350189734c6859b" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-2.1 /usr/bin/opam"))
2021-11-10 04:20.17 ---> using "4d29eb3e0b7cd69a97ed90837671d5ca38aa41e2fb94346298af500378eca6fa" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'git://github.com/ocaml/opam-repository.git' ~/opam-repository && git -C ~/opam-repository checkout -q 7b361ce572d98a700d2e0018cb6e9c72db9a3675"))
2021-11-10 04:20.17 ---> using "d735cc1084771dd7a4c27bc038a74be9c565f9b4862c23ef3b35f68ab04a6aef" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2021-11-10 04:20.17 ---> using "44eb507bce7a2e2ed046a7a65eaf9728147d93dd5621a9ab5b08e6a2b062590d" from cache

/: (run (network host)
        (shell "git clone -q 'git://github.com/ocaml/ocaml-beta-repository.git' ~/'beta' && git -C ~/'beta' checkout -q 79aeeadd813bdae424ab53f882f08bee0a4e0b89"))
2021-11-10 04:20.17 ---> using "982f7d54b73fc7cab2a09dec2ae08ff2574343a9745a7f336abd76f9a26d22dc" from cache

/: (run (shell "opam repository add --dont-select 'beta' ~/'beta'"))
[beta] Initialised
2021-11-10 04:20.17 ---> using "581fbaf65c6cbed22afcc69cdb3cb3a52aafc46e8c4cea4bc9ca5a44060fda80" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=beta,default '4.12' '4.12.1'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.12.1"} | "ocaml-system" {= "4.12.1"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> installed ocaml-options-vanilla.1
-> retrieved ocaml-base-compiler.4.12.1  (https://github.com/ocaml/ocaml/archive/4.12.1.tar.gz)
-> installed ocaml-base-compiler.4.12.1
-> installed ocaml-config.2
-> installed ocaml.4.12.1
Done.
# Run eval $(opam env --switch=4.12) to update the current shell environment
2021-11-10 04:20.17 ---> using "78d5078c0bdd824acd7c8517ca45814078f228f65eb155cdc753f924c17cc952" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [165 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Ign:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages [8831 kB]
- Fetched 9059 kB in 7s (1283 kB/s)
- Reading package lists...
- 
2021-11-10 04:20.17 ---> using "6018e4a4ef0cbdcce319671880ad2e4975281d34287180d093e49877a1b7bd23" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"camlidl.1.09\"\
               \nopam install -vy \"camlidl.1.09\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"camlidl.1.09\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] camlidl.1.09 is not installed.

Nothing to do.
The following actions will be performed:
  - install camlidl 1.09

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
Processing  1/3:
-> retrieved camlidl.1.09  (cached)
Processing  2/3: [camlidl: mv]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "mv" "config/Makefile.unix" "config/Makefile" (CWD=/home/opam/.opam/4.12/.opam-switch/build/camlidl.1.09)
Processing  2/3: [camlidl: make all]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "make" "all" (CWD=/home/opam/.opam/4.12/.opam-switch/build/camlidl.1.09)
- cd compiler; make all
- make[1]: Entering directory '/home/opam/.opam/4.12/.opam-switch/build/camlidl.1.09/compiler'
- rm -f config.ml
- sed -e 's|%%CPP%%|cpp|' \
-           config.mlp > config.ml
- chmod -w config.ml
- ocamlc -g -c config.mli
- ocamlc -g -c config.ml
- ocamlc -g -c utils.mli
- ocamlc -g -c utils.ml
- ocamlc -g -c clflags.ml
- ocamlc -g -c idltypes.mli
- ocamlc -g -c prefix.mli
- ocamlc -g -c prefix.ml
- ocamlc -g -c lexpr.mli
- ocamlc -g -c lexpr.ml
- ocamlc -g -c cvttyp.mli
- ocamlc -g -c cvttyp.ml
- ocamlc -g -c variables.mli
- ocamlc -g -c variables.ml
- ocamlc -g -c idlarray.mli
- ocamlc -g -c idlarray.ml
- ocamlc -g -c struct.mli
- ocamlc -g -c struct.ml
- ocamlc -g -c enum.mli
- ocamlc -g -c enum.ml
- ocamlc -g -c union.mli
- ocamlc -g -c union.ml
- ocamlc -g -c cvtval.mli
- ocamlc -g -c cvtval.ml
- ocamlc -g -c structdecl.mli
- ocamlc -g -c structdecl.ml
- ocamlc -g -c enumdecl.mli
- ocamlc -g -c enumdecl.ml
- ocamlc -g -c uniondecl.mli
- ocamlc -g -c uniondecl.ml
- ocamlc -g -c typedef.mli
- ocamlc -g -c typedef.ml
- ocamlc -g -c funct.mli
- ocamlc -g -c funct.ml
- ocamlc -g -c constdecl.mli
- ocamlc -g -c constdecl.ml
- ocamlc -g -c intf.mli
- ocamlc -g -c intf.ml
- ocamlc -g -c file.mli
- ocamlc -g -c file.ml
- ocamlc -g -c predef.mli
- ocamlc -g -c predef.ml
- ocamllex linenum.mll
- 16 states, 331 transitions, table size 1420 bytes
- ocamlc -g -c linenum.mli
- ocamlc -g -c linenum.ml
- ocamlc -g -c parse_aux.mli
- ocamlc -g -c parse_aux.ml
- ocamlyacc -v parser_midl.mly
- 12 shift/reduce conflicts, 4 reduce/reduce conflicts.
- ocamlc -g -c parser_midl.mli
- ocamlc -g -c parser_midl.ml
- ocamllex lexer_midl.mll
- 129 states, 1747 transitions, table size 7762 bytes
- ocamlc -g -c lexer_midl.mli
- ocamlc -g -c lexer_midl.ml
- ocamlc -g -c parse.mli
- ocamlc -g -c parse.ml
- ocamlc -g -c fixlabels.mli
- ocamlc -g -c fixlabels.ml
- ocamlc -g -c normalize.mli
- ocamlc -g -c normalize.ml
- ocamlc -g -c main.ml
- ocamlc -g -o camlidl config.cmo utils.cmo clflags.cmo prefix.cmo lexpr.cmo cvttyp.cmo variables.cmo idlarray.cmo struct.cmo enum.cmo union.cmo cvtval.cmo structdecl.cmo enumdecl.cmo uniondecl.cmo typedef.cmo funct.cmo constdecl.cmo intf.cmo file.cmo predef.cmo linenum.cmo parse_aux.cmo parser_midl.cmo lexer_midl.cmo parse.cmo fixlabels.cmo normalize.cmo main.cmo
- make[1]: Leaving directory '/home/opam/.opam/4.12/.opam-switch/build/camlidl.1.09/compiler'
- cd runtime; make all
- make[1]: Entering directory '/home/opam/.opam/4.12/.opam-switch/build/camlidl.1.09/runtime'
- ocamlc -g -ccopt "-Wall -g" idlalloc.c
- ocamlc -g -ccopt "-Wall -g" comintf.c
- ocamlc -g -ccopt "-Wall -g" comerror.c
- rm -f dllcamlidl.so
- ocamlmklib -o camlidl  idlalloc.o comintf.o comerror.o 
- make[1]: Leaving directory '/home/opam/.opam/4.12/.opam-switch/build/camlidl.1.09/runtime'
- cd lib; make all
- make[1]: Entering directory '/home/opam/.opam/4.12/.opam-switch/build/camlidl.1.09/lib'
- ocamlc -g -c com.mli
- ocamlc -g -c com.ml
- ocamlc -g -a -o com.cma -dllib -lcamlidl -cclib -lcamlidl com.cmo
- ocamlopt -c com.ml
- ocamlopt -a -o com.cmxa -cclib -lcamlidl com.cmx
- make[1]: Leaving directory '/home/opam/.opam/4.12/.opam-switch/build/camlidl.1.09/lib'
- cd tools; make all
- make[1]: Entering directory '/home/opam/.opam/4.12/.opam-switch/build/camlidl.1.09/tools'
- make[1]: Nothing to be done for 'all'.
- make[1]: Leaving directory '/home/opam/.opam/4.12/.opam-switch/build/camlidl.1.09/tools'
-> compiled  camlidl.1.09
-> installed camlidl.1.09
Done.
# Run eval $(opam env) to update the current shell environment
2021-11-10 04:20.41 ---> saved as "2d9cc7fdaf8a82349f173771847ad5cb64e73840734af3b3904b31ea7b1c9bb6"
Job succeeded