OCamllabs icon Home|Differences with the last checks|Previous runs


Building on phoebe.ocamllabs.io

(from ocaml/opam:debian-unstable)
2021-11-09 21:46.34 ---> using "0acd5aeaa8f7bc314514d9795d14a7f12ec72a6a5b11c5904350189734c6859b" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-2.1 /usr/bin/opam"))
2021-11-09 21:46.34 ---> using "4d29eb3e0b7cd69a97ed90837671d5ca38aa41e2fb94346298af500378eca6fa" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'git://github.com/ocaml/opam-repository.git' ~/opam-repository && git -C ~/opam-repository checkout -q 7b361ce572d98a700d2e0018cb6e9c72db9a3675"))
2021-11-09 21:46.34 ---> using "d735cc1084771dd7a4c27bc038a74be9c565f9b4862c23ef3b35f68ab04a6aef" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2021-11-09 21:46.34 ---> using "44eb507bce7a2e2ed046a7a65eaf9728147d93dd5621a9ab5b08e6a2b062590d" from cache

/: (run (network host)
        (shell "git clone -q 'git://github.com/ocaml/ocaml-beta-repository.git' ~/'beta' && git -C ~/'beta' checkout -q 79aeeadd813bdae424ab53f882f08bee0a4e0b89"))
2021-11-09 21:46.34 ---> using "982f7d54b73fc7cab2a09dec2ae08ff2574343a9745a7f336abd76f9a26d22dc" from cache

/: (run (shell "opam repository add --dont-select 'beta' ~/'beta'"))
[beta] Initialised
2021-11-09 21:46.34 ---> using "581fbaf65c6cbed22afcc69cdb3cb3a52aafc46e8c4cea4bc9ca5a44060fda80" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=beta,default '4.13' '4.13.1'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.13.1"} | "ocaml-system" {= "4.13.1"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> installed ocaml-options-vanilla.1
-> retrieved ocaml-base-compiler.4.13.1  (cached)
-> installed ocaml-base-compiler.4.13.1
-> installed ocaml-config.2
-> installed ocaml.4.13.1
Done.
# Run eval $(opam env --switch=4.13) to update the current shell environment
2021-11-09 21:46.34 ---> using "7ed5e7ed6ce3252aa3103d6856ad5ef3f791b5a7fa318916c1eabafe20e012dc" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [165 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Ign:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages [8823 kB]
- Fetched 9052 kB in 2s (5803 kB/s)
- Reading package lists...
- 
2021-11-09 21:46.34 ---> using "be3ac925b244d16d65a19dcf187c23ed608c9ff2722a2a94d4a2ed41efad8592" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"base-unix.base\"\
               \nopam install -vy \"base-unix.base\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"base-unix.base\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
  * Incompatible packages:
    - (invariant) -> ocaml-base-compiler >= 4.13.1
    - (request)
    You can temporarily relax the switch invariant with `--update-invariant'

No solution found, exiting
[NOTE] Package base-unix is already installed (current version is base).
2021-11-09 21:46.48 ---> saved as "c9756592b2a3174c4a664f85440de9dcc24f3cea31ab3fffb7ba33b3808a3934"
Job succeeded