OCamllabs icon Home|Differences with the last checks|Previous runs


Building on x86-bm-c4.sw.ocaml.org

(from ocaml/opam:debian-unstable@sha256:9018ce829df92c35f88e7c207d161758bf85fa58146b7fb83c1e7bdd52796af2)
2023-09-12 18:13.14 ---> using "a6d895057d33423d936537196324b0ae6b29c3c416a86d619af7ffab6d54780a" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2023-09-12 18:13.14 ---> using "c8ff46adfeac738d7617a8f1519af408882364b6f9b4b67c465a381ce2c0d02a" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q 8ee6bf822f4e1daaa08726e322bf03c9f0251bdb"))
2023-09-12 18:13.14 ---> using "a4d4bc62f6d9af635a1084ae9978d6b8b32d332991de6dfe6d56687d10fefcaf" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2023-09-12 18:13.14 ---> using "afadee60f5277fb2c9ccf0ae7c1548965f28cbdb61ebd53e732d06c8444ddd34" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.09' '4.09.1'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.09.1"} | "ocaml-system" {= "4.09.1"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-base-compiler.4.09.1  (cached)
-> installed ocaml-base-compiler.4.09.1
-> installed ocaml-config.1
-> installed ocaml.4.09.1
Done.
# Run eval $(opam env --switch=4.09) to update the current shell environment
2023-09-12 18:13.14 ---> using "f9323e3a93dc6bef15a663f7f1716f272e9a920aaa162978d02bb0d39f72dbd7" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [195 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2023-09-12-1406.07-F-2023-09-07-0809.21.pdiff [298 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2023-09-12-1406.07-F-2023-09-07-0809.21.pdiff [298 kB]
- Fetched 557 kB in 2s (227 kB/s)
- Reading package lists...
- 
2023-09-12 18:13.14 ---> using "11d7bef40f5784917763d61570526534221a1becefa758fc669569a5bb46d729" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"OCanren.0.3.0\"\
               \nopam install -vy \"OCanren.0.3.0\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"OCanren.0.3.0\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] OCanren.0.3.0 is not installed.

Nothing to do.
[ERROR] Package conflict!
No solution found, exiting
  * No agreement on the version of ocaml:
    - (invariant) -> ocaml-base-compiler = 4.09.1 -> ocaml = 4.09.1
    - OCanren >= 0.3.0 -> ocaml >= 4.10
    You can temporarily relax the switch invariant with `--update-invariant'
  * No agreement on the version of ocaml-base-compiler:
    - (invariant) -> ocaml-base-compiler = 4.09.1
    - OCanren >= 0.3.0 -> ocaml >= 4.10 -> ocaml-base-compiler = 4.11.1
  * Missing dependency:
    - OCanren >= 0.3.0 -> ocaml >= 4.10 -> ocaml-variants >= 4.10.0 -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'

'opam install -vy OCanren.0.3.0' failed.
"/usr/bin/env" "bash" "-c" "
opam remove -y "OCanren.0.3.0"
opam install -vy "OCanren.0.3.0"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "OCanren.0.3.0" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed