OCamllabs icon Home|Differences with the last checks|Previous runs


Building on laodoke.caelum.ci.dev

(from ocaml/opam:debian-unstable@sha256:9018ce829df92c35f88e7c207d161758bf85fa58146b7fb83c1e7bdd52796af2)
2023-09-12 21:18.23 ---> using "a6d895057d33423d936537196324b0ae6b29c3c416a86d619af7ffab6d54780a" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2023-09-12 21:18.23 ---> using "e73538c6e92b552cafae4b663aea9b2d2f9f30bc349b4e0658f8d37da4743963" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q 8ee6bf822f4e1daaa08726e322bf03c9f0251bdb"))
2023-09-12 21:18.23 ---> using "f8c197b393ae6197cc9af47bbe4b9eb9279201e827de1fea6364c7441be841de" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2023-09-12 21:18.23 ---> using "3728e710f1011cc94fc8d16c3fc87da6ce268e4fcef9a54d1b70dc8f1c1e8cf8" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.11' '4.11.2'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.11.2"} | "ocaml-system" {= "4.11.2"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-base-compiler.4.11.2  (cached)
-> installed ocaml-base-compiler.4.11.2
-> installed ocaml-config.1
-> installed ocaml.4.11.2
Done.
# Run eval $(opam env --switch=4.11) to update the current shell environment
2023-09-12 21:18.23 ---> using "02795d97618f9d197be387092566019a7c4cf8778c5fab36805628836905ca73" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [195 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2023-09-12-1406.07-F-2023-09-07-0809.21.pdiff [298 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2023-09-12-1406.07-F-2023-09-07-0809.21.pdiff [298 kB]
- Fetched 557 kB in 2s (226 kB/s)
- Reading package lists...
- 
2023-09-12 21:18.23 ---> using "184d683521e34ddd9e37cdabf8fc69b20adbc7323fbf3f0b3816e3082beffcc0" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"beluga.1.1.1\"\
               \nopam install -vy \"beluga.1.1.1\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"beluga.1.1.1\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
Nothing to do.
[NOTE] beluga.1.1.1 is not installed.

[ERROR] Package conflict!
  * No agreement on the version of ocaml:
    - (invariant) -> ocaml-base-compiler = 4.11.2 -> ocaml = 4.11.2
    - beluga >= 1.1.1 -> ocaml >= 4.14
    You can temporarily relax the switch invariant with `--update-invariant'

No solution found, exiting
'opam install -vy beluga.1.1.1' failed.
"/bin/bash" "-c" "
opam remove -y "beluga.1.1.1"
opam install -vy "beluga.1.1.1"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "beluga.1.1.1" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed