OCamllabs icon Home|Differences with the last checks|Previous runs


Building on c2-2.equinix.ci.dev

(from ocaml/opam:debian-unstable@sha256:9018ce829df92c35f88e7c207d161758bf85fa58146b7fb83c1e7bdd52796af2)
2023-09-12 18:42.10 ---> using "a6d895057d33423d936537196324b0ae6b29c3c416a86d619af7ffab6d54780a" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2023-09-12 18:42.10 ---> using "c8ff46adfeac738d7617a8f1519af408882364b6f9b4b67c465a381ce2c0d02a" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q 8ee6bf822f4e1daaa08726e322bf03c9f0251bdb"))
2023-09-12 18:42.10 ---> using "a4d4bc62f6d9af635a1084ae9978d6b8b32d332991de6dfe6d56687d10fefcaf" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2023-09-12 18:42.10 ---> using "afadee60f5277fb2c9ccf0ae7c1548965f28cbdb61ebd53e732d06c8444ddd34" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.12' '4.12.1'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.12.1"} | "ocaml-system" {= "4.12.1"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> installed ocaml-options-vanilla.1
-> retrieved ocaml-base-compiler.4.12.1  (cached)
-> installed ocaml-base-compiler.4.12.1
-> installed ocaml-config.2
-> installed ocaml.4.12.1
Done.
# Run eval $(opam env --switch=4.12) to update the current shell environment
2023-09-12 18:42.10 ---> using "24f43fb8f373431621aee4564195321d1394336298607a8774515f0577c85d86" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [195 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2023-09-12-1406.07-F-2023-09-07-0809.21.pdiff [298 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2023-09-12-1406.07-F-2023-09-07-0809.21.pdiff [298 kB]
- Fetched 557 kB in 2s (338 kB/s)
- Reading package lists...
- 
2023-09-12 18:42.10 ---> using "90be5296fe197b53d1ed413351e28a45066a2ed69c68fd397ffcf5db7dfbab06" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"argon2.1.0.1\"\
               \nopam install -vy \"argon2.1.0.1\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"argon2.1.0.1\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] argon2.1.0.1 is not installed.

Nothing to do.
The following actions will be performed:
=== install 12 packages
  - install argon2            1.0.1
  - install bigarray-compat   1.1.0  [required by ctypes]
  - install conf-libffi       2.0.0  [required by ctypes-foreign]
  - install conf-pkg-config   3      [required by ctypes-foreign]
  - install csexp             1.5.2  [required by dune-configurator]
  - install ctypes            0.21.1 [required by argon2]
  - install ctypes-foreign    0.21.1 [required by argon2]
  - install dune              3.10.0 [required by argon2]
  - install dune-configurator 3.10.0 [required by ctypes, ctypes-foreign]
  - install integers          0.7.0  [required by ctypes]
  - install result            1.5    [required by argon2]
  - install stdlib-shims      0.3.0  [required by integers]

The following system packages will first need to be installed:
    libffi-dev pkg-config

<><> Handling external dependencies <><><><><><><><><><><><><><><><><><><><><><>

opam believes some required external dependencies are missing. opam can:
> 1. Run apt-get to install them (may need root/sudo access)
  2. Display the recommended apt-get command and wait while you run it manually (e.g. in another terminal)
  3. Continue anyway, and, upon success, permanently register that this external dependency is present, but not detectable
  4. Abort the installation

[1/2/3/4] 1

+ /usr/bin/sudo "apt-get" "install" "-qq" "-yy" "libffi-dev" "pkg-config"
- debconf: delaying package configuration, since apt-utils is not installed
- Selecting previously unselected package libffi-dev:amd64.
- (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 18276 files and directories currently installed.)
- Preparing to unpack .../libffi-dev_3.4.4-1_amd64.deb ...
- Unpacking libffi-dev:amd64 (3.4.4-1) ...
- Selecting previously unselected package libpkgconf3:amd64.
- Preparing to unpack .../libpkgconf3_1.8.1-1_amd64.deb ...
- Unpacking libpkgconf3:amd64 (1.8.1-1) ...
- Selecting previously unselected package pkgconf-bin.
- Preparing to unpack .../pkgconf-bin_1.8.1-1_amd64.deb ...
- Unpacking pkgconf-bin (1.8.1-1) ...
- Selecting previously unselected package pkgconf:amd64.
- Preparing to unpack .../pkgconf_1.8.1-1_amd64.deb ...
- Unpacking pkgconf:amd64 (1.8.1-1) ...
- Selecting previously unselected package pkg-config:amd64.
- Preparing to unpack .../pkg-config_1.8.1-1_amd64.deb ...
- Unpacking pkg-config:amd64 (1.8.1-1) ...
- Setting up libffi-dev:amd64 (3.4.4-1) ...
- Setting up libpkgconf3:amd64 (1.8.1-1) ...
- Setting up pkgconf-bin (1.8.1-1) ...
- Setting up pkgconf:amd64 (1.8.1-1) ...
- Setting up pkg-config:amd64 (1.8.1-1) ...
- Processing triggers for libc-bin (2.37-7) ...

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
Processing  1/34: [argon2.1.0.1: http]
Processing  2/34: [argon2.1.0.1: http]
Processing  3/34: [argon2.1.0.1: http]
Processing  4/34: [argon2.1.0.1: http]
Processing  5/34: [argon2.1.0.1: http]
Processing  6/34: [argon2.1.0.1: http] [conf-pkg-config: pkg-config]
-> retrieved bigarray-compat.1.1.0  (cached)
Processing  7/34: [argon2.1.0.1: http] [conf-pkg-config: pkg-config]
-> retrieved csexp.1.5.2  (cached)
Processing  8/34: [argon2.1.0.1: http] [conf-pkg-config: pkg-config]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "pkg-config" "--help" (CWD=/home/opam/.opam/4.12/.opam-switch/build/conf-pkg-config.3)
- usage: pkgconf [OPTIONS] [LIBRARIES]
- 
- basic options:
- 
-   --help                            this message
-   --about                           print pkgconf version and license to stdout
-   --version                         print supported pkg-config version to stdout
-   --atleast-pkgconfig-version       check whether or not pkgconf is compatible
-                                     with a specified pkg-config version
-   --errors-to-stdout                print all errors on stdout instead of stderr
-   --print-errors                    ensure all errors are printed
-   --short-errors                    be less verbose about some errors
-   --silence-errors                  explicitly be silent about errors
-   --list-all                        list all known packages
-   --list-package-names              list all known package names
-   --simulate                        simulate walking the calculated dependency graph
-   --no-cache                        do not cache already seen packages when
-                                     walking the dependency graph
-   --log-file=filename               write an audit log to a specified file
-   --with-path=path                  adds a directory to the search path
-   --define-prefix                   override the prefix variable with one that is guessed based on
-                                     the location of the .pc file
-   --dont-define-prefix              do not override the prefix variable under any circumstances
-   --prefix-variable=varname         sets the name of the variable that pkgconf considers
-                                     to be the package prefix
-   --relocate=path                   relocates a path and exits (mostly for testsuite)
-   --dont-relocate-paths             disables path relocation support
- 
- cross-compilation personality support:
- 
-   --personality=triplet|filename    sets the personality to 'triplet' or a file named 'filename'
-   --dump-personality                dumps details concerning selected personality
- 
- checking specific pkg-config database entries:
- 
-   --atleast-version                 require a specific version of a module
-   --exact-version                   require an exact version of a module
-   --max-version                     require a maximum version of a module
-   --exists                          check whether or not a module exists
-   --uninstalled                     check whether or not an uninstalled module will be used
-   --no-uninstalled                  never use uninstalled modules when satisfying dependencies
-   --no-provides                     do not use 'provides' rules to resolve dependencies
-   --maximum-traverse-depth          maximum allowed depth for dependency graph
-   --static                          be more aggressive when computing dependency graph
-                                     (for static linking)
-   --shared                          use a simplified dependency graph (usually default)
-   --pure                            optimize a static dependency graph as if it were a normal
-                                     dependency graph
-   --env-only                        look only for package entries in PKG_CONFIG_PATH
-   --ignore-conflicts                ignore 'conflicts' rules in modules
-   --validate                        validate specific .pc files for correctness
- 
- querying specific pkg-config database fields:
- 
-   --define-variable=varname=value   define variable 'varname' as 'value'
-   --variable=varname                print specified variable entry to stdout
-   --cflags                          print required CFLAGS to stdout
-   --cflags-only-I                   print required include-dir CFLAGS to stdout
-   --cflags-only-other               print required non-include-dir CFLAGS to stdout
-   --libs                            print required linker flags to stdout
-   --libs-only-L                     print required LDPATH linker flags to stdout
-   --libs-only-l                     print required LIBNAME linker flags to stdout
-   --libs-only-other                 print required other linker flags to stdout
-   --print-requires                  print required dependency frameworks to stdout
-   --print-requires-private          print required dependency frameworks for static
-                                     linking to stdout
-   --print-provides                  print provided dependencies to stdout
-   --print-variables                 print all known variables in module to stdout
-   --digraph                         print entire dependency graph in graphviz 'dot' format
-   --keep-system-cflags              keep -I/usr/include entries in cflags output
-   --keep-system-libs                keep -L/lib:/lib/i386-linux-gnu:/lib/x86_64-linux-gnu:/lib/x86_64-linux-gnux32:/lib32:/libx32:/usr/lib:/usr/lib/i386-linux-gnu:/usr/lib/x86_64-linux-gnu:/usr/lib/x86_64-linux-gnux32:/usr/lib32:/usr/libx32 entries in libs output
-   --path                            show the exact filenames for any matching .pc files
-   --modversion                      print the specified module's version to stdout
-   --internal-cflags                 do not filter 'internal' cflags from output
- 
- filtering output:
- 
-   --msvc-syntax                     print translatable fragments in MSVC syntax
-   --fragment-filter=types           filter output fragments to the specified types
- 
- report bugs to <https://github.com/pkgconf/pkgconf/issues/new>.
-> compiled  conf-pkg-config.3
Processing  8/34: [argon2.1.0.1: http]
-> installed conf-pkg-config.3
Processing  9/34: [argon2.1.0.1: http]
Processing 10/34: [argon2.1.0.1: http] [conf-libffi: pkg-config libffi]
-> retrieved ctypes.0.21.1, ctypes-foreign.0.21.1  (cached)
Processing 11/34: [argon2.1.0.1: http] [conf-libffi: pkg-config libffi]
Processing 11/34: [conf-libffi: pkg-config libffi]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "pkg-config" "libffi" (CWD=/home/opam/.opam/4.12/.opam-switch/build/conf-libffi.2.0.0)
-> compiled  conf-libffi.2.0.0
Processing 11/34:
-> installed conf-libffi.2.0.0
Processing 12/34:
-> retrieved integers.0.7.0  (cached)
Processing 13/34:
-> retrieved argon2.1.0.1  (https://github.com/Khady/ocaml-argon2/releases/download/1.0.1/argon2-1.0.1.tbz)
Processing 14/34:
-> retrieved result.1.5  (cached)
-> retrieved stdlib-shims.0.3.0  (cached)
-> retrieved dune.3.10.0, dune-configurator.3.10.0  (cached)
Processing 15/34: [dune: ocaml 47]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "ocaml" "boot/bootstrap.ml" "-j" "47" (CWD=/home/opam/.opam/4.12/.opam-switch/build/dune.3.10.0)
- ocamlc -output-complete-exe -w -24 -g -o .duneboot.exe -I boot unix.cma boot/libs.ml boot/duneboot.ml
- ./.duneboot.exe -j 47
- 

Processing 15/34: [dune: ./_boot/dune.exe build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "./_boot/dune.exe" "build" "dune.install" "--release" "--profile" "dune-bootstrap" "-j" "47" (CWD=/home/opam/.opam/4.12/.opam-switch/build/dune.3.10.0)
-> compiled  dune.3.10.0
-> installed dune.3.10.0
Processing 17/34: [bigarray-compat: dune build]
Processing 18/34: [bigarray-compat: dune build] [csexp: dune build]
Processing 19/34: [bigarray-compat: dune build] [csexp: dune build] [result: dune build]
Processing 20/34: [bigarray-compat: dune build] [csexp: dune build] [result: dune build] [stdlib-shims: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "stdlib-shims" "-j" "47" (CWD=/home/opam/.opam/4.12/.opam-switch/build/stdlib-shims.0.3.0)
-> compiled  stdlib-shims.0.3.0
Processing 20/34: [bigarray-compat: dune build] [csexp: dune build] [result: dune build]
-> installed stdlib-shims.0.3.0
Processing 21/34: [bigarray-compat: dune build] [csexp: dune build] [result: dune build]
Processing 22/34: [bigarray-compat: dune build] [csexp: dune build] [integers: dune build] [result: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "csexp" "-j" "47" "@install" (CWD=/home/opam/.opam/4.12/.opam-switch/build/csexp.1.5.2)
-> compiled  csexp.1.5.2
Processing 22/34: [bigarray-compat: dune build] [integers: dune build] [result: dune build]
-> installed csexp.1.5.2
Processing 23/34: [bigarray-compat: dune build] [integers: dune build] [result: dune build]
Processing 24/34: [bigarray-compat: dune build] [dune-configurator: rm] [integers: dune build] [result: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "bigarray-compat" "-j" "47" (CWD=/home/opam/.opam/4.12/.opam-switch/build/bigarray-compat.1.1.0)
-> compiled  bigarray-compat.1.1.0
Processing 24/34: [dune-configurator: rm] [integers: dune build] [result: dune build]
-> installed bigarray-compat.1.1.0
Processing 25/34: [dune-configurator: rm] [integers: dune build] [result: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "result" "-j" "47" (CWD=/home/opam/.opam/4.12/.opam-switch/build/result.1.5)
-> compiled  result.1.5
Processing 25/34: [dune-configurator: rm] [integers: dune build]
-> installed result.1.5
Processing 26/34: [dune-configurator: rm] [integers: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "integers" "-j" "47" (CWD=/home/opam/.opam/4.12/.opam-switch/build/integers.0.7.0)
-> compiled  integers.0.7.0
Processing 26/34: [dune-configurator: rm]
-> installed integers.0.7.0
Processing 27/34: [dune-configurator: rm]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "rm" "-rf" "vendor/csexp" (CWD=/home/opam/.opam/4.12/.opam-switch/build/dune-configurator.3.10.0)
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "rm" "-rf" "vendor/pp" (CWD=/home/opam/.opam/4.12/.opam-switch/build/dune-configurator.3.10.0)
Processing 27/34: [dune-configurator: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "dune-configurator" "-j" "47" "@install" (CWD=/home/opam/.opam/4.12/.opam-switch/build/dune-configurator.3.10.0)
-> compiled  dune-configurator.3.10.0
-> installed dune-configurator.3.10.0
Processing 29/34: [ctypes: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ctypes" "-j" "47" "--promote-install-files=false" "@install" (CWD=/home/opam/.opam/4.12/.opam-switch/build/ctypes.0.21.1)
- (cd _build/default && /home/opam/.opam/4.12/bin/ocamlopt.opt -w -40 -g -I src/ctypes-top/.ctypes_top.objs/byte -I src/ctypes-top/.ctypes_top.objs/native -I /home/opam/.opam/4.12/lib/bigarray-compat -I /home/opam/.opam/4.12/lib/integers -I /home/opam/.opam/4.12/lib/ocaml/compiler-libs -I /home/opam/.opam/4.12/lib/stdlib-shims -I src/ctypes/.ctypes.objs/byte -I src/ctypes/.ctypes.objs/native -intf-suffix .ml -no-alias-deps -open Ctypes_top -o src/ctypes-top/.ctypes_top.objs/native/ctypes_top__Install_ctypes_printers.cmx -c -impl src/ctypes-top/install_ctypes_printers.ml)
- File "_none_", line 1:
- Warning 58 [no-cmx-file]: no cmx file was found in path for module Toploop, and its interface was not compiled with -opaque
Processing 29/34: [ctypes: dune install]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "install" "-p" "ctypes" "--create-install-files" "ctypes" (CWD=/home/opam/.opam/4.12/.opam-switch/build/ctypes.0.21.1)
-> compiled  ctypes.0.21.1
-> installed ctypes.0.21.1
Processing 31/34: [ctypes-foreign: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ctypes-foreign" "-j" "47" "--promote-install-files=false" "@install" (CWD=/home/opam/.opam/4.12/.opam-switch/build/ctypes-foreign.0.21.1)
Processing 31/34: [ctypes-foreign: dune install]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "install" "-p" "ctypes-foreign" "--create-install-files" "ctypes-foreign" (CWD=/home/opam/.opam/4.12/.opam-switch/build/ctypes-foreign.0.21.1)
-> compiled  ctypes-foreign.0.21.1
-> installed ctypes-foreign.0.21.1
Processing 33/34: [argon2: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "argon2" "-j" "47" "@install" (CWD=/home/opam/.opam/4.12/.opam-switch/build/argon2.1.0.1)
-> compiled  argon2.1.0.1
-> installed argon2.1.0.1
Done.
# Run eval $(opam env) to update the current shell environment
2023-09-12 18:43.56 ---> saved as "18823c31977443bca9ee1775292a9722bce7a216af1c5399970c02cebcad33a9"
Job succeeded