OCamllabs icon Home|Differences with the last checks|Previous runs


Building on asteria.caelum.ci.dev

(from ocaml/opam:debian-unstable@sha256:9018ce829df92c35f88e7c207d161758bf85fa58146b7fb83c1e7bdd52796af2)
2023-09-12 20:06.40 ---> using "a6d895057d33423d936537196324b0ae6b29c3c416a86d619af7ffab6d54780a" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2023-09-12 20:06.40 ---> using "c8ff46adfeac738d7617a8f1519af408882364b6f9b4b67c465a381ce2c0d02a" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q 8ee6bf822f4e1daaa08726e322bf03c9f0251bdb"))
2023-09-12 20:06.40 ---> using "a4d4bc62f6d9af635a1084ae9978d6b8b32d332991de6dfe6d56687d10fefcaf" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2023-09-12 20:06.40 ---> using "afadee60f5277fb2c9ccf0ae7c1548965f28cbdb61ebd53e732d06c8444ddd34" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '5.1' '5.1.0~rc1'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "5.1.0~rc1"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> installed ocaml-options-vanilla.1
-> retrieved ocaml-base-compiler.5.1.0~rc1  (cached)
-> installed ocaml-base-compiler.5.1.0~rc1
-> installed ocaml-config.3
-> installed ocaml.5.1.0
-> installed base-domains.base
-> installed base-nnp.base
Done.
# Run eval $(opam env --switch=5.1) to update the current shell environment
2023-09-12 20:06.40 ---> using "89304a9184d5a1f0fe98c2032e3248547a0d8320d49a9ae046f5209a569de9e5" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [195 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2023-09-12-1406.07-F-2023-09-07-0809.21.pdiff [298 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2023-09-12-1406.07-F-2023-09-07-0809.21.pdiff [298 kB]
- Fetched 557 kB in 1s (410 kB/s)
- Reading package lists...
2023-09-12 20:06.40 ---> using "bb957fcb06aa738457212b0a8dda0ac4441ec8116980b27212f5ac77883e3b19" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"bap-primus-lisp.2.5.0\"\
               \nopam install -vy \"bap-primus-lisp.2.5.0\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"bap-primus-lisp.2.5.0\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] bap-primus-lisp.2.5.0 is not installed.

Nothing to do.
[ERROR] Package conflict!
  * No agreement on the version of ocaml:
    - (invariant) -> ocaml-base-compiler = 5.1.0~rc1 -> ocaml = 5.1.0
    - bap-primus-lisp >= 2.5.0 -> bitvec >= 2.5.0 -> oasis >= 0.4.7 -> ocamlmod -> ocaml < 4.06.0
    You can temporarily relax the switch invariant with `--update-invariant'
  * No agreement on the version of ocaml-base-compiler:
    - (invariant) -> ocaml-base-compiler = 5.1.0~rc1
    - bap-primus-lisp >= 2.5.0 -> bitvec >= 2.5.0 -> oasis >= 0.4.7 -> ocamlmod -> ocaml < 4.06.0 -> ocaml-base-compiler = 3.09.1
  * Missing dependency:
    - bap-primus-lisp >= 2.5.0 -> bitvec >= 2.5.0 -> oasis >= 0.4.7 -> ocamlmod -> ocaml < 4.06.0 -> ocaml-variants -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'

No solution found, exiting
'opam install -vy bap-primus-lisp.2.5.0' failed.
"/usr/bin/env" "bash" "-c" "
opam remove -y "bap-primus-lisp.2.5.0"
opam install -vy "bap-primus-lisp.2.5.0"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "bap-primus-lisp.2.5.0" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed