OCamllabs icon Home|Differences with the last checks|Previous runs


Building on doris.caelum.ci.dev

(from ocaml/opam:debian-unstable)
Unable to find image 'ocaml/opam:debian-unstable' locally
debian-unstable: Pulling from ocaml/opam
67d782890fa0: Pulling fs layer
67d782890fa0: Verifying Checksum
67d782890fa0: Download complete
67d782890fa0: Pull complete
Digest: sha256:f95f89879cdedf718c3bc0bd75279248897ab332e434605f8ab0f32b62fd9ab4
Status: Downloaded newer image for ocaml/opam:debian-unstable
2024-02-07 14:25.14 ---> using "0acd5aeaa8f7bc314514d9795d14a7f12ec72a6a5b11c5904350189734c6859b" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2024-02-07 14:25.14 ---> using "65c3237f501f7c75f3828458ecf2342bc41c98aaef8c6a7fd82bf46a58cb258c" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q e587a9437d8bb41f7c0fda20b186c5c0d5178307"))
2024-02-07 14:25.14 ---> using "ba4ab7a29ffbb7242a0f4a23f5d47ab4641ccdfb0e44130f467a231865081ad1" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2024-02-07 14:25.14 ---> using "3ee1eaa848e0a3884e82cc07c535ab5dc8f986c3607c006421763988fa5c48fb" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.08' '4.08.1'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.08.1"} | "ocaml-system" {= "4.08.1"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-base-compiler.4.08.1  (cached)
-> installed ocaml-base-compiler.4.08.1
-> installed ocaml-config.1
-> installed ocaml.4.08.1
Done.
# Run eval $(opam env --switch=4.08) to update the current shell environment
2024-02-07 14:25.14 ---> using "f7977e6d5478cddbb129b6f40d6e1ebae54459499cfe6d60553be5ded1edd558" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [198 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-02-07-0807.59-F-2024-02-02-1408.05.pdiff [256 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-02-07-0807.59-F-2024-02-02-1408.05.pdiff [256 kB]
- Fetched 518 kB in 1s (361 kB/s)
- Reading package lists...
- 
2024-02-07 14:25.14 ---> using "a635887ec761c7137c42ffb0b59a8727e649e63bbd1944434640c56bd51a577d" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"conf-arb.1\"\
               \nopam install -vy \"conf-arb.1\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"conf-arb.1\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
Nothing to do.
[NOTE] conf-arb.1 is not installed.

The following actions will be performed:
=== install 1 package
  - install conf-arb 1

The following system packages will first need to be installed:
    libflint-arb-dev

<><> Handling external dependencies <><><><><><><><><><><><><><><><><><><><><><>

opam believes some required external dependencies are missing. opam can:
> 1. Run apt-get to install them (may need root/sudo access)
  2. Display the recommended apt-get command and wait while you run it manually (e.g. in another terminal)
  3. Continue anyway, and, upon success, permanently register that this external dependency is present, but not detectable
  4. Abort the installation

[1/2/3/4] 1

+ /usr/bin/sudo "apt-get" "install" "-qq" "-yy" "libflint-arb-dev"
- debconf: delaying package configuration, since apt-utils is not installed
- Selecting previously unselected package libgf2x3:amd64.
- (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 19832 files and directories currently installed.)
- Preparing to unpack .../0-libgf2x3_1.3.0-2_amd64.deb ...
- Unpacking libgf2x3:amd64 (1.3.0-2) ...
- Selecting previously unselected package libntl44:amd64.
- Preparing to unpack .../1-libntl44_11.5.1-1+b2_amd64.deb ...
- Unpacking libntl44:amd64 (11.5.1-1+b2) ...
- Selecting previously unselected package libflint17:amd64.
- Preparing to unpack .../2-libflint17_2.9.0-5_amd64.deb ...
- Unpacking libflint17:amd64 (2.9.0-5) ...
- Selecting previously unselected package libflint-arb2:amd64.
- Preparing to unpack .../3-libflint-arb2_1%3a2.23.0-1+b1_amd64.deb ...
- Unpacking libflint-arb2:amd64 (1:2.23.0-1+b1) ...
- Selecting previously unselected package libflint18:amd64.
- Preparing to unpack .../4-libflint18_3.0.1-2_amd64.deb ...
- Unpacking libflint18:amd64 (3.0.1-2) ...
- Selecting previously unselected package libgmpxx4ldbl:amd64.
- Preparing to unpack .../5-libgmpxx4ldbl_2%3a6.3.0+dfsg-2_amd64.deb ...
- Unpacking libgmpxx4ldbl:amd64 (2:6.3.0+dfsg-2) ...
- Selecting previously unselected package libgmp-dev:amd64.
- Preparing to unpack .../6-libgmp-dev_2%3a6.3.0+dfsg-2_amd64.deb ...
- Unpacking libgmp-dev:amd64 (2:6.3.0+dfsg-2) ...
- Selecting previously unselected package libmpfr-dev:amd64.
- Preparing to unpack .../7-libmpfr-dev_4.2.1-1_amd64.deb ...
- Unpacking libmpfr-dev:amd64 (4.2.1-1) ...
- Selecting previously unselected package libflint-dev.
- Preparing to unpack .../8-libflint-dev_3.0.1-2_amd64.deb ...
- Unpacking libflint-dev (3.0.1-2) ...
- Selecting previously unselected package libflint-arb-dev:amd64.
- Preparing to unpack .../9-libflint-arb-dev_1%3a2.23.0-1+b1_amd64.deb ...
- Unpacking libflint-arb-dev:amd64 (1:2.23.0-1+b1) ...
- Setting up libgf2x3:amd64 (1.3.0-2) ...
- Setting up libgmpxx4ldbl:amd64 (2:6.3.0+dfsg-2) ...
- Setting up libflint18:amd64 (3.0.1-2) ...
- Setting up libntl44:amd64 (11.5.1-1+b2) ...
- Setting up libgmp-dev:amd64 (2:6.3.0+dfsg-2) ...
- Setting up libflint17:amd64 (2.9.0-5) ...
- Setting up libmpfr-dev:amd64 (4.2.1-1) ...
- Setting up libflint-arb2:amd64 (1:2.23.0-1+b1) ...
- Setting up libflint-dev (3.0.1-2) ...
- Setting up libflint-arb-dev:amd64 (1:2.23.0-1+b1) ...
- Processing triggers for libc-bin (2.37-15) ...

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
Processing  2/3: [conf-arb: sh echo "#include  \"arb.h\"" > test.c]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "sh" "-exc" "echo \"#include  \\\"arb.h\\\"\" > test.c" (CWD=/home/opam/.opam/4.08/.opam-switch/build/conf-arb.1)
- + echo #include  "arb.h"
Processing  2/3: [conf-arb: sh]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "sh" "-exc" "cc -c $CFLAGS -I/usr/local/include test.c" (CWD=/home/opam/.opam/4.08/.opam-switch/build/conf-arb.1)
- + cc -c -I/usr/local/include test.c
- In file included from /usr/include/mag.h:25,
-                  from /usr/include/arb.h:22,
-                  from test.c:1:
- /usr/include/fmpz_extras.h:208:1: error: static declaration of 'fmpz_ui_pow_ui' follows non-static declaration
-   208 | fmpz_ui_pow_ui(fmpz_t x, ulong b, ulong e)
-       | ^~~~~~~~~~~~~~
- In file included from /usr/include/mag.h:24:
- /usr/include/flint/fmpz.h:422:6: note: previous declaration of 'fmpz_ui_pow_ui' with type 'void(fmpz *, mp_limb_t,  mp_limb_t)' {aka 'void(long int *, long unsigned int,  long unsigned int)'}
-   422 | void fmpz_ui_pow_ui(fmpz_t x, ulong b, ulong e);
-       |      ^~~~~~~~~~~~~~
- In file included from /usr/include/mag.h:501:
- /usr/include/fmpr.h: In function 'fmpr_set_ui':
- /usr/include/fmpr.h:360:11: error: 'count_trailing_zeros' is deprecated. Use 'flint_ctz' instead.
-   360 |         count_trailing_zeros(b, c);
-       |           ^~~~~~~~~~~~~~~~~~~~~~~~~                                       
- /usr/include/fmpr.h: In function 'fmpr_set_si':
- /usr/include/fmpr.h:375:11: error: 'count_trailing_zeros' is deprecated. Use 'flint_ctz' instead.
-   375 |         count_trailing_zeros(b, c);
-       |           ^~~~~~~~~~~~~~~~~~~~~~~~~                                       
- In file included from /usr/include/arb.h:23:
- /usr/include/arf.h: In function 'arf_init_set_ui':
- /usr/include/arf.h:435:11: error: 'count_leading_zeros' is deprecated. Use 'flint_clz' instead.
-   435 |         count_leading_zeros(c, v);
-       |           ^~~~~~~~~~~~~~~~~~~~~~~~                                       
- /usr/include/arf.h: In function 'arf_set_ui':
- /usr/include/arf.h:467:11: error: 'count_leading_zeros' is deprecated. Use 'flint_clz' instead.
-   467 |         count_leading_zeros(c, v);
-       |           ^~~~~~~~~~~~~~~~~~~~~~~~                                       
- /usr/include/arf.h: In function 'arf_bits':
- /usr/include/arf.h:656:11: error: 'count_trailing_zeros' is deprecated. Use 'flint_ctz' instead.
-   656 |         count_trailing_zeros(c, xp[0]);
-       |           ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~                                   
- /usr/include/arb.h: In function '_arb_mpn_leading_zeros':
- /usr/include/arb.h:1041:11: error: 'count_leading_zeros' is deprecated. Use 'flint_clz' instead.
-  1041 |             count_leading_zeros(bits, t);
-       |           ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~                                
[ERROR] The compilation of conf-arb.1 failed at "sh -exc cc -c $CFLAGS -I/usr/local/include test.c".

#=== ERROR while compiling conf-arb.1 =========================================#
# context              2.2.0~beta2~dev | linux/x86_64 | ocaml-base-compiler.4.08.1 | file:///home/opam/opam-repository
# path                 ~/.opam/4.08/.opam-switch/build/conf-arb.1
# command              ~/.opam/opam-init/hooks/sandbox.sh build sh -exc cc -c $CFLAGS -I/usr/local/include test.c
# exit-code            1
# env-file             ~/.opam/log/conf-arb-8-ce0894.env
# output-file          ~/.opam/log/conf-arb-8-ce0894.out
### output ###
# + cc -c -I/usr/local/include test.c
# In file included from /usr/include/mag.h:25,
#                  from /usr/include/arb.h:22,
#                  from test.c:1:
# /usr/include/fmpz_extras.h:208:1: error: static declaration of 'fmpz_ui_pow_ui' follows non-static declaration
#   208 | fmpz_ui_pow_ui(fmpz_t x, ulong b, ulong e)
#       | ^~~~~~~~~~~~~~
# In file included from /usr/include/mag.h:24:
# /usr/include/flint/fmpz.h:422:6: note: previous declaration of 'fmpz_ui_pow_ui' with type 'void(fmpz *, mp_limb_t,  mp_limb_t)' {aka 'void(long int *, long unsigned int,  long unsigned int)'}
#   422 | void fmpz_ui_pow_ui(fmpz_t x, ulong b, ulong e);
#       |      ^~~~~~~~~~~~~~
# In file included from /usr/include/mag.h:501:
# /usr/include/fmpr.h: In function 'fmpr_set_ui':
# /usr/include/fmpr.h:360:11: error: 'count_trailing_zeros' is deprecated. Use 'flint_ctz' instead.
#   360 |         count_trailing_zeros(b, c);
#       |           ^~~~~~~~~~~~~~~~~~~~~~~~~                                       
# /usr/include/fmpr.h: In function 'fmpr_set_si':
# /usr/include/fmpr.h:375:11: error: 'count_trailing_zeros' is deprecated. Use 'flint_ctz' instead.
#   375 |         count_trailing_zeros(b, c);
#       |           ^~~~~~~~~~~~~~~~~~~~~~~~~                                       
# In file included from /usr/include/arb.h:23:
# /usr/include/arf.h: In function 'arf_init_set_ui':
# /usr/include/arf.h:435:11: error: 'count_leading_zeros' is deprecated. Use 'flint_clz' instead.
#   435 |         count_leading_zeros(c, v);
#       |           ^~~~~~~~~~~~~~~~~~~~~~~~                                       
# /usr/include/arf.h: In function 'arf_set_ui':
# /usr/include/arf.h:467:11: error: 'count_leading_zeros' is deprecated. Use 'flint_clz' instead.
#   467 |         count_leading_zeros(c, v);
#       |           ^~~~~~~~~~~~~~~~~~~~~~~~                                       
# /usr/include/arf.h: In function 'arf_bits':
# /usr/include/arf.h:656:11: error: 'count_trailing_zeros' is deprecated. Use 'flint_ctz' instead.
#   656 |         count_trailing_zeros(c, xp[0]);
#       |           ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~                                   
# /usr/include/arb.h: In function '_arb_mpn_leading_zeros':
# /usr/include/arb.h:1041:11: error: 'count_leading_zeros' is deprecated. Use 'flint_clz' instead.
#  1041 |             count_leading_zeros(bits, t);
#       |           ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~                                



<><> Error report <><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><>
+- The following actions failed
| - build conf-arb 1
+- 
- No changes have been performed
# Run eval $(opam env) to update the current shell environment
'opam install -vy conf-arb.1' failed.
"/usr/bin/env" "bash" "-c" "
opam remove -y "conf-arb.1"
opam install -vy "conf-arb.1"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "conf-arb.1" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 31
Failed: Build failed