OCamllabs icon Home|Differences with the last checks|Previous runs


Building on x86-bm-c8.sw.ocaml.org

(from ocaml/opam:debian-unstable)
Unable to find image 'ocaml/opam:debian-unstable' locally
debian-unstable: Pulling from ocaml/opam
67d782890fa0: Pulling fs layer
67d782890fa0: Verifying Checksum
67d782890fa0: Download complete
67d782890fa0: Pull complete
Digest: sha256:f95f89879cdedf718c3bc0bd75279248897ab332e434605f8ab0f32b62fd9ab4
Status: Downloaded newer image for ocaml/opam:debian-unstable
2024-02-07 14:14.52 ---> using "0acd5aeaa8f7bc314514d9795d14a7f12ec72a6a5b11c5904350189734c6859b" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2024-02-07 14:14.52 ---> using "65c3237f501f7c75f3828458ecf2342bc41c98aaef8c6a7fd82bf46a58cb258c" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q e587a9437d8bb41f7c0fda20b186c5c0d5178307"))
2024-02-07 14:14.52 ---> using "ba4ab7a29ffbb7242a0f4a23f5d47ab4641ccdfb0e44130f467a231865081ad1" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2024-02-07 14:14.52 ---> using "3ee1eaa848e0a3884e82cc07c535ab5dc8f986c3607c006421763988fa5c48fb" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.09' '4.09.1'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.09.1"} | "ocaml-system" {= "4.09.1"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-base-compiler.4.09.1  (https://github.com/ocaml/ocaml/archive/4.09.1.tar.gz)
-> installed ocaml-base-compiler.4.09.1
-> installed ocaml-config.1
-> installed ocaml.4.09.1
Done.
# Run eval $(opam env --switch=4.09) to update the current shell environment
2024-02-07 14:14.52 ---> using "ccf37499373be7210dadd0f6c2f0835cf990be35a10ac526f54b4c0f289433bb" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [198 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-02-07-0807.59-F-2024-02-02-1408.05.pdiff [256 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-02-07-0807.59-F-2024-02-02-1408.05.pdiff [256 kB]
- Fetched 518 kB in 3s (155 kB/s)
- Reading package lists...
- 
2024-02-07 14:14.52 ---> using "84a941c42fbf762849d63927a0f2ba1a5543bee2b2450914faa3177716bbd1fb" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"colibri2.0.4\"\
               \nopam install -vy \"colibri2.0.4\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"colibri2.0.4\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] colibri2.0.4 is not installed.

Nothing to do.
[ERROR] Package conflict!
  * No agreement on the version of ocaml:
    - (invariant) -> ocaml-base-compiler = 4.09.1 -> ocaml = 4.09.1
    - colibri2 >= 0.4 -> ocaml >= 4.12
    You can temporarily relax the switch invariant with `--update-invariant'
  * No agreement on the version of ocaml-base-compiler:
    - (invariant) -> ocaml-base-compiler = 4.09.1
    - colibri2 >= 0.4 -> ocaml >= 4.12 -> ocaml-base-compiler >= 4.12.0~
  * Missing dependency:
    - colibri2 >= 0.4 -> ocaml >= 4.12 -> ocaml-variants < 5.3.1~ -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'

No solution found, exiting
'opam install -vy colibri2.0.4' failed.
"/usr/bin/env" "bash" "-c" "
opam remove -y "colibri2.0.4"
opam install -vy "colibri2.0.4"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "colibri2.0.4" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed