OCamllabs icon Home|Differences with the last checks|Previous runs


Building on c2-2.equinix.ci.dev

(from ocaml/opam:debian-unstable)
Unable to find image 'ocaml/opam:debian-unstable' locally
debian-unstable: Pulling from ocaml/opam
Digest: sha256:f95f89879cdedf718c3bc0bd75279248897ab332e434605f8ab0f32b62fd9ab4
Status: Downloaded newer image for ocaml/opam:debian-unstable
2024-02-07 14:18.39 ---> using "0acd5aeaa8f7bc314514d9795d14a7f12ec72a6a5b11c5904350189734c6859b" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2024-02-07 14:18.39 ---> using "5a48029448e4c4dcb1058375cea3e3790f5832d398adedd7742173873baea387" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q e587a9437d8bb41f7c0fda20b186c5c0d5178307"))
2024-02-07 14:18.39 ---> using "35363af8e7fbced5953ca14e49e69607a924438d7a8f346e5570189952d702ed" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2024-02-07 14:18.39 ---> using "476598702655138b5abc5c5a972ae2f5f6c1035470956308228445d2d0759538" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.09' '4.09.1'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.09.1"} | "ocaml-system" {= "4.09.1"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-base-compiler.4.09.1  (https://github.com/ocaml/ocaml/archive/4.09.1.tar.gz)
-> installed ocaml-base-compiler.4.09.1
-> installed ocaml-config.1
-> installed ocaml.4.09.1
Done.
# Run eval $(opam env --switch=4.09) to update the current shell environment
2024-02-07 14:18.39 ---> using "7b82ee4cd5d24b53c9e247c64d150d749ec375e10a8abc8ce87eda69c5b48477" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [198 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-02-07-0807.59-F-2024-02-02-1408.05.pdiff [256 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-02-07-0807.59-F-2024-02-02-1408.05.pdiff [256 kB]
- Fetched 518 kB in 2s (289 kB/s)
- Reading package lists...
- 
2024-02-07 14:18.39 ---> using "fb847f0c0583006790c99c9f143d039dc988f9703934fd7d4c0f8c2aceb1ef02" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"conduit-async.6.2.1\"\
               \nopam install -vy \"conduit-async.6.2.1\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"conduit-async.6.2.1\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
Nothing to do.
[NOTE] conduit-async.6.2.1 is not installed.

[ERROR] Package conflict!
  * No agreement on the version of ocaml:
    - (invariant) -> ocaml-base-compiler = 4.09.1 -> ocaml = 4.09.1
    - conduit-async >= 6.2.1 -> core >= v0.15.0 -> ocaml >= 4.11.0
    You can temporarily relax the switch invariant with `--update-invariant'
  * No agreement on the version of ocaml-base-compiler:
    - (invariant) -> ocaml-base-compiler = 4.09.1
    - conduit-async >= 6.2.1 -> core >= v0.15.0 -> ocaml >= 4.11.0 -> ocaml-base-compiler = 4.11.0
  * Missing dependency:
    - conduit-async >= 6.2.1 -> core >= v0.15.0 -> ocaml >= 4.11.0 -> ocaml-variants < 4.11.4~ -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'
  * Missing dependency:
    - conduit-async >= 6.2.1 -> core >= v0.15.0 -> ocaml >= 4.11.0 -> ocaml-variants >= 4.11.0 -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'

No solution found, exiting
'opam install -vy conduit-async.6.2.1' failed.
"/bin/bash" "-c" "
opam remove -y "conduit-async.6.2.1"
opam install -vy "conduit-async.6.2.1"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "conduit-async.6.2.1" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed