OCamllabs icon Home|Differences with the last checks|Previous runs


Building on x86-bm-c6.sw.ocaml.org

(from ocaml/opam:debian-unstable)
Unable to find image 'ocaml/opam:debian-unstable' locally
debian-unstable: Pulling from ocaml/opam
13dc3ce10855: Pulling fs layer
13dc3ce10855: Verifying Checksum
13dc3ce10855: Download complete
13dc3ce10855: Pull complete
Digest: sha256:6dbb1e6b4b767fa11369e17e0d90d7f294f4268e08e4aad51632f1951e9764d2
Status: Downloaded newer image for ocaml/opam:debian-unstable
2024-03-28 10:42.28 ---> using "0acd5aeaa8f7bc314514d9795d14a7f12ec72a6a5b11c5904350189734c6859b" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2024-03-28 10:42.28 ---> using "65c3237f501f7c75f3828458ecf2342bc41c98aaef8c6a7fd82bf46a58cb258c" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q fe00df86c9b4d714ec1d1c3b5fad3b9485967f6e"))
2024-03-28 10:42.28 ---> using "1969b865dc0121544b5da025cca93a3017a18292e4eb09b2cafbb1c174a48136" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2024-03-28 10:42.28 ---> using "8e73b7cc41b9f391e9c71cd803608f55cb84b633abc3d24bdb07c4d652d870c1" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.08' '4.08.1'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.08.1"} | "ocaml-system" {= "4.08.1"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-base-compiler.4.08.1  (cached)
-> installed ocaml-base-compiler.4.08.1
-> installed ocaml-config.1
-> installed ocaml.4.08.1
Done.
# Run eval $(opam env --switch=4.08) to update the current shell environment
2024-03-28 10:42.28 ---> using "9d545c1305e07d1e00b27f173ab8ac143c009406bae5ec190385179bb16c3260" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [198 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-03-28-0807.42-F-2024-03-21-1407.24.pdiff [602 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-03-28-0807.42-F-2024-03-21-1407.24.pdiff [602 kB]
- Fetched 864 kB in 4s (192 kB/s)
- Reading package lists...
- 
2024-03-28 10:42.28 ---> using "c74f41a695421ca47d879cd963d39669e67ca44093569383bd79513001d14f33" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"ansi.0.7.0\"\
               \nopam install -vy \"ansi.0.7.0\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"ansi.0.7.0\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] ansi.0.7.0 is not installed.

Nothing to do.
[ERROR] Package conflict!
  * No agreement on the version of ocaml:
    - (invariant) -> ocaml-base-compiler = 4.08.1 -> ocaml = 4.08.1
    - ansi >= 0.7.0 -> ocaml >= 4.10.0
    You can temporarily relax the switch invariant with `--update-invariant'
  * No agreement on the version of ocaml-base-compiler:
    - (invariant) -> ocaml-base-compiler = 4.08.1
    - ansi >= 0.7.0 -> ocaml >= 4.10.0 -> ocaml-base-compiler = 4.11.0
  * Missing dependency:
    - ansi >= 0.7.0 -> ocaml >= 4.10.0 -> ocaml-variants < 5.3.1~ -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'
  * Missing dependency:
    - ansi >= 0.7.0 -> ocaml >= 4.10.0 -> ocaml-variants >= 4.10.2 -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'

No solution found, exiting
'opam install -vy ansi.0.7.0' failed.
"/usr/bin/env" "bash" "-c" "
opam remove -y "ansi.0.7.0"
opam install -vy "ansi.0.7.0"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "ansi.0.7.0" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed