OCamllabs icon Home|Differences with the last checks|Previous runs


Building on x86-bm-c5.sw.ocaml.org

(from ocaml/opam:debian-unstable)
Unable to find image 'ocaml/opam:debian-unstable' locally
debian-unstable: Pulling from ocaml/opam
Digest: sha256:6dbb1e6b4b767fa11369e17e0d90d7f294f4268e08e4aad51632f1951e9764d2
Status: Downloaded newer image for ocaml/opam:debian-unstable
2024-03-28 17:16.17 ---> using "0acd5aeaa8f7bc314514d9795d14a7f12ec72a6a5b11c5904350189734c6859b" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2024-03-28 17:16.17 ---> using "65c3237f501f7c75f3828458ecf2342bc41c98aaef8c6a7fd82bf46a58cb258c" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q fe00df86c9b4d714ec1d1c3b5fad3b9485967f6e"))
2024-03-28 17:16.17 ---> using "1969b865dc0121544b5da025cca93a3017a18292e4eb09b2cafbb1c174a48136" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2024-03-28 17:16.17 ---> using "8e73b7cc41b9f391e9c71cd803608f55cb84b633abc3d24bdb07c4d652d870c1" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.13' '4.13.1'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.13.1"} | "ocaml-system" {= "4.13.1"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> installed ocaml-options-vanilla.1
-> retrieved ocaml-base-compiler.4.13.1  (cached)
-> installed ocaml-base-compiler.4.13.1
-> installed ocaml-config.2
-> installed ocaml.4.13.1
Done.
# Run eval $(opam env --switch=4.13) to update the current shell environment
2024-03-28 17:16.17 ---> using "be1cd69d23b2c223cbd3ccc584ce51e7737e69969da4aeb11f6b19eb4c7ea99f" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [198 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-03-28-1405.05-F-2024-03-21-1407.24.pdiff [616 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-03-28-1405.05-F-2024-03-21-1407.24.pdiff [616 kB]
- Fetched 877 kB in 4s (211 kB/s)
- Reading package lists...
- 
2024-03-28 17:16.17 ---> using "7738adb715a4fd0c50a3f4cc6b9f367e83bafb9fec2e0b1efe1f64eb18d87c8a" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"batsat.0.7\"\
               \nopam install -vy \"batsat.0.7\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"batsat.0.7\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] batsat.0.7 is not installed.

Nothing to do.
The following actions will be performed:
=== install 3 packages
  - install batsat         0.7
  - install conf-rust-2018 1      [required by batsat]
  - install dune           3.14.2 [required by batsat]

The following system packages will first need to be installed:
    cargo

<><> Handling external dependencies <><><><><><><><><><><><><><><><><><><><><><>

opam believes some required external dependencies are missing. opam can:
> 1. Run apt-get to install them (may need root/sudo access)
  2. Display the recommended apt-get command and wait while you run it manually (e.g. in another terminal)
  3. Continue anyway, and, upon success, permanently register that this external dependency is present, but not detectable
  4. Abort the installation

[1/2/3/4] 1

+ /usr/bin/sudo "apt-get" "install" "-qq" "-yy" "cargo"
- debconf: delaying package configuration, since apt-utils is not installed
- dpkg: libcurl3-gnutls:amd64: dependency problems, but removing anyway as you requested:
-  git depends on libcurl3-gnutls (>= 7.56.1).
- 
- (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 19678 files and directories currently installed.)
- Removing libcurl3-gnutls:amd64 (8.6.0-3) ...
- Selecting previously unselected package libcurl3t64-gnutls:amd64.
- (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 19670 files and directories currently installed.)
- Preparing to unpack .../libcurl3t64-gnutls_8.7.1-1_amd64.deb ...
- Unpacking libcurl3t64-gnutls:amd64 (8.7.1-1) ...
- Selecting previously unselected package libpipeline1:amd64.
- Preparing to unpack .../libpipeline1_1.5.7-1+b2_amd64.deb ...
- Unpacking libpipeline1:amd64 (1.5.7-1+b2) ...
- Selecting previously unselected package binfmt-support.
- Preparing to unpack .../binfmt-support_2.2.2-6_amd64.deb ...
- Unpacking binfmt-support (2.2.2-6) ...
- Selecting previously unselected package libpython3.11-minimal:amd64.
- Preparing to unpack .../libpython3.11-minimal_3.11.8-3+b2_amd64.deb ...
- Unpacking libpython3.11-minimal:amd64 (3.11.8-3+b2) ...
- Selecting previously unselected package python3.11-minimal.
- Preparing to unpack .../python3.11-minimal_3.11.8-3+b2_amd64.deb ...
- Unpacking python3.11-minimal (3.11.8-3+b2) ...
- Setting up libpython3.11-minimal:amd64 (3.11.8-3+b2) ...
- Setting up python3.11-minimal (3.11.8-3+b2) ...
- Selecting previously unselected package python3-minimal.
- (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 20010 files and directories currently installed.)
- Preparing to unpack .../python3-minimal_3.11.8-1_amd64.deb ...
- Unpacking python3-minimal (3.11.8-1) ...
- Selecting previously unselected package media-types.
- Preparing to unpack .../media-types_10.1.0_all.deb ...
- Unpacking media-types (10.1.0) ...
- Selecting previously unselected package libpython3.11-stdlib:amd64.
- Preparing to unpack .../libpython3.11-stdlib_3.11.8-3+b2_amd64.deb ...
- Unpacking libpython3.11-stdlib:amd64 (3.11.8-3+b2) ...
- Selecting previously unselected package python3.11.
- Preparing to unpack .../python3.11_3.11.8-3+b2_amd64.deb ...
- Unpacking python3.11 (3.11.8-3+b2) ...
- Selecting previously unselected package libpython3-stdlib:amd64.
- Preparing to unpack .../libpython3-stdlib_3.11.8-1_amd64.deb ...
- Unpacking libpython3-stdlib:amd64 (3.11.8-1) ...
- Setting up python3-minimal (3.11.8-1) ...
- Selecting previously unselected package python3.
- (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 20436 files and directories currently installed.)
- Preparing to unpack .../00-python3_3.11.8-1_amd64.deb ...
- Unpacking python3 (3.11.8-1) ...
- Selecting previously unselected package libhttp-parser2.9:amd64.
- Preparing to unpack .../01-libhttp-parser2.9_2.9.4-6+b1_amd64.deb ...
- Unpacking libhttp-parser2.9:amd64 (2.9.4-6+b1) ...
- Selecting previously unselected package libmbedcrypto7t64:amd64.
- Preparing to unpack .../02-libmbedcrypto7t64_2.28.7-1.1_amd64.deb ...
- Unpacking libmbedcrypto7t64:amd64 (2.28.7-1.1) ...
- Selecting previously unselected package libmbedx509-1t64:amd64.
- Preparing to unpack .../03-libmbedx509-1t64_2.28.7-1.1_amd64.deb ...
- Unpacking libmbedx509-1t64:amd64 (2.28.7-1.1) ...
- Selecting previously unselected package libmbedtls14t64:amd64.
- Preparing to unpack .../04-libmbedtls14t64_2.28.7-1.1_amd64.deb ...
- Unpacking libmbedtls14t64:amd64 (2.28.7-1.1) ...
- Selecting previously unselected package libgit2-1.7:amd64.
- Preparing to unpack .../05-libgit2-1.7_1.7.2+ds-1+b1_amd64.deb ...
- Unpacking libgit2-1.7:amd64 (1.7.2+ds-1+b1) ...
- Selecting previously unselected package libicu72:amd64.
- Preparing to unpack .../06-libicu72_72.1-4+b1_amd64.deb ...
- Unpacking libicu72:amd64 (72.1-4+b1) ...
- Selecting previously unselected package libxml2:amd64.
- Preparing to unpack .../07-libxml2_2.9.14+dfsg-1.3+b2_amd64.deb ...
- Unpacking libxml2:amd64 (2.9.14+dfsg-1.3+b2) ...
- Selecting previously unselected package libz3-4:amd64.
- Preparing to unpack .../08-libz3-4_4.8.12-3.1+b2_amd64.deb ...
- Unpacking libz3-4:amd64 (4.8.12-3.1+b2) ...
- Selecting previously unselected package libllvm16t64:amd64.
- Preparing to unpack .../09-libllvm16t64_1%3a16.0.6-24_amd64.deb ...
- Unpacking libllvm16t64:amd64 (1:16.0.6-24) ...
- Selecting previously unselected package libstd-rust-1.70:amd64.
- Preparing to unpack .../10-libstd-rust-1.70_1.70.0+dfsg1-9_amd64.deb ...
- Unpacking libstd-rust-1.70:amd64 (1.70.0+dfsg1-9) ...
- Selecting previously unselected package libstd-rust-dev:amd64.
- Preparing to unpack .../11-libstd-rust-dev_1.70.0+dfsg1-9_amd64.deb ...
- Unpacking libstd-rust-dev:amd64 (1.70.0+dfsg1-9) ...
- Selecting previously unselected package rustc.
- Preparing to unpack .../12-rustc_1.70.0+dfsg1-9_amd64.deb ...
- Unpacking rustc (1.70.0+dfsg1-9) ...
- Selecting previously unselected package cargo.
- Preparing to unpack .../13-cargo_0.70.1+ds1-3_amd64.deb ...
- Unpacking cargo (0.70.1+ds1-3) ...
- Preparing to unpack .../14-curl_8.7.1-1_amd64.deb ...
- Unpacking curl (8.7.1-1) over (8.6.0-4) ...
- Preparing to unpack .../15-libcurl4t64_8.7.1-1_amd64.deb ...
- Unpacking libcurl4t64:amd64 (8.7.1-1) over (8.6.0-4) ...
- Selecting previously unselected package icu-devtools.
- Preparing to unpack .../16-icu-devtools_72.1-4+b1_amd64.deb ...
- Unpacking icu-devtools (72.1-4+b1) ...
- Selecting previously unselected package libclang-cpp16t64.
- Preparing to unpack .../17-libclang-cpp16t64_1%3a16.0.6-24_amd64.deb ...
- Unpacking libclang-cpp16t64 (1:16.0.6-24) ...
- Selecting previously unselected package libffi-dev:amd64.
- Preparing to unpack .../18-libffi-dev_3.4.6-1_amd64.deb ...
- Unpacking libffi-dev:amd64 (3.4.6-1) ...
- Selecting previously unselected package libicu-dev:amd64.
- Preparing to unpack .../19-libicu-dev_72.1-4+b1_amd64.deb ...
- Unpacking libicu-dev:amd64 (72.1-4+b1) ...
- Selecting previously unselected package libncurses6:amd64.
- Preparing to unpack .../20-libncurses6_6.4+20240113-1_amd64.deb ...
- Unpacking libncurses6:amd64 (6.4+20240113-1) ...
- Selecting previously unselected package libncurses-dev:amd64.
- Preparing to unpack .../21-libncurses-dev_6.4+20240113-1_amd64.deb ...
- Unpacking libncurses-dev:amd64 (6.4+20240113-1) ...
- Selecting previously unselected package libpfm4:amd64.
- Preparing to unpack .../22-libpfm4_4.13.0+git32-g0d4ed0e-1_amd64.deb ...
- Unpacking libpfm4:amd64 (4.13.0+git32-g0d4ed0e-1) ...
- Selecting previously unselected package libxml2-dev:amd64.
- Preparing to unpack .../23-libxml2-dev_2.9.14+dfsg-1.3+b2_amd64.deb ...
- Unpacking libxml2-dev:amd64 (2.9.14+dfsg-1.3+b2) ...
- Selecting previously unselected package libyaml-0-2:amd64.
- Preparing to unpack .../24-libyaml-0-2_0.2.5-1_amd64.deb ...
- Unpacking libyaml-0-2:amd64 (0.2.5-1) ...
- Selecting previously unselected package libz3-dev:amd64.
- Preparing to unpack .../25-libz3-dev_4.8.12-3.1+b2_amd64.deb ...
- Unpacking libz3-dev:amd64 (4.8.12-3.1+b2) ...
- Selecting previously unselected package llvm-16-runtime.
- Preparing to unpack .../26-llvm-16-runtime_1%3a16.0.6-24_amd64.deb ...
- Unpacking llvm-16-runtime (1:16.0.6-24) ...
- Selecting previously unselected package llvm-16-linker-tools.
- Preparing to unpack .../27-llvm-16-linker-tools_1%3a16.0.6-24_amd64.deb ...
- Unpacking llvm-16-linker-tools (1:16.0.6-24) ...
- Selecting previously unselected package llvm-16.
- Preparing to unpack .../28-llvm-16_1%3a16.0.6-24_amd64.deb ...
- Unpacking llvm-16 (1:16.0.6-24) ...
- Selecting previously unselected package python3-pkg-resources.
- Preparing to unpack .../29-python3-pkg-resources_68.1.2-2_all.deb ...
- Unpacking python3-pkg-resources (68.1.2-2) ...
- Selecting previously unselected package python3-pygments.
- Preparing to unpack .../30-python3-pygments_2.17.2+dfsg-1_all.deb ...
- Unpacking python3-pygments (2.17.2+dfsg-1) ...
- Selecting previously unselected package python3-yaml.
- Preparing to unpack .../31-python3-yaml_6.0.1-2_amd64.deb ...
- Unpacking python3-yaml (6.0.1-2) ...
- Selecting previously unselected package llvm-16-tools.
- Preparing to unpack .../32-llvm-16-tools_1%3a16.0.6-24_amd64.deb ...
- Unpacking llvm-16-tools (1:16.0.6-24) ...
- Selecting previously unselected package llvm-16-dev.
- Preparing to unpack .../33-llvm-16-dev_1%3a16.0.6-24_amd64.deb ...
- Unpacking llvm-16-dev (1:16.0.6-24) ...
- Setting up media-types (10.1.0) ...
- Setting up libpipeline1:amd64 (1.5.7-1+b2) ...
- Setting up libicu72:amd64 (72.1-4+b1) ...
- Setting up libmbedcrypto7t64:amd64 (2.28.7-1.1) ...
- Setting up libcurl4t64:amd64 (8.7.1-1) ...
- Setting up libyaml-0-2:amd64 (0.2.5-1) ...
- Setting up libpython3.11-stdlib:amd64 (3.11.8-3+b2) ...
- Setting up libcurl3t64-gnutls:amd64 (8.7.1-1) ...
- Setting up libffi-dev:amd64 (3.4.6-1) ...
- Setting up libz3-4:amd64 (4.8.12-3.1+b2) ...
- Setting up libpfm4:amd64 (4.13.0+git32-g0d4ed0e-1) ...
- Setting up libncurses6:amd64 (6.4+20240113-1) ...
- Setting up binfmt-support (2.2.2-6) ...
- invoke-rc.d: could not determine current runlevel
- invoke-rc.d: policy-rc.d denied execution of start.
- Setting up icu-devtools (72.1-4+b1) ...
- Setting up curl (8.7.1-1) ...
- Setting up libicu-dev:amd64 (72.1-4+b1) ...
- Setting up libxml2:amd64 (2.9.14+dfsg-1.3+b2) ...
- Setting up libhttp-parser2.9:amd64 (2.9.4-6+b1) ...
- Setting up libpython3-stdlib:amd64 (3.11.8-1) ...
- Setting up libz3-dev:amd64 (4.8.12-3.1+b2) ...
- Setting up python3.11 (3.11.8-3+b2) ...
- Setting up libncurses-dev:amd64 (6.4+20240113-1) ...
- Setting up libmbedx509-1t64:amd64 (2.28.7-1.1) ...
- Setting up python3 (3.11.8-1) ...
- running python rtupdate hooks for python3.11...
- running python post-rtupdate hooks for python3.11...
- Setting up libllvm16t64:amd64 (1:16.0.6-24) ...
- Setting up libxml2-dev:amd64 (2.9.14+dfsg-1.3+b2) ...
- Setting up libstd-rust-1.70:amd64 (1.70.0+dfsg1-9) ...
- Setting up libmbedtls14t64:amd64 (2.28.7-1.1) ...
- Setting up libgit2-1.7:amd64 (1.7.2+ds-1+b1) ...
- Setting up python3-pkg-resources (68.1.2-2) ...
- Setting up llvm-16-runtime (1:16.0.6-24) ...
- Setting up python3-yaml (6.0.1-2) ...
- Setting up libclang-cpp16t64 (1:16.0.6-24) ...
- Setting up llvm-16-linker-tools (1:16.0.6-24) ...
- Setting up libstd-rust-dev:amd64 (1.70.0+dfsg1-9) ...
- Setting up python3-pygments (2.17.2+dfsg-1) ...
- Setting up rustc (1.70.0+dfsg1-9) ...
- Setting up llvm-16 (1:16.0.6-24) ...
- Setting up llvm-16-tools (1:16.0.6-24) ...
- Setting up cargo (0.70.1+ds1-3) ...
- Setting up llvm-16-dev (1:16.0.6-24) ...
- Processing triggers for libc-bin (2.37-15.1) ...

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
Processing  1/9: [batsat.0.7: http]
Processing  2/9: [batsat.0.7: http]
Processing  3/9: [batsat.0.7: http]
Processing  4/9: [batsat.0.7: http] [conf-rust-2018: cargo]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "cargo" "--version" (CWD=/home/opam/.opam/4.13/.opam-switch/build/conf-rust-2018.1)
- cargo 1.69.1
Processing  4/9: [batsat.0.7: http] [conf-rust-2018: rustc 2018]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "rustc" "--edition" "2018" "test.rs" (CWD=/home/opam/.opam/4.13/.opam-switch/build/conf-rust-2018.1)
-> compiled  conf-rust-2018.1
Processing  4/9: [batsat.0.7: http]
-> installed conf-rust-2018.1
Processing  5/9: [batsat.0.7: http]
Processing  5/9:
-> retrieved batsat.0.7  (https://github.com/c-cube/batsat-ocaml/archive/v0.7.tar.gz)
-> retrieved dune.3.14.2  (cached)
Processing  6/9: [dune: ocaml 31]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "ocaml" "boot/bootstrap.ml" "-j" "31" (CWD=/home/opam/.opam/4.13/.opam-switch/build/dune.3.14.2)
- ocamlc -output-complete-exe -w -24 -g -o .duneboot.exe -I boot unix.cma boot/libs.ml boot/duneboot.ml
- ./.duneboot.exe -j 31
- cd _boot && /home/opam/.opam/4.13/bin/ocamlopt.opt -c -g -no-alias-deps -w -49-6 -alert -unstable -I +threads opamLocal.ml
- File "vendor/opam/src/repository/opamLocal.ml", lines 109-114, characters 46-34:
- Warning 8 [partial-match]: this pattern-matching is not exhaustive.
- Here is an example of a case that is not matched:
- Checksum_mismatch _
- File "vendor/opam/src/repository/opamLocal.ml", lines 170-189, characters 44-56:
- Warning 8 [partial-match]: this pattern-matching is not exhaustive.
- Here is an example of a case that is not matched:
- Checksum_mismatch _
- File "vendor/opam/src/repository/opamLocal.ml", lines 209-231, characters 8-44:
- Warning 8 [partial-match]: this pattern-matching is not exhaustive.
- Here is an example of a case that is not matched:
- Checksum_mismatch _
- cd _boot && /home/opam/.opam/4.13/bin/ocamlopt.opt -c -g -no-alias-deps -w -49-6 -alert -unstable -I +threads opamVCS.ml
- File "vendor/opam/src/repository/opamVCS.ml", lines 179-182, characters 11-40:
- Warning 8 [partial-match]: this pattern-matching is not exhaustive.
- Here is an example of a case that is not matched:
- Checksum_mismatch _
- cd _boot && /home/opam/.opam/4.13/bin/ocamlopt.opt -c -g -no-alias-deps -w -49-6 -alert -unstable -I +threads opamDownload.ml
- File "vendor/opam/src/repository/opamDownload.ml", lines 323-361, characters 42-41:
- Warning 8 [partial-match]: this pattern-matching is not exhaustive.
- Here is an example of a case that is not matched:
- Checksum_mismatch _
- cd _boot && /home/opam/.opam/4.13/bin/ocamlopt.opt -c -g -no-alias-deps -w -49-6 -alert -unstable -I +threads opamRepository.ml
- File "vendor/opam/src/repository/opamRepository.ml", lines 88-90, characters 45-77:
- Warning 8 [partial-match]: this pattern-matching is not exhaustive.
- Here is an example of a case that is not matched:
- Checksum_mismatch _
- File "vendor/opam/src/repository/opamRepository.ml", lines 277-281, characters 38-17:
- Warning 8 [partial-match]: this pattern-matching is not exhaustive.
- Here is an example of a case that is not matched:
- Checksum_mismatch _
- File "vendor/opam/src/repository/opamRepository.ml", lines 423-427, characters 12-42:
- Warning 8 [partial-match]: this pattern-matching is not exhaustive.
- Here is an example of a case that is not matched:
- (_, Checksum_mismatch _)
- 

Processing  6/9: [dune: ./_boot/dune.exe build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "./_boot/dune.exe" "build" "dune.install" "--release" "--profile" "dune-bootstrap" "-j" "31" (CWD=/home/opam/.opam/4.13/.opam-switch/build/dune.3.14.2)
-> compiled  dune.3.14.2
-> installed dune.3.14.2
Processing  8/9: [batsat: ./build_rust.sh]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "./build_rust.sh" (CWD=/home/opam/.opam/4.13/.opam-switch/build/batsat.0.7)
-    Compiling proc-macro2 v1.0.32
-    Compiling unicode-xid v0.2.2
-    Compiling syn v1.0.81
-    Compiling cc v1.0.72
-    Compiling ocaml-sys v0.22.0
-    Compiling chlorine v1.0.10
-    Compiling ocaml-interop v0.8.7
-    Compiling static_assertions v1.1.0
-    Compiling bit-vec v0.5.1
-    Compiling batsat v0.5.0
-    Compiling quote v1.0.10
-    Compiling ocaml-boxroot-sys v0.2.0
-    Compiling synstructure v0.12.6
-    Compiling ocaml-derive v0.22.0
-    Compiling ocaml v0.22.2
-    Compiling batsat-stubs v0.1.0 (/home/opam/.opam/4.13/.opam-switch/build/batsat.0.7)
- warning: attribute should be applied to an `extern` block with non-Rust ABI
-  --> src/lib.rs:1:1
-   |
- 1 | #[link(name = "batsat")]
-   | ^^^^^^^^^^^^^^^^^^^^^^^^
- 2 | use ocaml::Pointer;
-   | ------------------- not an `extern` block
-   |
-   = warning: this was previously accepted by the compiler but is being phased out; it will become a hard error in a future release!
-   = note: `#[warn(unused_attributes)]` on by default
- 
- warning: `batsat-stubs` (lib) generated 1 warning
-     Finished release [optimized + debuginfo] target(s) in 20.00s
Processing  8/9: [batsat: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "batsat" "-j" "31" (CWD=/home/opam/.opam/4.13/.opam-switch/build/batsat.0.7)
-> compiled  batsat.0.7
-> installed batsat.0.7
Done.
# Run eval $(opam env) to update the current shell environment
2024-03-28 17:17.36 ---> saved as "b45e7ce811c5e162358e345f780f35ba2d67b54ab0776f16bce4e990f4cf3d6e"
Job succeeded