OCamllabs icon Home|Differences with the last checks|Previous runs


Building on x86-bm-c2.sw.ocaml.org

(from ocaml/opam:debian-unstable)
Unable to find image 'ocaml/opam:debian-unstable' locally
debian-unstable: Pulling from ocaml/opam
Digest: sha256:6dbb1e6b4b767fa11369e17e0d90d7f294f4268e08e4aad51632f1951e9764d2
Status: Downloaded newer image for ocaml/opam:debian-unstable
2024-03-28 14:54.25 ---> using "0acd5aeaa8f7bc314514d9795d14a7f12ec72a6a5b11c5904350189734c6859b" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2024-03-28 14:54.25 ---> using "65c3237f501f7c75f3828458ecf2342bc41c98aaef8c6a7fd82bf46a58cb258c" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q fe00df86c9b4d714ec1d1c3b5fad3b9485967f6e"))
2024-03-28 14:54.25 ---> using "1969b865dc0121544b5da025cca93a3017a18292e4eb09b2cafbb1c174a48136" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2024-03-28 14:54.25 ---> using "8e73b7cc41b9f391e9c71cd803608f55cb84b633abc3d24bdb07c4d652d870c1" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '5.0' '5.0.0'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "5.0.0"} | "ocaml-system" {= "5.0.0"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> installed ocaml-options-vanilla.1
-> retrieved ocaml-base-compiler.5.0.0  (cached)
-> installed ocaml-base-compiler.5.0.0
-> installed ocaml-config.3
-> installed ocaml.5.0.0
-> installed base-domains.base
-> installed base-nnp.base
Done.
# Run eval $(opam env --switch=5.0) to update the current shell environment
2024-03-28 14:54.25 ---> using "5643994c2ef271863ba060e71fbd3b26453b0904bfa098854083953efc731f15" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [198 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-03-28-0807.42-F-2024-03-21-1407.24.pdiff [602 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-03-28-0807.42-F-2024-03-21-1407.24.pdiff [602 kB]
- Fetched 864 kB in 3s (297 kB/s)
- Reading package lists...
- 
2024-03-28 14:54.25 ---> using "82576906bd68e0d6b45b1e2e16691a1abb63a290388f04dd513a6eabc98eaa85" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"bap-dwarf.2.5.0\"\
               \nopam install -vy \"bap-dwarf.2.5.0\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"bap-dwarf.2.5.0\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
Nothing to do.
[NOTE] bap-dwarf.2.5.0 is not installed.

[ERROR] Package conflict!
  * No agreement on the version of ocaml-base-compiler:
    - (invariant) -> ocaml-base-compiler = 5.0.0
    - bap-dwarf >= 2.5.0 -> ppx_bap -> ocaml < 4.12.0 -> ocaml-base-compiler < 3.07+1
    You can temporarily relax the switch invariant with `--update-invariant'
  * No agreement on the version of ocaml:
    - (invariant) -> ocaml-base-compiler = 5.0.0 -> ocaml = 5.0.0
    - bap-dwarf >= 2.5.0 -> ppx_bap -> ppx_bin_prot < v0.15 -> base < v0.13 -> ocaml < 4.06.0
  * Missing dependency:
    - bap-dwarf >= 2.5.0 -> ppx_bap -> ocaml < 4.12.0 -> ocaml-variants >= 3.09.2 -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'

No solution found, exiting
'opam install -vy bap-dwarf.2.5.0' failed.
"/usr/bin/env" "bash" "-c" "
opam remove -y "bap-dwarf.2.5.0"
opam install -vy "bap-dwarf.2.5.0"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "bap-dwarf.2.5.0" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed