OCamllabs icon Home|Differences with the last checks|Previous runs


Building on doris.caelum.ci.dev

(from ocaml/opam:debian-unstable)
Unable to find image 'ocaml/opam:debian-unstable' locally
debian-unstable: Pulling from ocaml/opam
Digest: sha256:6dbb1e6b4b767fa11369e17e0d90d7f294f4268e08e4aad51632f1951e9764d2
Status: Downloaded newer image for ocaml/opam:debian-unstable
2024-03-28 08:48.38 ---> using "0acd5aeaa8f7bc314514d9795d14a7f12ec72a6a5b11c5904350189734c6859b" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2024-03-28 08:48.38 ---> using "65c3237f501f7c75f3828458ecf2342bc41c98aaef8c6a7fd82bf46a58cb258c" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q fe00df86c9b4d714ec1d1c3b5fad3b9485967f6e"))
2024-03-28 08:48.38 ---> using "1969b865dc0121544b5da025cca93a3017a18292e4eb09b2cafbb1c174a48136" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2024-03-28 08:48.38 ---> using "8e73b7cc41b9f391e9c71cd803608f55cb84b633abc3d24bdb07c4d652d870c1" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '5.1' '5.1.0'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "5.1.0"} | "ocaml-system" {= "5.1.0"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> installed ocaml-options-vanilla.1
-> retrieved ocaml-base-compiler.5.1.0  (https://github.com/ocaml/ocaml/archive/5.1.0.tar.gz)
-> installed ocaml-base-compiler.5.1.0
-> installed ocaml-config.3
-> installed ocaml.5.1.0
-> installed base-domains.base
-> installed base-nnp.base
Done.
# Run eval $(opam env --switch=5.1) to update the current shell environment
2024-03-28 08:48.38 ---> using "48a37234dec686069e839a6643dcaba0ecb05841c9efe503502a6a52094db090" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [198 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-03-28-0211.59-F-2024-03-21-1407.24.pdiff [600 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-03-28-0211.59-F-2024-03-21-1407.24.pdiff [600 kB]
- Fetched 862 kB in 1s (594 kB/s)
- Reading package lists...
- 
2024-03-28 08:48.38 ---> using "3fbdf3f9232a25a290c102ec3d9c70d1abbbe994161582c8df70eb187a40e914" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"afl.2.57b\"\
               \nopam install -vy \"afl.2.57b\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"afl.2.57b\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] afl.2.57b is not installed.

Nothing to do.
The following actions will be performed:
=== install 1 package
  - install afl 2.57b

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
Processing  1/3:
-> retrieved afl.2.57b  (cached)
[afl: patch] applying add-uninstall-target.patch
Processing  2/3: [afl: patch]
Processing  2/3: [afl: make]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "make" (CWD=/home/opam/.opam/5.1/.opam-switch/build/afl.2.57b)
- [*] Checking for the ability to compile x86 code...
- [+] Everything seems to be working, ready to compile.
- cc -O3 -funroll-loops -Wall -D_FORTIFY_SOURCE=2 -g -Wno-pointer-sign -DAFL_PATH=\"/usr/local/lib/afl\" -DDOC_PATH=\"/usr/local/share/doc/afl\" -DBIN_PATH=\"/usr/local/bin\" afl-gcc.c -o afl-gcc -ldl
- set -e; for i in afl-g++ afl-clang afl-clang++; do ln -sf afl-gcc $i; done
- cc -O3 -funroll-loops -Wall -D_FORTIFY_SOURCE=2 -g -Wno-pointer-sign -DAFL_PATH=\"/usr/local/lib/afl\" -DDOC_PATH=\"/usr/local/share/doc/afl\" -DBIN_PATH=\"/usr/local/bin\" afl-fuzz.c -o afl-fuzz -ldl
- cc -O3 -funroll-loops -Wall -D_FORTIFY_SOURCE=2 -g -Wno-pointer-sign -DAFL_PATH=\"/usr/local/lib/afl\" -DDOC_PATH=\"/usr/local/share/doc/afl\" -DBIN_PATH=\"/usr/local/bin\" afl-showmap.c -o afl-showmap -ldl
- cc -O3 -funroll-loops -Wall -D_FORTIFY_SOURCE=2 -g -Wno-pointer-sign -DAFL_PATH=\"/usr/local/lib/afl\" -DDOC_PATH=\"/usr/local/share/doc/afl\" -DBIN_PATH=\"/usr/local/bin\" afl-tmin.c -o afl-tmin -ldl
- cc -O3 -funroll-loops -Wall -D_FORTIFY_SOURCE=2 -g -Wno-pointer-sign -DAFL_PATH=\"/usr/local/lib/afl\" -DDOC_PATH=\"/usr/local/share/doc/afl\" -DBIN_PATH=\"/usr/local/bin\" afl-gotcpu.c -o afl-gotcpu -ldl
- cc -O3 -funroll-loops -Wall -D_FORTIFY_SOURCE=2 -g -Wno-pointer-sign -DAFL_PATH=\"/usr/local/lib/afl\" -DDOC_PATH=\"/usr/local/share/doc/afl\" -DBIN_PATH=\"/usr/local/bin\" afl-analyze.c -o afl-analyze -ldl
- cc -O3 -funroll-loops -Wall -D_FORTIFY_SOURCE=2 -g -Wno-pointer-sign -DAFL_PATH=\"/usr/local/lib/afl\" -DDOC_PATH=\"/usr/local/share/doc/afl\" -DBIN_PATH=\"/usr/local/bin\" afl-as.c -o afl-as -ldl
- ln -sf afl-as as
- [*] Testing the CC wrapper and instrumentation output...
- unset AFL_USE_ASAN AFL_USE_MSAN; AFL_QUIET=1 AFL_INST_RATIO=100 AFL_PATH=. ./afl-gcc -O3 -funroll-loops -Wall -D_FORTIFY_SOURCE=2 -g -Wno-pointer-sign -DAFL_PATH=\"/usr/local/lib/afl\" -DDOC_PATH=\"/usr/local/share/doc/afl\" -DBIN_PATH=\"/usr/local/bin\" test-instr.c -o test-instr -ldl
- ./afl-showmap -m none -q -o .test-instr0 ./test-instr < /dev/null
- echo 1 | ./afl-showmap -m none -q -o .test-instr1 ./test-instr
- [+] All right, the instrumentation seems to be working!
- [+] All done! Be sure to review README - it's pretty short and useful.
-> compiled  afl.2.57b
Processing  3/3: [afl: make install]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "install" "make" "PREFIX=/home/opam/.opam/5.1" "install" (CWD=/home/opam/.opam/5.1/.opam-switch/build/afl.2.57b)
- [*] Checking for the ability to compile x86 code...
- [+] Everything seems to be working, ready to compile.
- [*] Testing the CC wrapper and instrumentation output...
- unset AFL_USE_ASAN AFL_USE_MSAN; AFL_QUIET=1 AFL_INST_RATIO=100 AFL_PATH=. ./afl-gcc -O3 -funroll-loops -Wall -D_FORTIFY_SOURCE=2 -g -Wno-pointer-sign -DAFL_PATH=\"/home/opam/.opam/5.1/lib/afl\" -DDOC_PATH=\"/home/opam/.opam/5.1/share/doc/afl\" -DBIN_PATH=\"/home/opam/.opam/5.1/bin\" test-instr.c -o test-instr -ldl
- ./afl-showmap -m none -q -o .test-instr0 ./test-instr < /dev/null
- echo 1 | ./afl-showmap -m none -q -o .test-instr1 ./test-instr
- [+] All right, the instrumentation seems to be working!
- [+] All done! Be sure to review README - it's pretty short and useful.
- mkdir -p -m 755 ${DESTDIR}/home/opam/.opam/5.1/bin ${DESTDIR}/home/opam/.opam/5.1/lib/afl ${DESTDIR}/home/opam/.opam/5.1/share/doc/afl ${DESTDIR}/home/opam/.opam/5.1/share/afl
- rm -f ${DESTDIR}/home/opam/.opam/5.1/bin/afl-plot.sh
- install -m 755 afl-gcc afl-fuzz afl-showmap afl-tmin afl-gotcpu afl-analyze afl-plot afl-cmin afl-whatsup ${DESTDIR}/home/opam/.opam/5.1/bin
- rm -f ${DESTDIR}/home/opam/.opam/5.1/bin/afl-as
- if [ -f afl-qemu-trace ]; then install -m 755 afl-qemu-trace ${DESTDIR}/home/opam/.opam/5.1/bin; fi
- if [ -f afl-clang-fast -a -f afl-llvm-pass.so -a -f afl-llvm-rt.o ]; then set -e; install -m 755 afl-clang-fast ${DESTDIR}/home/opam/.opam/5.1/bin; ln -sf afl-clang-fast ${DESTDIR}/home/opam/.opam/5.1/bin/afl-clang-fast++; install -m 755 afl-llvm-pass.so afl-llvm-rt.o ${DESTDIR}/home/opam/.opam/5.1/lib/afl; fi
- if [ -f afl-llvm-rt-32.o ]; then set -e; install -m 755 afl-llvm-rt-32.o ${DESTDIR}/home/opam/.opam/5.1/lib/afl; fi
- if [ -f afl-llvm-rt-64.o ]; then set -e; install -m 755 afl-llvm-rt-64.o ${DESTDIR}/home/opam/.opam/5.1/lib/afl; fi
- set -e; for i in afl-g++ afl-clang afl-clang++; do ln -sf afl-gcc ${DESTDIR}/home/opam/.opam/5.1/bin/$i; done
- install -m 755 afl-as ${DESTDIR}/home/opam/.opam/5.1/lib/afl
- ln -sf afl-as ${DESTDIR}/home/opam/.opam/5.1/lib/afl/as
- install -m 644 docs/README docs/ChangeLog docs/*.txt ${DESTDIR}/home/opam/.opam/5.1/share/doc/afl
- cp -r testcases/ ${DESTDIR}/home/opam/.opam/5.1/share/afl
- cp -r dictionaries/ ${DESTDIR}/home/opam/.opam/5.1/share/afl
-> installed afl.2.57b
Done.
# Run eval $(opam env) to update the current shell environment
2024-03-28 08:48.52 ---> saved as "7ac681e47094b3d1d9e4a1b214b74d31435c4016978e67a481cb2fa1bad14749"
Job succeeded