OCamllabs icon Home|Differences with the last checks|Previous runs


Building on doris.caelum.ci.dev

(from ocaml/opam:debian-unstable)
2024-06-08 15:07.12 ---> using "0acd5aeaa8f7bc314514d9795d14a7f12ec72a6a5b11c5904350189734c6859b" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2024-06-08 15:07.12 ---> using "65c3237f501f7c75f3828458ecf2342bc41c98aaef8c6a7fd82bf46a58cb258c" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q f4fe6a19e8ca89de0028a1ab90cb61ecdab7084b"))
2024-06-08 15:07.12 ---> using "307bb6974cfcb6190f28f6f7d49d40b196c2bfe8efe0033ec2dcae030ffa6019" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2024-06-08 15:07.12 ---> using "e61767b92e01fc91060002a915012365bb54961334fb628e2e2bfb162cd99d7e" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.09' '4.09.1'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.09.1"} | "ocaml-system" {= "4.09.1"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved ocaml-config.1  (cached)
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-base-compiler.4.09.1  (cached)
-> installed ocaml-base-compiler.4.09.1
-> installed ocaml-config.1
-> installed ocaml.4.09.1
Done.
# Run eval $(opam env --switch=4.09) to update the current shell environment
2024-06-08 15:07.12 ---> using "d9f8c0bb5ae77221090952e7db0347afc1afdac81c8550cb8972217ebb4d0091" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [198 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-06-08-0814.31-F-2024-06-04-0804.54.pdiff [309 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-06-08-0814.31-F-2024-06-04-0804.54.pdiff [309 kB]
- Fetched 571 kB in 1s (386 kB/s)
- Reading package lists...
- 
2024-06-08 15:07.12 ---> using "801d4b6a2ece17488dda155d9a1b313728ca73913fb8fbfc2902e9f36cbfa7fe" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"atomic.base\"\
               \nopam install -vy \"atomic.base\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"atomic.base\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
Nothing to do.
[NOTE] atomic.base is not installed.

[ERROR] Package conflict!
  * No agreement on the version of ocaml:
    - (invariant) -> ocaml-base-compiler = 4.09.1 -> ocaml = 4.09.1
    - atomic >= base -> ocaml >= 4.12.0
    You can temporarily relax the switch invariant with `--update-invariant'

No solution found, exiting
'opam install -vy atomic.base' failed.
"/usr/bin/env" "bash" "-c" "
opam remove -y "atomic.base"
opam install -vy "atomic.base"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "atomic.base" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed