OCamllabs icon Home|Differences with the last checks|Previous runs


Building on doris.caelum.ci.dev

(from ocaml/opam:debian-unstable)
2024-06-08 19:08.34 ---> using "0acd5aeaa8f7bc314514d9795d14a7f12ec72a6a5b11c5904350189734c6859b" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2024-06-08 19:08.34 ---> using "65c3237f501f7c75f3828458ecf2342bc41c98aaef8c6a7fd82bf46a58cb258c" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q f4fe6a19e8ca89de0028a1ab90cb61ecdab7084b"))
2024-06-08 19:08.34 ---> using "307bb6974cfcb6190f28f6f7d49d40b196c2bfe8efe0033ec2dcae030ffa6019" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2024-06-08 19:08.34 ---> using "e61767b92e01fc91060002a915012365bb54961334fb628e2e2bfb162cd99d7e" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '5.2' '5.2.0'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "5.2.0"} | "ocaml-system" {= "5.2.0"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved ocaml-config.3  (cached)
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> installed host-arch-x86_64.1
-> installed host-system-other.1
-> installed ocaml-options-vanilla.1
-> retrieved ocaml-base-compiler.5.2.0  (cached)
-> installed ocaml-base-compiler.5.2.0
-> installed ocaml-config.3
-> installed ocaml.5.2.0
-> installed base-domains.base
-> installed base-nnp.base
Done.
# Run eval $(opam env --switch=5.2) to update the current shell environment
2024-06-08 19:08.34 ---> using "f2265d36df0bbedd99947bd20e38afe95c9847127eaa02d15b602a08438e7f01" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [198 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-06-08-1408.33-F-2024-06-04-0804.54.pdiff [331 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-06-08-1408.33-F-2024-06-04-0804.54.pdiff [331 kB]
- Fetched 593 kB in 2s (357 kB/s)
- Reading package lists...
- 
2024-06-08 19:08.34 ---> using "8aa1384bc2a599e8420866df43db227a11cbdd3bb7c20703bece1e75d6c22a07" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"camelot.1.7.1\"\
               \nopam install -vy \"camelot.1.7.1\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"camelot.1.7.1\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
Nothing to do.
[NOTE] camelot.1.7.1 is not installed.

[ERROR] Package conflict!
No solution found, exiting
  * No agreement on the version of ocaml:
    - (invariant) -> ocaml-base-compiler >= 5.2.0 -> ocaml = 5.2.0
    - camelot >= 1.7.1 -> ocaml < 4.13
    You can temporarily relax the switch invariant with `--update-invariant'
  * No agreement on the version of ocaml-base-compiler:
    - (invariant) -> ocaml-base-compiler >= 5.2.0
    - camelot >= 1.7.1 -> ocaml < 4.13 -> ocaml-base-compiler = 3.07+2
  * Missing dependency:
    - camelot >= 1.7.1 -> ocaml < 4.13 -> ocaml-variants -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'

'opam install -vy camelot.1.7.1' failed.
"/usr/bin/env" "bash" "-c" "
opam remove -y "camelot.1.7.1"
opam install -vy "camelot.1.7.1"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "camelot.1.7.1" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed