OCamllabs icon Home|Differences with the last checks|Previous runs


Building on doris.caelum.ci.dev

(from ocaml/opam:debian-unstable)
2024-06-30 21:11.11 ---> using "0acd5aeaa8f7bc314514d9795d14a7f12ec72a6a5b11c5904350189734c6859b" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2024-06-30 21:11.11 ---> using "65c3237f501f7c75f3828458ecf2342bc41c98aaef8c6a7fd82bf46a58cb258c" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q 3bcb45c36ed254e850b498bff678e3e5848b23e1"))
2024-06-30 21:11.11 ---> using "3d0bfbfa177ca2531fcfa9e2869627278a2c31cf290ac589bbf0639aba3b017c" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2024-06-30 21:11.11 ---> using "5dff26d510618c1d48fe6b00f268416e83e2cb4c80c378ed525d97eb709030a0" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.08' '4.08.1'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.08.1"} | "ocaml-system" {= "4.08.1"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved ocaml-config.1  (cached)
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-base-compiler.4.08.1  (cached)
-> installed ocaml-base-compiler.4.08.1
-> installed ocaml-config.1
-> installed ocaml.4.08.1
Done.
# Run eval $(opam env --switch=4.08) to update the current shell environment
2024-06-30 21:11.11 ---> using "ad775bba96779a023c874bf756009ac479a83ad0078691fd8542d087b040156c" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [198 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-06-30-1411.31-F-2024-06-27-0211.32.pdiff [248 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-06-30-1411.31-F-2024-06-27-0211.32.pdiff [248 kB]
- Fetched 510 kB in 2s (330 kB/s)
- Reading package lists...
- 
2024-06-30 21:11.11 ---> using "8da0bdbec14db8e247f35eed506e9736be91e23030a3e56afbca1cab28ac44bd" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"bson2.0.0.1\"\
               \nopam install -vy \"bson2.0.0.1\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"bson2.0.0.1\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] bson2.0.0.1 is not installed.

Nothing to do.
The following actions will be performed:
=== install 57 packages
  - install base                    v0.12.2            [required by core_kernel]
  - install base_bigstring          v0.12.0            [required by core_kernel]
  - install base_quickcheck         v0.12.1            [required by core_kernel]
  - install bin_prot                v0.12.0            [required by core_kernel]
  - install bson2                   0.0.1
  - install core                    v0.12.4            [required by bson2]
  - install core_kernel             v0.12.3            [required by core]
  - install csexp                   1.5.2              [required by dune-configurator]
  - install dune                    3.16.0             [required by bson2]
  - install dune-configurator       3.16.0             [required by base]
  - install fieldslib               v0.12.0            [required by core_kernel]
  - install jane-street-headers     v0.12.0            [required by core_kernel]
  - install jst-config              v0.12.0            [required by core]
  - install num                     1.5                [required by sexplib]
  - install ocaml-compiler-libs     v0.12.4            [required by ppxlib]
  - install ocaml-migrate-parsetree 1.8.0 (deprecated) [required by ppxlib]
  - install octavius                1.2.2              [required by ppx_js_style]
  - install parsexp                 v0.12.0            [required by sexplib]
  - install ppx_assert              v0.12.0            [required by core_kernel]
  - install ppx_base                v0.12.0            [required by core_kernel]
  - install ppx_bench               v0.12.0            [required by ppx_jane]
  - install ppx_bin_prot            v0.12.1            [required by ppx_jane]
  - install ppx_compare             v0.12.0            [required by ppx_expect]
  - install ppx_custom_printf       v0.12.1            [required by ppx_jane]
  - install ppx_derivers            1.2.1              [required by ppxlib]
  - install ppx_enumerate           v0.12.0            [required by ppx_base]
  - install ppx_expect              v0.12.0            [required by ppx_jane]
  - install ppx_fail                v0.12.0            [required by ppx_jane]
  - install ppx_fields_conv         v0.12.0            [required by ppx_jane]
  - install ppx_hash                v0.12.0            [required by core_kernel]
  - install ppx_here                v0.12.0            [required by ppx_jane]
  - install ppx_inline_test         v0.12.0            [required by core_kernel]
  - install ppx_jane                v0.12.0            [required by core]
  - install ppx_js_style            v0.12.0            [required by ppx_base]
  - install ppx_let                 v0.12.0            [required by ppx_jane]
  - install ppx_module_timer        v0.12.0            [required by ppx_jane]
  - install ppx_optcomp             v0.12.0            [required by ppx_jane]
  - install ppx_optional            v0.12.0            [required by ppx_jane]
  - install ppx_pipebang            v0.12.0            [required by ppx_jane]
  - install ppx_sexp_conv           v0.12.0            [required by core_kernel]
  - install ppx_sexp_message        v0.12.0            [required by core_kernel]
  - install ppx_sexp_value          v0.12.0            [required by ppx_jane]
  - install ppx_stable              v0.12.0            [required by ppx_jane]
  - install ppx_typerep_conv        v0.12.0            [required by ppx_jane]
  - install ppx_variants_conv       v0.12.0            [required by ppx_jane]
  - install ppxlib                  0.8.1              [required by ppx_jane]
  - install re                      1.11.0             [required by ppx_expect]
  - install result                  1.5                [required by ocaml-migrate-parsetree]
  - install seq                     base               [required by re]
  - install sexplib                 v0.12.0            [required by core]
  - install sexplib0                v0.12.0            [required by base, sexplib]
  - install spawn                   v0.15.1            [required by core]
  - install splittable_random       v0.12.0            [required by core_kernel]
  - install stdio                   v0.12.0            [required by core_kernel]
  - install time_now                v0.12.0            [required by core_kernel]
  - install typerep                 v0.12.0            [required by core_kernel]
  - install variantslib             v0.12.0            [required by core_kernel]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
Processing  1/170: [base.v0.12.2: extract]
Processing  2/170: [base.v0.12.2: extract] [base_bigstring.v0.12.0: extract]
Processing  3/170: [base.v0.12.2: extract] [base_bigstring.v0.12.0: extract] [base_quickcheck.v0.12.1: extract]
-> retrieved base_bigstring.v0.12.0  (cached)
Processing  3/170: [base.v0.12.2: extract] [base_quickcheck.v0.12.1: extract]
Processing  4/170: [base.v0.12.2: extract] [base_quickcheck.v0.12.1: extract] [bin_prot.v0.12.0: extract]
-> retrieved base_quickcheck.v0.12.1  (cached)
Processing  4/170: [base.v0.12.2: extract] [bin_prot.v0.12.0: extract]
Processing  5/170: [base.v0.12.2: extract] [bin_prot.v0.12.0: extract] [bson2.0.0.1: http]
-> retrieved base.v0.12.2  (cached)
Processing  5/170: [bin_prot.v0.12.0: extract] [bson2.0.0.1: http]
Processing  6/170: [bin_prot.v0.12.0: extract] [bson2.0.0.1: http] [core.v0.12.4: extract]
-> retrieved bin_prot.v0.12.0  (cached)
Processing  6/170: [bson2.0.0.1: http] [core.v0.12.4: extract]
Processing  7/170: [bson2.0.0.1: http] [core.v0.12.4: extract] [core_kernel.v0.12.3: extract]
-> retrieved core.v0.12.4  (cached)
Processing  7/170: [bson2.0.0.1: http] [core_kernel.v0.12.3: extract]
Processing  8/170: [bson2.0.0.1: http] [core_kernel.v0.12.3: extract] [csexp.1.5.2: extract]
-> retrieved core_kernel.v0.12.3  (cached)
Processing  8/170: [bson2.0.0.1: http] [csexp.1.5.2: extract]
Processing  9/170: [bson2.0.0.1: http] [csexp.1.5.2: extract] [dune.3.16.0, dune-configurator.3.16.0: extract]
-> retrieved csexp.1.5.2  (cached)
Processing  9/170: [bson2.0.0.1: http] [dune.3.16.0, dune-configurator.3.16.0: extract]
Processing 10/170: [bson2.0.0.1: http] [dune.3.16.0, dune-configurator.3.16.0: extract] [fieldslib.v0.12.0: extract]
-> retrieved fieldslib.v0.12.0  (cached)
Processing 10/170: [bson2.0.0.1: http] [dune.3.16.0, dune-configurator.3.16.0: extract]
Processing 11/170: [bson2.0.0.1: http] [dune.3.16.0, dune-configurator.3.16.0: extract] [jane-street-headers.v0.12.0: extract]
-> retrieved jane-street-headers.v0.12.0  (cached)
Processing 11/170: [bson2.0.0.1: http] [dune.3.16.0, dune-configurator.3.16.0: extract]
Processing 12/170: [bson2.0.0.1: http] [dune.3.16.0, dune-configurator.3.16.0: extract] [jst-config.v0.12.0: extract]
-> retrieved jst-config.v0.12.0  (cached)
Processing 12/170: [bson2.0.0.1: http] [dune.3.16.0, dune-configurator.3.16.0: extract]
Processing 13/170: [bson2.0.0.1: http] [dune.3.16.0, dune-configurator.3.16.0: extract] [num.1.5: extract]
-> retrieved num.1.5  (cached)
Processing 13/170: [bson2.0.0.1: http] [dune.3.16.0, dune-configurator.3.16.0: extract]
Processing 14/170: [bson2.0.0.1: http] [dune.3.16.0, dune-configurator.3.16.0: extract] [ocaml-compiler-libs.v0.12.4: extract]
Processing 15/170: [bson2.0.0.1: http] [dune.3.16.0, dune-configurator.3.16.0: extract] [ocaml-compiler-libs.v0.12.4: extract] [num: make opam-legacy]
-> retrieved ocaml-compiler-libs.v0.12.4  (cached)
Processing 15/170: [bson2.0.0.1: http] [dune.3.16.0, dune-configurator.3.16.0: extract] [num: make opam-legacy]
Processing 16/170: [bson2.0.0.1: http] [dune.3.16.0, dune-configurator.3.16.0: extract] [ocaml-migrate-parsetree.1.8.0: extract] [num: make opam-legacy]
Processing 16/170: [bson2.0.0.1: extract] [dune.3.16.0, dune-configurator.3.16.0: extract] [ocaml-migrate-parsetree.1.8.0: extract] [num: make opam-legacy]
-> retrieved bson2.0.0.1  (https://github.com/nosman/Bson2/archive/0.0.1.tar.gz)
Processing 16/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ocaml-migrate-parsetree.1.8.0: extract] [num: make opam-legacy]
Processing 17/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ocaml-migrate-parsetree.1.8.0: extract] [octavius.1.2.2: extract] [num: make opam-legacy]
-> retrieved octavius.1.2.2  (cached)
Processing 17/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ocaml-migrate-parsetree.1.8.0: extract] [num: make opam-legacy]
Processing 18/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ocaml-migrate-parsetree.1.8.0: extract] [parsexp.v0.12.0: extract] [num: make opam-legacy]
-> retrieved parsexp.v0.12.0  (cached)
Processing 18/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ocaml-migrate-parsetree.1.8.0: extract] [num: make opam-legacy]
Processing 19/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ocaml-migrate-parsetree.1.8.0: extract] [ppx_assert.v0.12.0: extract] [num: make opam-legacy]
-> retrieved ocaml-migrate-parsetree.1.8.0  (cached)
Processing 19/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_assert.v0.12.0: extract] [num: make opam-legacy]
Processing 20/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_assert.v0.12.0: extract] [ppx_base.v0.12.0: extract] [num: make opam-legacy]
-> retrieved ppx_assert.v0.12.0  (cached)
Processing 20/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_base.v0.12.0: extract] [num: make opam-legacy]
Processing 21/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_base.v0.12.0: extract] [ppx_bench.v0.12.0: extract] [num: make opam-legacy]
-> retrieved ppx_base.v0.12.0  (cached)
Processing 21/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_bench.v0.12.0: extract] [num: make opam-legacy]
Processing 22/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_bench.v0.12.0: extract] [ppx_bin_prot.v0.12.1: extract] [num: make opam-legacy]
-> retrieved ppx_bench.v0.12.0  (cached)
Processing 22/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_bin_prot.v0.12.1: extract] [num: make opam-legacy]
Processing 23/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_bin_prot.v0.12.1: extract] [ppx_compare.v0.12.0: extract] [num: make opam-legacy]
-> retrieved ppx_bin_prot.v0.12.1  (cached)
Processing 23/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_compare.v0.12.0: extract] [num: make opam-legacy]
Processing 24/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_compare.v0.12.0: extract] [ppx_custom_printf.v0.12.1: extract] [num: make opam-legacy]
-> retrieved ppx_compare.v0.12.0  (cached)
Processing 24/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_custom_printf.v0.12.1: extract] [num: make opam-legacy]
Processing 25/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_custom_printf.v0.12.1: extract] [ppx_derivers.1.2.1: extract] [num: make opam-legacy]
-> retrieved ppx_custom_printf.v0.12.1  (cached)
Processing 25/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_derivers.1.2.1: extract] [num: make opam-legacy]
Processing 26/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_derivers.1.2.1: extract] [ppx_enumerate.v0.12.0: extract] [num: make opam-legacy]
-> retrieved ppx_derivers.1.2.1  (cached)
Processing 26/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_enumerate.v0.12.0: extract] [num: make opam-legacy]
Processing 27/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_enumerate.v0.12.0: extract] [ppx_expect.v0.12.0: extract] [num: make opam-legacy]
-> retrieved ppx_enumerate.v0.12.0  (cached)
Processing 27/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_expect.v0.12.0: extract] [num: make opam-legacy]
Processing 28/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_expect.v0.12.0: extract] [ppx_fail.v0.12.0: extract] [num: make opam-legacy]
-> retrieved ppx_expect.v0.12.0  (cached)
Processing 28/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_fail.v0.12.0: extract] [num: make opam-legacy]
Processing 29/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_fail.v0.12.0: extract] [ppx_fields_conv.v0.12.0: extract] [num: make opam-legacy]
-> retrieved ppx_fail.v0.12.0  (cached)
Processing 29/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_fields_conv.v0.12.0: extract] [num: make opam-legacy]
Processing 30/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_fields_conv.v0.12.0: extract] [ppx_hash.v0.12.0: extract] [num: make opam-legacy]
-> retrieved ppx_fields_conv.v0.12.0  (cached)
Processing 30/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_hash.v0.12.0: extract] [num: make opam-legacy]
Processing 31/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_hash.v0.12.0: extract] [ppx_here.v0.12.0: extract] [num: make opam-legacy]
-> retrieved ppx_hash.v0.12.0  (cached)
Processing 31/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_here.v0.12.0: extract] [num: make opam-legacy]
Processing 32/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_here.v0.12.0: extract] [ppx_inline_test.v0.12.0: extract] [num: make opam-legacy]
-> retrieved ppx_here.v0.12.0  (cached)
Processing 32/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_inline_test.v0.12.0: extract] [num: make opam-legacy]
Processing 33/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_inline_test.v0.12.0: extract] [ppx_jane.v0.12.0: extract] [num: make opam-legacy]
-> retrieved ppx_inline_test.v0.12.0  (cached)
Processing 33/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_jane.v0.12.0: extract] [num: make opam-legacy]
Processing 34/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_jane.v0.12.0: extract] [ppx_js_style.v0.12.0: extract] [num: make opam-legacy]
-> retrieved ppx_jane.v0.12.0  (cached)
Processing 34/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_js_style.v0.12.0: extract] [num: make opam-legacy]
Processing 35/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_js_style.v0.12.0: extract] [ppx_let.v0.12.0: extract] [num: make opam-legacy]
-> retrieved ppx_js_style.v0.12.0  (cached)
Processing 35/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_let.v0.12.0: extract] [num: make opam-legacy]
Processing 36/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_let.v0.12.0: extract] [ppx_module_timer.v0.12.0: extract] [num: make opam-legacy]
-> retrieved ppx_let.v0.12.0  (cached)
Processing 36/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_module_timer.v0.12.0: extract] [num: make opam-legacy]
Processing 37/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_module_timer.v0.12.0: extract] [ppx_optcomp.v0.12.0: extract] [num: make opam-legacy]
-> retrieved ppx_module_timer.v0.12.0  (cached)
Processing 37/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_optcomp.v0.12.0: extract] [num: make opam-legacy]
Processing 38/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_optcomp.v0.12.0: extract] [ppx_optional.v0.12.0: extract] [num: make opam-legacy]
-> retrieved ppx_optcomp.v0.12.0  (cached)
Processing 38/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_optional.v0.12.0: extract] [num: make opam-legacy]
Processing 39/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_optional.v0.12.0: extract] [ppx_pipebang.v0.12.0: extract] [num: make opam-legacy]
-> retrieved ppx_optional.v0.12.0  (cached)
Processing 39/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_pipebang.v0.12.0: extract] [num: make opam-legacy]
Processing 40/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_pipebang.v0.12.0: extract] [ppx_sexp_conv.v0.12.0: extract] [num: make opam-legacy]
-> retrieved ppx_pipebang.v0.12.0  (cached)
Processing 40/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_sexp_conv.v0.12.0: extract] [num: make opam-legacy]
Processing 41/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_sexp_conv.v0.12.0: extract] [ppx_sexp_message.v0.12.0: extract] [num: make opam-legacy]
-> retrieved ppx_sexp_conv.v0.12.0  (cached)
Processing 41/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_sexp_message.v0.12.0: extract] [num: make opam-legacy]
Processing 42/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_sexp_message.v0.12.0: extract] [ppx_sexp_value.v0.12.0: extract] [num: make opam-legacy]
-> retrieved ppx_sexp_message.v0.12.0  (cached)
Processing 42/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_sexp_value.v0.12.0: extract] [num: make opam-legacy]
Processing 43/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_sexp_value.v0.12.0: extract] [ppx_stable.v0.12.0: extract] [num: make opam-legacy]
-> retrieved ppx_sexp_value.v0.12.0  (cached)
Processing 43/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_stable.v0.12.0: extract] [num: make opam-legacy]
Processing 44/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_stable.v0.12.0: extract] [ppx_typerep_conv.v0.12.0: extract] [num: make opam-legacy]
-> retrieved ppx_stable.v0.12.0  (cached)
Processing 44/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_typerep_conv.v0.12.0: extract] [num: make opam-legacy]
Processing 45/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_typerep_conv.v0.12.0: extract] [ppx_variants_conv.v0.12.0: extract] [num: make opam-legacy]
-> retrieved ppx_typerep_conv.v0.12.0  (cached)
Processing 45/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_variants_conv.v0.12.0: extract] [num: make opam-legacy]
Processing 46/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppx_variants_conv.v0.12.0: extract] [ppxlib.0.8.1: extract] [num: make opam-legacy]
-> retrieved ppx_variants_conv.v0.12.0  (cached)
Processing 46/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppxlib.0.8.1: extract] [num: make opam-legacy]
Processing 47/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [ppxlib.0.8.1: extract] [re.1.11.0: extract] [num: make opam-legacy]
-> retrieved ppxlib.0.8.1  (cached)
Processing 47/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [re.1.11.0: extract] [num: make opam-legacy]
Processing 48/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [re.1.11.0: extract] [result.1.5: extract] [num: make opam-legacy]
-> retrieved re.1.11.0  (cached)
Processing 48/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [result.1.5: extract] [num: make opam-legacy]
-> retrieved seq.base  (cached)
Processing 49/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [result.1.5: extract] [num: make opam-legacy]
Processing 50/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [result.1.5: extract] [sexplib.v0.12.0: extract] [num: make opam-legacy]
Processing 51/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [result.1.5: extract] [sexplib.v0.12.0: extract] [num: make opam-legacy]
-> installed seq.base
Processing 52/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [result.1.5: extract] [sexplib.v0.12.0: extract] [num: make opam-legacy]
-> retrieved result.1.5  (cached)
Processing 52/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [sexplib.v0.12.0: extract] [num: make opam-legacy]
Processing 53/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [sexplib.v0.12.0: extract] [sexplib0.v0.12.0: extract] [num: make opam-legacy]
-> retrieved sexplib.v0.12.0  (cached)
Processing 53/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [sexplib0.v0.12.0: extract] [num: make opam-legacy]
Processing 54/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [sexplib0.v0.12.0: extract] [spawn.v0.15.1: extract] [num: make opam-legacy]
-> retrieved sexplib0.v0.12.0  (cached)
Processing 54/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [spawn.v0.15.1: extract] [num: make opam-legacy]
Processing 55/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [spawn.v0.15.1: extract] [splittable_random.v0.12.0: extract] [num: make opam-legacy]
-> retrieved spawn.v0.15.1  (cached)
Processing 55/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [splittable_random.v0.12.0: extract] [num: make opam-legacy]
Processing 56/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [splittable_random.v0.12.0: extract] [stdio.v0.12.0: extract] [num: make opam-legacy]
-> retrieved splittable_random.v0.12.0  (cached)
Processing 56/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [stdio.v0.12.0: extract] [num: make opam-legacy]
Processing 57/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [stdio.v0.12.0: extract] [time_now.v0.12.0: extract] [num: make opam-legacy]
-> retrieved stdio.v0.12.0  (cached)
Processing 57/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [time_now.v0.12.0: extract] [num: make opam-legacy]
Processing 58/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [time_now.v0.12.0: extract] [typerep.v0.12.0: extract] [num: make opam-legacy]
-> retrieved time_now.v0.12.0  (cached)
Processing 58/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [typerep.v0.12.0: extract] [num: make opam-legacy]
Processing 59/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [typerep.v0.12.0: extract] [variantslib.v0.12.0: extract] [num: make opam-legacy]
-> retrieved typerep.v0.12.0  (cached)
Processing 59/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [variantslib.v0.12.0: extract] [num: make opam-legacy]
-> retrieved variantslib.v0.12.0  (cached)
Processing 59/170: [dune.3.16.0, dune-configurator.3.16.0: extract] [num: make opam-legacy]
-> retrieved dune.3.16.0, dune-configurator.3.16.0  (cached)
Processing 59/170: [num: make opam-legacy]
Processing 60/170: [dune: ocaml 255] [num: make opam-legacy]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "make" "PROFILE=release" "opam-legacy" (CWD=/home/opam/.opam/4.08/.opam-switch/build/num.1.5)
- make -C src all
- make[1]: Entering directory '/home/opam/.opam/4.08/.opam-switch/build/num.1.5/src'
- ocamlc -ccopt -DBNG_ARCH_amd64 -c bng.c
- ocamlc -ccopt -DBNG_ARCH_amd64 -c nat_stubs.c
- ocamlmklib -oc nums bng.o nat_stubs.o
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c int_misc.mli
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c int_misc.ml
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c nat.mli
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c nat.ml
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c big_int.mli
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c big_int.ml
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c arith_flags.mli
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c arith_flags.ml
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c ratio.mli
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c ratio.ml
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c num.mli
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c num.ml
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c arith_status.mli
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c arith_status.ml
- ocamlmklib -o nums -oc nums -linkall int_misc.cmo nat.cmo big_int.cmo arith_flags.cmo ratio.cmo num.cmo arith_status.cmo
- cp ../toplevel/num_top_printers.mli ../toplevel/num_top.mli ../toplevel/num_top_printers.ml ../toplevel/num_top.ml .
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c num_top_printers.mli
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c num_top_printers.ml
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c num_top.mli
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c num_top.ml
- ocamlc -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -a -o num_top.cma num_top_printers.cmo num_top.cmo
- echo 'version = "1.6~dev"' > META.top
- cat META.num-top.in >> META.top
- ocamlopt -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c int_misc.ml
- ocamlopt -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c nat.ml
- ocamlopt -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c big_int.ml
- ocamlopt -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c arith_flags.ml
- ocamlopt -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c ratio.ml
- ocamlopt -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c num.ml
- ocamlopt -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -c arith_status.ml
- ocamlmklib -o nums -oc nums -linkall int_misc.cmx nat.cmx big_int.cmx arith_flags.cmx ratio.cmx num.cmx arith_status.cmx
- ocamlopt -w +a-4-9-41-42-44-45-48  -bin-annot -g -safe-string -strict-sequence -strict-formats -I +compiler-libs -I . -shared -o nums.cmxs nums.cmxa
- make[1]: Leaving directory '/home/opam/.opam/4.08/.opam-switch/build/num.1.5/src'
- cp src/num-legacy.install num.install
-> compiled  num.1.5
Processing 60/170: [dune: ocaml 255]
-> installed num.1.5
Processing 61/170: [dune: ocaml 255]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "ocaml" "boot/bootstrap.ml" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/dune.3.16.0)
- ocamlc -custom -w -24 -g -o .duneboot.exe -I boot unix.cma boot/libs.ml boot/duneboot.ml
- ./.duneboot.exe -j 255
- cd _boot && /home/opam/.opam/4.08/bin/ocamlopt.opt -c -g -no-alias-deps -w -49-6 -alert -unstable -I +threads dune_util__Gc.ml
- File "src/dune_util/gc.ml", line 78, characters 5-351:
- Warning 23: all the fields are explicitly listed in this record:
- the 'with' clause is useless.
- 

Processing 61/170: [dune: ./_boot/dune.exe build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "./_boot/dune.exe" "build" "dune.install" "--release" "--profile" "dune-bootstrap" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/dune.3.16.0)
-> compiled  dune.3.16.0
-> installed dune.3.16.0
Processing 63/170: [csexp: dune build]
Processing 64/170: [csexp: dune build] [jane-street-headers: dune build]
Processing 65/170: [csexp: dune build] [jane-street-headers: dune build] [ocaml-compiler-libs: dune build]
Processing 66/170: [csexp: dune build] [jane-street-headers: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build]
Processing 67/170: [csexp: dune build] [jane-street-headers: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [ppx_derivers: dune build]
Processing 68/170: [csexp: dune build] [jane-street-headers: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [ppx_derivers: dune build] [re: dune build]
Processing 69/170: [csexp: dune build] [jane-street-headers: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [ppx_derivers: dune build] [re: dune build] [result: dune build]
Processing 70/170: [csexp: dune build] [jane-street-headers: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [ppx_derivers: dune build] [re: dune build] [result: dune build] [sexplib0: dune build]
Processing 71/170: [csexp: dune build] [jane-street-headers: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [ppx_derivers: dune build] [re: dune build] [result: dune build] [sexplib0: dune build] [spawn: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "jane-street-headers" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/jane-street-headers.v0.12.0)
-> compiled  jane-street-headers.v0.12.0
Processing 71/170: [csexp: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [ppx_derivers: dune build] [re: dune build] [result: dune build] [sexplib0: dune build] [spawn: dune build]
-> installed jane-street-headers.v0.12.0
Processing 72/170: [csexp: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [ppx_derivers: dune build] [re: dune build] [result: dune build] [sexplib0: dune build] [spawn: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_derivers" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_derivers.1.2.1)
-> compiled  ppx_derivers.1.2.1
Processing 72/170: [csexp: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [re: dune build] [result: dune build] [sexplib0: dune build] [spawn: dune build]
-> installed ppx_derivers.1.2.1
Processing 73/170: [csexp: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [re: dune build] [result: dune build] [sexplib0: dune build] [spawn: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "csexp" "-j" "255" "@install" (CWD=/home/opam/.opam/4.08/.opam-switch/build/csexp.1.5.2)
-> compiled  csexp.1.5.2
Processing 73/170: [ocaml-compiler-libs: dune build] [octavius: dune build] [re: dune build] [result: dune build] [sexplib0: dune build] [spawn: dune build]
-> installed csexp.1.5.2
Processing 74/170: [ocaml-compiler-libs: dune build] [octavius: dune build] [re: dune build] [result: dune build] [sexplib0: dune build] [spawn: dune build]
Processing 75/170: [dune-configurator: rm] [ocaml-compiler-libs: dune build] [octavius: dune build] [re: dune build] [result: dune build] [sexplib0: dune build] [spawn: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ocaml-compiler-libs" "-j" "255" "@install" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ocaml-compiler-libs.v0.12.4)
- (cd _build/default && /home/opam/.opam/4.08/bin/ocamlc.opt -w -40 -safe-string -g -bin-annot -I src/ocaml_optcomp/.ocaml_optcomp.objs/byte -I /home/opam/.opam/4.08/lib/ocaml/compiler-libs -no-alias-deps -o src/ocaml_optcomp/.ocaml_optcomp.objs/byte/ocaml_optcomp.cmo -c -impl src/ocaml_optcomp/ocaml_optcomp.ml)
- File "src/ocaml_optcomp/ocaml_optcomp.ml", line 12, characters 42-56:
- 12 | module Available_regs                   = Available_regs
-                                                ^^^^^^^^^^^^^^
- Warning 49: no cmi file was found in path for module Available_regs
- File "src/ocaml_optcomp/ocaml_optcomp.ml", line 87, characters 42-62:
- 87 | module Reg_availability_set             = Reg_availability_set
-                                                ^^^^^^^^^^^^^^^^^^^^
- Warning 49: no cmi file was found in path for module Reg_availability_set
- File "src/ocaml_optcomp/ocaml_optcomp.ml", line 88, characters 42-61:
- 88 | module Reg_with_debug_info              = Reg_with_debug_info
-                                                ^^^^^^^^^^^^^^^^^^^
- Warning 49: no cmi file was found in path for module Reg_with_debug_info
- (cd _build/default && /home/opam/.opam/4.08/bin/ocamlopt.opt -w -40 -safe-string -g -I src/ocaml_optcomp/.ocaml_optcomp.objs/byte -I src/ocaml_optcomp/.ocaml_optcomp.objs/native -I /home/opam/.opam/4.08/lib/ocaml/compiler-libs -intf-suffix .ml -no-alias-deps -o src/ocaml_optcomp/.ocaml_optcomp.objs/native/ocaml_optcomp.cmx -c -impl src/ocaml_optcomp/ocaml_optcomp.ml)
- File "src/ocaml_optcomp/ocaml_optcomp.ml", line 12, characters 42-56:
- 12 | module Available_regs                   = Available_regs
-                                                ^^^^^^^^^^^^^^
- Warning 49: no cmi file was found in path for module Available_regs
- File "src/ocaml_optcomp/ocaml_optcomp.ml", line 87, characters 42-62:
- 87 | module Reg_availability_set             = Reg_availability_set
-                                                ^^^^^^^^^^^^^^^^^^^^
- Warning 49: no cmi file was found in path for module Reg_availability_set
- File "src/ocaml_optcomp/ocaml_optcomp.ml", line 88, characters 42-61:
- 88 | module Reg_with_debug_info              = Reg_with_debug_info
-                                                ^^^^^^^^^^^^^^^^^^^
- Warning 49: no cmi file was found in path for module Reg_with_debug_info
-> compiled  ocaml-compiler-libs.v0.12.4
Processing 75/170: [dune-configurator: rm] [octavius: dune build] [re: dune build] [result: dune build] [sexplib0: dune build] [spawn: dune build]
-> installed ocaml-compiler-libs.v0.12.4
Processing 76/170: [dune-configurator: rm] [octavius: dune build] [re: dune build] [result: dune build] [sexplib0: dune build] [spawn: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "octavius" "-j" "255" "@install" (CWD=/home/opam/.opam/4.08/.opam-switch/build/octavius.1.2.2)
-> compiled  octavius.1.2.2
Processing 76/170: [dune-configurator: rm] [re: dune build] [result: dune build] [sexplib0: dune build] [spawn: dune build]
-> installed octavius.1.2.2
Processing 77/170: [dune-configurator: rm] [re: dune build] [result: dune build] [sexplib0: dune build] [spawn: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "re" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/re.1.11.0)
-> compiled  re.1.11.0
Processing 77/170: [dune-configurator: rm] [result: dune build] [sexplib0: dune build] [spawn: dune build]
-> installed re.1.11.0
Processing 78/170: [dune-configurator: rm] [result: dune build] [sexplib0: dune build] [spawn: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "result" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/result.1.5)
-> compiled  result.1.5
Processing 78/170: [dune-configurator: rm] [sexplib0: dune build] [spawn: dune build]
-> installed result.1.5
Processing 79/170: [dune-configurator: rm] [sexplib0: dune build] [spawn: dune build]
Processing 80/170: [dune-configurator: rm] [ocaml-migrate-parsetree: dune build] [sexplib0: dune build] [spawn: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "sexplib0" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/sexplib0.v0.12.0)
- (cd _build/default && /home/opam/.opam/4.08/bin/ocamlc.opt -w -40 -g -bin-annot -I .sexplib0.objs/byte -intf-suffix .ml -no-alias-deps -open Sexplib0 -o .sexplib0.objs/byte/sexplib0__Sexp_conv.cmo -c -impl sexp_conv.ml)
- File "sexp_conv.ml", line 108, characters 13-29:
- 108 |     let id = Obj.extension_id slot in
-                    ^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_id
- use Obj.Extension_constructor.id
- File "sexp_conv.ml", line 120, characters 13-29:
- 120 |     let id = Obj.extension_id extension_constructor in
-                    ^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_id
- use Obj.Extension_constructor.id
- File "sexp_conv.ml", line 143, characters 19-44:
- 143 |     add ?finalise (Obj.extension_constructor exn) sexp_of_exn
-                          ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- File "sexp_conv.ml", line 146, characters 13-29:
- 146 |     let id = Obj.extension_id (Obj.extension_constructor exn) in
-                    ^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_id
- use Obj.Extension_constructor.id
- File "sexp_conv.ml", line 146, characters 31-56:
- 146 |     let id = Obj.extension_id (Obj.extension_constructor exn) in
-                                      ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- (cd _build/default && /home/opam/.opam/4.08/bin/ocamlopt.opt -w -40 -g -I .sexplib0.objs/byte -I .sexplib0.objs/native -intf-suffix .ml -no-alias-deps -open Sexplib0 -o .sexplib0.objs/native/sexplib0__Sexp_conv.cmx -c -impl sexp_conv.ml)
- File "sexp_conv.ml", line 108, characters 13-29:
- 108 |     let id = Obj.extension_id slot in
-                    ^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_id
- use Obj.Extension_constructor.id
- File "sexp_conv.ml", line 120, characters 13-29:
- 120 |     let id = Obj.extension_id extension_constructor in
-                    ^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_id
- use Obj.Extension_constructor.id
- File "sexp_conv.ml", line 143, characters 19-44:
- 143 |     add ?finalise (Obj.extension_constructor exn) sexp_of_exn
-                          ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- File "sexp_conv.ml", line 146, characters 13-29:
- 146 |     let id = Obj.extension_id (Obj.extension_constructor exn) in
-                    ^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_id
- use Obj.Extension_constructor.id
- File "sexp_conv.ml", line 146, characters 31-56:
- 146 |     let id = Obj.extension_id (Obj.extension_constructor exn) in
-                                      ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
-> compiled  sexplib0.v0.12.0
Processing 80/170: [dune-configurator: rm] [ocaml-migrate-parsetree: dune build] [spawn: dune build]
-> installed sexplib0.v0.12.0
Processing 81/170: [dune-configurator: rm] [ocaml-migrate-parsetree: dune build] [spawn: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "spawn" "-j" "255" "@install" (CWD=/home/opam/.opam/4.08/.opam-switch/build/spawn.v0.15.1)
-> compiled  spawn.v0.15.1
Processing 81/170: [dune-configurator: rm] [ocaml-migrate-parsetree: dune build]
-> installed spawn.v0.15.1
Processing 82/170: [dune-configurator: rm] [ocaml-migrate-parsetree: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "rm" "-rf" "vendor/csexp" (CWD=/home/opam/.opam/4.08/.opam-switch/build/dune-configurator.3.16.0)
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "rm" "-rf" "vendor/pp" (CWD=/home/opam/.opam/4.08/.opam-switch/build/dune-configurator.3.16.0)
Processing 82/170: [dune-configurator: dune build] [ocaml-migrate-parsetree: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "dune-configurator" "-j" "255" "@install" (CWD=/home/opam/.opam/4.08/.opam-switch/build/dune-configurator.3.16.0)
-> compiled  dune-configurator.3.16.0
Processing 82/170: [ocaml-migrate-parsetree: dune build]
-> installed dune-configurator.3.16.0
Processing 83/170: [ocaml-migrate-parsetree: dune build]
Processing 84/170: [base: dune build] [ocaml-migrate-parsetree: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ocaml-migrate-parsetree" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ocaml-migrate-parsetree.1.8.0)
-> compiled  ocaml-migrate-parsetree.1.8.0
Processing 84/170: [base: dune build]
-> installed ocaml-migrate-parsetree.1.8.0
Processing 85/170: [base: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "base" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/base.v0.12.2)
-> compiled  base.v0.12.2
-> installed base.v0.12.2
Processing 87/170: [fieldslib: dune build]
Processing 88/170: [fieldslib: dune build] [parsexp: dune build]
Processing 89/170: [fieldslib: dune build] [parsexp: dune build] [stdio: dune build]
Processing 90/170: [fieldslib: dune build] [parsexp: dune build] [stdio: dune build] [typerep: dune build]
Processing 91/170: [fieldslib: dune build] [parsexp: dune build] [stdio: dune build] [typerep: dune build] [variantslib: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "fieldslib" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/fieldslib.v0.12.0)
-> compiled  fieldslib.v0.12.0
Processing 91/170: [parsexp: dune build] [stdio: dune build] [typerep: dune build] [variantslib: dune build]
-> installed fieldslib.v0.12.0
Processing 92/170: [parsexp: dune build] [stdio: dune build] [typerep: dune build] [variantslib: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "variantslib" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/variantslib.v0.12.0)
-> compiled  variantslib.v0.12.0
Processing 92/170: [parsexp: dune build] [stdio: dune build] [typerep: dune build]
-> installed variantslib.v0.12.0
Processing 93/170: [parsexp: dune build] [stdio: dune build] [typerep: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "stdio" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/stdio.v0.12.0)
-> compiled  stdio.v0.12.0
Processing 93/170: [parsexp: dune build] [typerep: dune build]
-> installed stdio.v0.12.0
Processing 94/170: [parsexp: dune build] [typerep: dune build]
Processing 95/170: [parsexp: dune build] [ppxlib: dune build] [typerep: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "typerep" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/typerep.v0.12.0)
-> compiled  typerep.v0.12.0
Processing 95/170: [parsexp: dune build] [ppxlib: dune build]
-> installed typerep.v0.12.0
Processing 96/170: [parsexp: dune build] [ppxlib: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "parsexp" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/parsexp.v0.12.0)
-> compiled  parsexp.v0.12.0
Processing 96/170: [ppxlib: dune build]
-> installed parsexp.v0.12.0
Processing 97/170: [ppxlib: dune build]
Processing 98/170: [ppxlib: dune build] [sexplib: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "sexplib" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/sexplib.v0.12.0)
- (cd _build/default && /home/opam/.opam/4.08/bin/ocamlc.opt -w -40 -g -bin-annot -I src/.sexplib.objs/byte -I /home/opam/.opam/4.08/lib/base/caml -I /home/opam/.opam/4.08/lib/parsexp -I /home/opam/.opam/4.08/lib/sexplib0 -intf-suffix .ml -no-alias-deps -open Sexplib -o src/.sexplib.objs/byte/sexplib__Exn_magic.cmo -c -impl src/exn_magic.ml)
- File "src/exn_magic.ml", line 2, characters 26-51:
- 2 |   Conv.Exn_converter.add (Obj.extension_constructor exc) (fun _exc -> Sexp.Atom exc_name)
-                               ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- File "src/exn_magic.ml", line 12, characters 26-51:
- 12 |   Conv.Exn_converter.add (Obj.extension_constructor exc) (fun exc ->
-                                ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- File "src/exn_magic.ml", line 26, characters 26-51:
- 26 |   Conv.Exn_converter.add (Obj.extension_constructor exc) (fun exc ->
-                                ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- File "src/exn_magic.ml", line 41, characters 26-51:
- 41 |   Conv.Exn_converter.add (Obj.extension_constructor exc) (fun exc ->
-                                ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- File "src/exn_magic.ml", line 57, characters 26-51:
- 57 |   Conv.Exn_converter.add (Obj.extension_constructor exc) (fun exc ->
-                                ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- File "src/exn_magic.ml", line 74, characters 26-51:
- 74 |   Conv.Exn_converter.add (Obj.extension_constructor exc) (fun exc ->
-                                ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- File "src/exn_magic.ml", line 94, characters 26-51:
- 94 |   Conv.Exn_converter.add (Obj.extension_constructor exc) (fun exc ->
-                                ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- File "src/exn_magic.ml", line 115, characters 26-51:
- 115 |   Conv.Exn_converter.add (Obj.extension_constructor exc) (fun exc ->
-                                 ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- File "src/exn_magic.ml", line 137, characters 26-51:
- 137 |   Conv.Exn_converter.add (Obj.extension_constructor exc) (fun exc ->
-                                 ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- File "src/exn_magic.ml", line 160, characters 26-51:
- 160 |   Conv.Exn_converter.add (Obj.extension_constructor exc) (fun exc ->
-                                 ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- File "src/exn_magic.ml", line 184, characters 26-51:
- 184 |   Conv.Exn_converter.add (Obj.extension_constructor exc) (fun exc ->
-                                 ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- (cd _build/default && /home/opam/.opam/4.08/bin/ocamlopt.opt -w -40 -g -I src/.sexplib.objs/byte -I src/.sexplib.objs/native -I /home/opam/.opam/4.08/lib/base/caml -I /home/opam/.opam/4.08/lib/parsexp -I /home/opam/.opam/4.08/lib/sexplib0 -intf-suffix .ml -no-alias-deps -open Sexplib -o src/.sexplib.objs/native/sexplib__Exn_magic.cmx -c -impl src/exn_magic.ml)
- File "src/exn_magic.ml", line 2, characters 26-51:
- 2 |   Conv.Exn_converter.add (Obj.extension_constructor exc) (fun _exc -> Sexp.Atom exc_name)
-                               ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- File "src/exn_magic.ml", line 12, characters 26-51:
- 12 |   Conv.Exn_converter.add (Obj.extension_constructor exc) (fun exc ->
-                                ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- File "src/exn_magic.ml", line 26, characters 26-51:
- 26 |   Conv.Exn_converter.add (Obj.extension_constructor exc) (fun exc ->
-                                ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- File "src/exn_magic.ml", line 41, characters 26-51:
- 41 |   Conv.Exn_converter.add (Obj.extension_constructor exc) (fun exc ->
-                                ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- File "src/exn_magic.ml", line 57, characters 26-51:
- 57 |   Conv.Exn_converter.add (Obj.extension_constructor exc) (fun exc ->
-                                ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- File "src/exn_magic.ml", line 74, characters 26-51:
- 74 |   Conv.Exn_converter.add (Obj.extension_constructor exc) (fun exc ->
-                                ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- File "src/exn_magic.ml", line 94, characters 26-51:
- 94 |   Conv.Exn_converter.add (Obj.extension_constructor exc) (fun exc ->
-                                ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- File "src/exn_magic.ml", line 115, characters 26-51:
- 115 |   Conv.Exn_converter.add (Obj.extension_constructor exc) (fun exc ->
-                                 ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- File "src/exn_magic.ml", line 137, characters 26-51:
- 137 |   Conv.Exn_converter.add (Obj.extension_constructor exc) (fun exc ->
-                                 ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- File "src/exn_magic.ml", line 160, characters 26-51:
- 160 |   Conv.Exn_converter.add (Obj.extension_constructor exc) (fun exc ->
-                                 ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- File "src/exn_magic.ml", line 184, characters 26-51:
- 184 |   Conv.Exn_converter.add (Obj.extension_constructor exc) (fun exc ->
-                                 ^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
-> compiled  sexplib.v0.12.0
Processing 98/170: [ppxlib: dune build]
-> installed sexplib.v0.12.0
Processing 99/170: [ppxlib: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppxlib" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppxlib.0.8.1)
-> compiled  ppxlib.0.8.1
-> installed ppxlib.0.8.1
Processing 101/170: [ppx_compare: dune build]
Processing 102/170: [ppx_compare: dune build] [ppx_enumerate: dune build]
Processing 103/170: [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build]
Processing 104/170: [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_here: dune build]
Processing 105/170: [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_here: dune build] [ppx_inline_test: dune build]
Processing 106/170: [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_here: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build]
Processing 107/170: [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_here: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_let: dune build]
Processing 108/170: [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_here: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optcomp: dune build]
Processing 109/170: [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_here: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build]
Processing 110/170: [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_here: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build]
Processing 111/170: [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_here: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build]
Processing 112/170: [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_here: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build]
Processing 113/170: [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_here: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build]
Processing 114/170: [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_here: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_optcomp" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_optcomp.v0.12.0)
-> compiled  ppx_optcomp.v0.12.0
Processing 114/170: [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_here: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
-> installed ppx_optcomp.v0.12.0
Processing 115/170: [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_here: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_here" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_here.v0.12.0)
-> compiled  ppx_here.v0.12.0
Processing 115/170: [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
-> installed ppx_here.v0.12.0
Processing 116/170: [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
Processing 117/170: [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fail: dune build] [ppx_fields_conv: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_let" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_let.v0.12.0)
-> compiled  ppx_let.v0.12.0
Processing 117/170: [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fail: dune build] [ppx_fields_conv: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
-> installed ppx_let.v0.12.0
Processing 118/170: [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fail: dune build] [ppx_fields_conv: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_enumerate" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_enumerate.v0.12.0)
-> compiled  ppx_enumerate.v0.12.0
Processing 118/170: [ppx_compare: dune build] [ppx_fail: dune build] [ppx_fields_conv: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
-> installed ppx_enumerate.v0.12.0
Processing 119/170: [ppx_compare: dune build] [ppx_fail: dune build] [ppx_fields_conv: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_fields_conv" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_fields_conv.v0.12.0)
-> compiled  ppx_fields_conv.v0.12.0
Processing 119/170: [ppx_compare: dune build] [ppx_fail: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
-> installed ppx_fields_conv.v0.12.0
Processing 120/170: [ppx_compare: dune build] [ppx_fail: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_compare" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_compare.v0.12.0)
-> compiled  ppx_compare.v0.12.0
Processing 120/170: [ppx_fail: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
-> installed ppx_compare.v0.12.0
Processing 121/170: [ppx_fail: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_optional" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_optional.v0.12.0)
-> compiled  ppx_optional.v0.12.0
Processing 121/170: [ppx_fail: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
-> installed ppx_optional.v0.12.0
Processing 122/170: [ppx_fail: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_stable" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_stable.v0.12.0)
-> compiled  ppx_stable.v0.12.0
Processing 122/170: [ppx_fail: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
-> installed ppx_stable.v0.12.0
Processing 123/170: [ppx_fail: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_typerep_conv" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_typerep_conv.v0.12.0)
-> compiled  ppx_typerep_conv.v0.12.0
Processing 123/170: [ppx_fail: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_variants_conv: dune build]
-> installed ppx_typerep_conv.v0.12.0
Processing 124/170: [ppx_fail: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_variants_conv" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_variants_conv.v0.12.0)
-> compiled  ppx_variants_conv.v0.12.0
Processing 124/170: [ppx_fail: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build]
-> installed ppx_variants_conv.v0.12.0
Processing 125/170: [ppx_fail: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_sexp_conv" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_sexp_conv.v0.12.0)
-> compiled  ppx_sexp_conv.v0.12.0
Processing 125/170: [ppx_fail: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_pipebang: dune build]
-> installed ppx_sexp_conv.v0.12.0
Processing 126/170: [ppx_fail: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_pipebang: dune build]
Processing 127/170: [ppx_assert: dune build] [ppx_fail: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_pipebang: dune build]
Processing 128/170: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_fail: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_pipebang: dune build]
Processing 129/170: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_fail: dune build] [ppx_hash: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_pipebang: dune build]
Processing 130/170: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_fail: dune build] [ppx_hash: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_pipebang: dune build] [ppx_sexp_message: dune build]
Processing 131/170: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_fail: dune build] [ppx_hash: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_pipebang: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_pipebang" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_pipebang.v0.12.0)
-> compiled  ppx_pipebang.v0.12.0
Processing 131/170: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_fail: dune build] [ppx_hash: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
-> installed ppx_pipebang.v0.12.0
Processing 132/170: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_fail: dune build] [ppx_hash: dune build] [ppx_inline_test: dune build] [ppx_js_style: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_inline_test" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_inline_test.v0.12.0)
-> compiled  ppx_inline_test.v0.12.0
Processing 132/170: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_fail: dune build] [ppx_hash: dune build] [ppx_js_style: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
-> installed ppx_inline_test.v0.12.0
Processing 133/170: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_fail: dune build] [ppx_hash: dune build] [ppx_js_style: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
Processing 134/170: [ppx_assert: dune build] [ppx_bench: dune build] [ppx_custom_printf: dune build] [ppx_fail: dune build] [ppx_hash: dune build] [ppx_js_style: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_js_style" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_js_style.v0.12.0)
-> compiled  ppx_js_style.v0.12.0
Processing 134/170: [ppx_assert: dune build] [ppx_bench: dune build] [ppx_custom_printf: dune build] [ppx_fail: dune build] [ppx_hash: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
-> installed ppx_js_style.v0.12.0
Processing 135/170: [ppx_assert: dune build] [ppx_bench: dune build] [ppx_custom_printf: dune build] [ppx_fail: dune build] [ppx_hash: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_fail" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_fail.v0.12.0)
-> compiled  ppx_fail.v0.12.0
Processing 135/170: [ppx_assert: dune build] [ppx_bench: dune build] [ppx_custom_printf: dune build] [ppx_hash: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
-> installed ppx_fail.v0.12.0
Processing 136/170: [ppx_assert: dune build] [ppx_bench: dune build] [ppx_custom_printf: dune build] [ppx_hash: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_hash" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_hash.v0.12.0)
-> compiled  ppx_hash.v0.12.0
Processing 136/170: [ppx_assert: dune build] [ppx_bench: dune build] [ppx_custom_printf: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
-> installed ppx_hash.v0.12.0
Processing 137/170: [ppx_assert: dune build] [ppx_bench: dune build] [ppx_custom_printf: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
Processing 138/170: [ppx_assert: dune build] [ppx_base: dune build] [ppx_bench: dune build] [ppx_custom_printf: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_sexp_message" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_sexp_message.v0.12.0)
-> compiled  ppx_sexp_message.v0.12.0
Processing 138/170: [ppx_assert: dune build] [ppx_base: dune build] [ppx_bench: dune build] [ppx_custom_printf: dune build] [ppx_sexp_value: dune build]
-> installed ppx_sexp_message.v0.12.0
Processing 139/170: [ppx_assert: dune build] [ppx_base: dune build] [ppx_bench: dune build] [ppx_custom_printf: dune build] [ppx_sexp_value: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_assert" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_assert.v0.12.0)
-> compiled  ppx_assert.v0.12.0
Processing 139/170: [ppx_base: dune build] [ppx_bench: dune build] [ppx_custom_printf: dune build] [ppx_sexp_value: dune build]
-> installed ppx_assert.v0.12.0
Processing 140/170: [ppx_base: dune build] [ppx_bench: dune build] [ppx_custom_printf: dune build] [ppx_sexp_value: dune build]
Processing 141/170: [jst-config: dune build] [ppx_base: dune build] [ppx_bench: dune build] [ppx_custom_printf: dune build] [ppx_sexp_value: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_sexp_value" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_sexp_value.v0.12.0)
-> compiled  ppx_sexp_value.v0.12.0
Processing 141/170: [jst-config: dune build] [ppx_base: dune build] [ppx_bench: dune build] [ppx_custom_printf: dune build]
-> installed ppx_sexp_value.v0.12.0
Processing 142/170: [jst-config: dune build] [ppx_base: dune build] [ppx_bench: dune build] [ppx_custom_printf: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_bench" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_bench.v0.12.0)
-> compiled  ppx_bench.v0.12.0
Processing 142/170: [jst-config: dune build] [ppx_base: dune build] [ppx_custom_printf: dune build]
-> installed ppx_bench.v0.12.0
Processing 143/170: [jst-config: dune build] [ppx_base: dune build] [ppx_custom_printf: dune build]
Processing 144/170: [jst-config: dune build] [ppx_base: dune build] [ppx_custom_printf: dune build] [splittable_random: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_custom_printf" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_custom_printf.v0.12.1)
-> compiled  ppx_custom_printf.v0.12.1
Processing 144/170: [jst-config: dune build] [ppx_base: dune build] [splittable_random: dune build]
-> installed ppx_custom_printf.v0.12.1
Processing 145/170: [jst-config: dune build] [ppx_base: dune build] [splittable_random: dune build]
Processing 146/170: [bin_prot: dune build] [jst-config: dune build] [ppx_base: dune build] [splittable_random: dune build]
Processing 147/170: [bin_prot: dune build] [jst-config: dune build] [ppx_base: dune build] [ppx_expect: dune build] [splittable_random: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_base" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_base.v0.12.0)
-> compiled  ppx_base.v0.12.0
Processing 147/170: [bin_prot: dune build] [jst-config: dune build] [ppx_expect: dune build] [splittable_random: dune build]
-> installed ppx_base.v0.12.0
Processing 148/170: [bin_prot: dune build] [jst-config: dune build] [ppx_expect: dune build] [splittable_random: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "splittable_random" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/splittable_random.v0.12.0)
-> compiled  splittable_random.v0.12.0
Processing 148/170: [bin_prot: dune build] [jst-config: dune build] [ppx_expect: dune build]
-> installed splittable_random.v0.12.0
Processing 149/170: [bin_prot: dune build] [jst-config: dune build] [ppx_expect: dune build]
Processing 150/170: [base_quickcheck: dune build] [bin_prot: dune build] [jst-config: dune build] [ppx_expect: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "jst-config" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/jst-config.v0.12.0)
-> compiled  jst-config.v0.12.0
Processing 150/170: [base_quickcheck: dune build] [bin_prot: dune build] [ppx_expect: dune build]
-> installed jst-config.v0.12.0
Processing 151/170: [base_quickcheck: dune build] [bin_prot: dune build] [ppx_expect: dune build]
Processing 152/170: [base_quickcheck: dune build] [bin_prot: dune build] [ppx_expect: dune build] [time_now: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "bin_prot" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/bin_prot.v0.12.0)
-> compiled  bin_prot.v0.12.0
Processing 152/170: [base_quickcheck: dune build] [ppx_expect: dune build] [time_now: dune build]
-> installed bin_prot.v0.12.0
Processing 153/170: [base_quickcheck: dune build] [ppx_expect: dune build] [time_now: dune build]
Processing 154/170: [base_quickcheck: dune build] [ppx_bin_prot: dune build] [ppx_expect: dune build] [time_now: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_expect" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_expect.v0.12.0)
- (cd _build/default && /home/opam/.opam/4.08/bin/ocamlc.opt -w -40 -g -bin-annot -I collector/.expect_test_collector.objs/byte -I /home/opam/.opam/4.08/lib/base -I /home/opam/.opam/4.08/lib/base/caml -I /home/opam/.opam/4.08/lib/base/shadow_stdlib -I /home/opam/.opam/4.08/lib/fieldslib -I /home/opam/.opam/4.08/lib/ppx_compare/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_inline_test/config -I /home/opam/.opam/4.08/lib/ppx_inline_test/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_sexp_conv/runtime-lib -I /home/opam/.opam/4.08/lib/sexplib0 -I common/.expect_test_common.objs/byte -I config/.expect_test_config.objs/byte -intf-suffix .ml -no-alias-deps -open Expect_test_collector__ -o collector/.expect_test_collector.objs/byte/expect_test_collector.cmo -c -impl collector/expect_test_collector.pp.ml)
- File "collector/expect_test_collector.ml", line 61, characters 17-34:
- 61 |       Caml.flush Pervasives.stderr;
-                       ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- (cd _build/default && /home/opam/.opam/4.08/bin/ocamlc.opt -w -40 -g -bin-annot -I evaluator/.ppx_expect_evaluator.objs/byte -I /home/opam/.opam/4.08/lib/base -I /home/opam/.opam/4.08/lib/base/caml -I /home/opam/.opam/4.08/lib/base/shadow_stdlib -I /home/opam/.opam/4.08/lib/fieldslib -I /home/opam/.opam/4.08/lib/ppx_assert/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_compare/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_inline_test/config -I /home/opam/.opam/4.08/lib/ppx_inline_test/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_sexp_conv/runtime-lib -I /home/opam/.opam/4.08/lib/ppxlib/print_diff -I /home/opam/.opam/4.08/lib/re -I /home/opam/.opam/4.08/lib/seq -I /home/opam/.opam/4.08/lib/sexplib0 -I /home/opam/.opam/4.08/lib/stdio -I /home/opam/.opam/4.08/lib/variantslib -I collector/.expect_test_collector.objs/byte -I common/.expect_test_common.objs/byte -I config/.expect_test_config.objs/byte -I matcher/.expect_test_matcher.objs/byte -intf-suffix .ml -no-alias-deps -o evaluator/.ppx_expect_evaluator.objs/byte/ppx_expect_evaluator.cmo -c -impl evaluator/ppx_expect_evaluator.pp.ml)
- File "evaluator/ppx_expect_evaluator.ml", line 37, characters 12-42:
- 37 |             Caml.Obj.extension_constructor exn
-                  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Caml.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- File "evaluator/ppx_expect_evaluator.ml", line 38, characters 15-38:
- 38 |             |> Caml.Obj.extension_name
-                     ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Caml.Obj.extension_name
- use Obj.Extension_constructor.name
- (cd _build/default && /home/opam/.opam/4.08/bin/ocamlopt.opt -w -40 -g -I collector/.expect_test_collector.objs/byte -I collector/.expect_test_collector.objs/native -I /home/opam/.opam/4.08/lib/base -I /home/opam/.opam/4.08/lib/base/caml -I /home/opam/.opam/4.08/lib/base/shadow_stdlib -I /home/opam/.opam/4.08/lib/fieldslib -I /home/opam/.opam/4.08/lib/ppx_compare/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_inline_test/config -I /home/opam/.opam/4.08/lib/ppx_inline_test/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_sexp_conv/runtime-lib -I /home/opam/.opam/4.08/lib/sexplib0 -I common/.expect_test_common.objs/byte -I common/.expect_test_common.objs/native -I config/.expect_test_config.objs/byte -I config/.expect_test_config.objs/native -intf-suffix .ml -no-alias-deps -open Expect_test_collector__ -o collector/.expect_test_collector.objs/native/expect_test_collector.cmx -c -impl collector/expect_test_collector.pp.ml)
- File "collector/expect_test_collector.ml", line 61, characters 17-34:
- 61 |       Caml.flush Pervasives.stderr;
-                       ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- (cd _build/default && /home/opam/.opam/4.08/bin/ocamlopt.opt -w -40 -g -I evaluator/.ppx_expect_evaluator.objs/byte -I evaluator/.ppx_expect_evaluator.objs/native -I /home/opam/.opam/4.08/lib/base -I /home/opam/.opam/4.08/lib/base/caml -I /home/opam/.opam/4.08/lib/base/shadow_stdlib -I /home/opam/.opam/4.08/lib/fieldslib -I /home/opam/.opam/4.08/lib/ppx_assert/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_compare/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_inline_test/config -I /home/opam/.opam/4.08/lib/ppx_inline_test/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_sexp_conv/runtime-lib -I /home/opam/.opam/4.08/lib/ppxlib/print_diff -I /home/opam/.opam/4.08/lib/re -I /home/opam/.opam/4.08/lib/seq -I /home/opam/.opam/4.08/lib/sexplib0 -I /home/opam/.opam/4.08/lib/stdio -I /home/opam/.opam/4.08/lib/variantslib -I collector/.expect_test_collector.objs/byte -I collector/.expect_test_collector.objs/native -I common/.expect_test_common.objs/byte -I common/.expect_test_common.objs/native -I config/.expect_test_config.objs/byte -I config/.expect_test_config.objs/native -I matcher/.expect_test_matcher.objs/byte -I matcher/.expect_test_matcher.objs/native -intf-suffix .ml -no-alias-deps -o evaluator/.ppx_expect_evaluator.objs/native/ppx_expect_evaluator.cmx -c -impl evaluator/ppx_expect_evaluator.pp.ml)
- File "evaluator/ppx_expect_evaluator.ml", line 37, characters 12-42:
- 37 |             Caml.Obj.extension_constructor exn
-                  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Caml.Obj.extension_constructor
- use Obj.Extension_constructor.of_val
- File "evaluator/ppx_expect_evaluator.ml", line 38, characters 15-38:
- 38 |             |> Caml.Obj.extension_name
-                     ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Caml.Obj.extension_name
- use Obj.Extension_constructor.name
-> compiled  ppx_expect.v0.12.0
Processing 154/170: [base_quickcheck: dune build] [ppx_bin_prot: dune build] [time_now: dune build]
-> installed ppx_expect.v0.12.0
Processing 155/170: [base_quickcheck: dune build] [ppx_bin_prot: dune build] [time_now: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "time_now" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/time_now.v0.12.0)
-> compiled  time_now.v0.12.0
Processing 155/170: [base_quickcheck: dune build] [ppx_bin_prot: dune build]
-> installed time_now.v0.12.0
Processing 156/170: [base_quickcheck: dune build] [ppx_bin_prot: dune build]
Processing 157/170: [base_quickcheck: dune build] [ppx_bin_prot: dune build] [ppx_module_timer: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "base_quickcheck" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/base_quickcheck.v0.12.1)
-> compiled  base_quickcheck.v0.12.1
Processing 157/170: [ppx_bin_prot: dune build] [ppx_module_timer: dune build]
-> installed base_quickcheck.v0.12.1
Processing 158/170: [ppx_bin_prot: dune build] [ppx_module_timer: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_bin_prot" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_bin_prot.v0.12.1)
-> compiled  ppx_bin_prot.v0.12.1
Processing 158/170: [ppx_module_timer: dune build]
-> installed ppx_bin_prot.v0.12.1
Processing 159/170: [ppx_module_timer: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_module_timer" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_module_timer.v0.12.0)
-> compiled  ppx_module_timer.v0.12.0
-> installed ppx_module_timer.v0.12.0
Processing 161/170: [ppx_jane: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_jane" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/ppx_jane.v0.12.0)
-> compiled  ppx_jane.v0.12.0
-> installed ppx_jane.v0.12.0
Processing 163/170: [base_bigstring: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "base_bigstring" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/base_bigstring.v0.12.0)
-> compiled  base_bigstring.v0.12.0
-> installed base_bigstring.v0.12.0
Processing 165/170: [core_kernel: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "core_kernel" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/core_kernel.v0.12.3)
- (cd _build/default/src && /usr/bin/gcc -O2 -fno-strict-aliasing -fwrapv -fcommon -fPIC -D_FILE_OFFSET_BITS=64 -D_REENTRANT -O2 -fno-strict-aliasing -fwrapv -fcommon -fPIC -D_LARGEFILE64_SOURCE -g -I /home/opam/.opam/4.08/lib/ocaml -I /home/opam/.opam/4.08/lib/base -I /home/opam/.opam/4.08/lib/base/caml -I /home/opam/.opam/4.08/lib/base/md5 -I /home/opam/.opam/4.08/lib/base/shadow_stdlib -I /home/opam/.opam/4.08/lib/base_bigstring -I /home/opam/.opam/4.08/lib/base_quickcheck -I /home/opam/.opam/4.08/lib/bin_prot -I /home/opam/.opam/4.08/lib/bin_prot/shape -I /home/opam/.opam/4.08/lib/fieldslib -I /home/opam/.opam/4.08/lib/jane-street-headers -I /home/opam/.opam/4.08/lib/parsexp -I /home/opam/.opam/4.08/lib/ppx_assert/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_bench/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_compare/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_enumerate/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_expect/collector -I /home/opam/.opam/4.08/lib/ppx_expect/common -I /home/opam/.opam/4.08/lib/ppx_expect/config -I /home/opam/.opam/4.08/lib/ppx_hash/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_inline_test/config -I /home/opam/.opam/4.08/lib/ppx_inline_test/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_module_timer/runtime -I /home/opam/.opam/4.08/lib/ppx_sexp_conv/runtime-lib -I /home/opam/.opam/4.08/lib/sexplib -I /home/opam/.opam/4.08/lib/sexplib0 -I /home/opam/.opam/4.08/lib/splittable_random -I /home/opam/.opam/4.08/lib/stdio -I /home/opam/.opam/4.08/lib/time_now -I /home/opam/.opam/4.08/lib/typerep -I /home/opam/.opam/4.08/lib/variantslib -I ../base_for_tests/src -o md5_stubs.o -c md5_stubs.c)
- md5_stubs.c:11:32: warning: '-pedantic' is not an option that controls warnings [-Wpragmas]
-    11 | #pragma GCC diagnostic ignored "-pedantic"
-       |                                ^~~~~~~~~~~
- (cd _build/default && /home/opam/.opam/4.08/bin/ocamlc.opt -w -40 -g -bin-annot -I src/.core_kernel.objs/byte -I /home/opam/.opam/4.08/lib/base -I /home/opam/.opam/4.08/lib/base/caml -I /home/opam/.opam/4.08/lib/base/md5 -I /home/opam/.opam/4.08/lib/base/shadow_stdlib -I /home/opam/.opam/4.08/lib/base_bigstring -I /home/opam/.opam/4.08/lib/base_quickcheck -I /home/opam/.opam/4.08/lib/bin_prot -I /home/opam/.opam/4.08/lib/bin_prot/shape -I /home/opam/.opam/4.08/lib/fieldslib -I /home/opam/.opam/4.08/lib/jane-street-headers -I /home/opam/.opam/4.08/lib/parsexp -I /home/opam/.opam/4.08/lib/ppx_assert/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_bench/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_compare/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_enumerate/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_expect/collector -I /home/opam/.opam/4.08/lib/ppx_expect/common -I /home/opam/.opam/4.08/lib/ppx_expect/config -I /home/opam/.opam/4.08/lib/ppx_hash/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_inline_test/config -I /home/opam/.opam/4.08/lib/ppx_inline_test/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_module_timer/runtime -I /home/opam/.opam/4.08/lib/ppx_sexp_conv/runtime-lib -I /home/opam/.opam/4.08/lib/sexplib -I /home/opam/.opam/4.08/lib/sexplib0 -I /home/opam/.opam/4.08/lib/splittable_random -I /home/opam/.opam/4.08/lib/stdio -I /home/opam/.opam/4.08/lib/time_now -I /home/opam/.opam/4.08/lib/typerep -I /home/opam/.opam/4.08/lib/variantslib -I base_for_tests/src/.base_for_tests.objs/byte -intf-suffix .ml -no-alias-deps -open Core_kernel__ -o src/.core_kernel.objs/byte/core_kernel__Zone.cmo -c -impl src/zone.pp.ml)
- File "src/zone.ml", line 323, characters 18-37:
- 323 |           let _ = input_tz_file_v1 ic in
-                         ^^^^^^^^^^^^^^^^^^^
- Warning 5: this function application is partial,
- maybe some arguments are missing.
- (cd _build/default && /home/opam/.opam/4.08/bin/ocamlopt.opt -w -40 -g -I src/.core_kernel.objs/byte -I src/.core_kernel.objs/native -I /home/opam/.opam/4.08/lib/base -I /home/opam/.opam/4.08/lib/base/caml -I /home/opam/.opam/4.08/lib/base/md5 -I /home/opam/.opam/4.08/lib/base/shadow_stdlib -I /home/opam/.opam/4.08/lib/base_bigstring -I /home/opam/.opam/4.08/lib/base_quickcheck -I /home/opam/.opam/4.08/lib/bin_prot -I /home/opam/.opam/4.08/lib/bin_prot/shape -I /home/opam/.opam/4.08/lib/fieldslib -I /home/opam/.opam/4.08/lib/jane-street-headers -I /home/opam/.opam/4.08/lib/parsexp -I /home/opam/.opam/4.08/lib/ppx_assert/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_bench/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_compare/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_enumerate/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_expect/collector -I /home/opam/.opam/4.08/lib/ppx_expect/common -I /home/opam/.opam/4.08/lib/ppx_expect/config -I /home/opam/.opam/4.08/lib/ppx_hash/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_inline_test/config -I /home/opam/.opam/4.08/lib/ppx_inline_test/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_module_timer/runtime -I /home/opam/.opam/4.08/lib/ppx_sexp_conv/runtime-lib -I /home/opam/.opam/4.08/lib/sexplib -I /home/opam/.opam/4.08/lib/sexplib0 -I /home/opam/.opam/4.08/lib/splittable_random -I /home/opam/.opam/4.08/lib/stdio -I /home/opam/.opam/4.08/lib/time_now -I /home/opam/.opam/4.08/lib/typerep -I /home/opam/.opam/4.08/lib/variantslib -I base_for_tests/src/.base_for_tests.objs/byte -I base_for_tests/src/.base_for_tests.objs/native -intf-suffix .ml -no-alias-deps -open Core_kernel__ -o src/.core_kernel.objs/native/core_kernel__Zone.cmx -c -impl src/zone.pp.ml)
- File "src/zone.ml", line 323, characters 18-37:
- 323 |           let _ = input_tz_file_v1 ic in
-                         ^^^^^^^^^^^^^^^^^^^
- Warning 5: this function application is partial,
- maybe some arguments are missing.
-> compiled  core_kernel.v0.12.3
-> installed core_kernel.v0.12.3
Processing 167/170: [core: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "core" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/core.v0.12.4)
- (cd _build/default && /home/opam/.opam/4.08/bin/ocamlopt.opt -w -40 -g -I src/.core.objs/byte -I src/.core.objs/native -I /home/opam/.opam/4.08/lib/base -I /home/opam/.opam/4.08/lib/base/caml -I /home/opam/.opam/4.08/lib/base/md5 -I /home/opam/.opam/4.08/lib/base/shadow_stdlib -I /home/opam/.opam/4.08/lib/base_bigstring -I /home/opam/.opam/4.08/lib/base_quickcheck -I /home/opam/.opam/4.08/lib/bin_prot -I /home/opam/.opam/4.08/lib/bin_prot/shape -I /home/opam/.opam/4.08/lib/core_kernel -I /home/opam/.opam/4.08/lib/core_kernel/base_for_tests -I /home/opam/.opam/4.08/lib/fieldslib -I /home/opam/.opam/4.08/lib/jane-street-headers -I /home/opam/.opam/4.08/lib/ocaml/threads -I /home/opam/.opam/4.08/lib/parsexp -I /home/opam/.opam/4.08/lib/ppx_assert/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_bench/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_compare/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_enumerate/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_expect/collector -I /home/opam/.opam/4.08/lib/ppx_expect/common -I /home/opam/.opam/4.08/lib/ppx_expect/config -I /home/opam/.opam/4.08/lib/ppx_hash/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_inline_test/config -I /home/opam/.opam/4.08/lib/ppx_inline_test/runtime-lib -I /home/opam/.opam/4.08/lib/ppx_module_timer/runtime -I /home/opam/.opam/4.08/lib/ppx_sexp_conv/runtime-lib -I /home/opam/.opam/4.08/lib/sexplib -I /home/opam/.opam/4.08/lib/sexplib/unix -I /home/opam/.opam/4.08/lib/sexplib0 -I /home/opam/.opam/4.08/lib/spawn -I /home/opam/.opam/4.08/lib/splittable_random -I /home/opam/.opam/4.08/lib/stdio -I /home/opam/.opam/4.08/lib/time_now -I /home/opam/.opam/4.08/lib/typerep -I /home/opam/.opam/4.08/lib/variantslib -intf-suffix .ml -no-alias-deps -open Core__ -o src/.core.objs/native/core__Iobuf.cmx -c -impl src/iobuf.pp.ml)
- File "src/iobuf.ml", line 1080, characters 4-62:
- 1080 |     (set_bounds_and_buffer_sub [@inlined]) ~pos ~len ~src ~dst
-            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 55: Cannot inline: Function information unavailable
-> compiled  core.v0.12.4
-> installed core.v0.12.4
Processing 169/170: [bson2: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "bson2" "-j" "255" (CWD=/home/opam/.opam/4.08/.opam-switch/build/bson2.0.0.1)
-> compiled  bson2.0.0.1
-> installed bson2.0.0.1
Done.

<><> ocaml-migrate-parsetree.1.8.0 installed successfully <><><><><><><><><><><>
=> Note: This package is deprecated.
# Run eval $(opam env) to update the current shell environment
2024-06-30 21:13.07 ---> saved as "ff3236c4bdad13ac3b6d2ffc6c7dfb13b257e8011226b924c2b3a4fa4aa12045"
Job succeeded