OCamllabs icon Home|Differences with the last checks|Previous runs


Building on x86-bm-c7.sw.ocaml.org

(from ocaml/opam:debian-unstable)
2024-06-30 18:26.26 ---> using "0acd5aeaa8f7bc314514d9795d14a7f12ec72a6a5b11c5904350189734c6859b" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2024-06-30 18:26.26 ---> using "65c3237f501f7c75f3828458ecf2342bc41c98aaef8c6a7fd82bf46a58cb258c" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q 3bcb45c36ed254e850b498bff678e3e5848b23e1"))
2024-06-30 18:26.26 ---> using "3d0bfbfa177ca2531fcfa9e2869627278a2c31cf290ac589bbf0639aba3b017c" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2024-06-30 18:26.26 ---> using "5dff26d510618c1d48fe6b00f268416e83e2cb4c80c378ed525d97eb709030a0" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.08' '4.08.1'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.08.1"} | "ocaml-system" {= "4.08.1"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved ocaml-config.1  (cached)
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-base-compiler.4.08.1  (cached)
-> installed ocaml-base-compiler.4.08.1
-> installed ocaml-config.1
-> installed ocaml.4.08.1
Done.
# Run eval $(opam env --switch=4.08) to update the current shell environment
2024-06-30 18:26.26 ---> using "ad775bba96779a023c874bf756009ac479a83ad0078691fd8542d087b040156c" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [198 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-06-30-1411.31-F-2024-06-27-0211.32.pdiff [248 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-06-30-1411.31-F-2024-06-27-0211.32.pdiff [248 kB]
- Fetched 510 kB in 4s (142 kB/s)
- Reading package lists...
- 
2024-06-30 18:26.26 ---> using "8da0bdbec14db8e247f35eed506e9736be91e23030a3e56afbca1cab28ac44bd" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"autofonce_m4.0.8\"\
               \nopam install -vy \"autofonce_m4.0.8\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"autofonce_m4.0.8\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] autofonce_m4.0.8 is not installed.

Nothing to do.
[ERROR] Package conflict!
  * No agreement on the version of ocaml:
    - (invariant) -> ocaml-base-compiler = 4.08.1 -> ocaml = 4.08.1
    - autofonce_m4 -> ocaml >= 4.10.0
    You can temporarily relax the switch invariant with `--update-invariant'
  * No agreement on the version of ocaml-base-compiler:
    - (invariant) -> ocaml-base-compiler = 4.08.1
    - autofonce_m4 -> ocaml >= 4.10.0 -> ocaml-base-compiler >= 4.12.0~
  * Missing dependency:
    - autofonce_m4 -> ocaml >= 4.10.0 -> ocaml-variants >= 4.10.0 -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'
  * Missing dependency:
    - autofonce_m4 -> ocaml >= 4.10.0 -> ocaml-variants >= 4.10.0 -> system-msvc
    unmet availability conditions: 'os = "win32"'

No solution found, exiting
'opam install -vy autofonce_m4.0.8' failed.
"/usr/bin/env" "bash" "-c" "
opam remove -y "autofonce_m4.0.8"
opam install -vy "autofonce_m4.0.8"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "autofonce_m4.0.8" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed