OCamllabs icon Home|Differences with the last checks|Previous runs


Building on doris.caelum.ci.dev

(from ocaml/opam:debian-unstable)
2024-06-30 15:57.13 ---> using "0acd5aeaa8f7bc314514d9795d14a7f12ec72a6a5b11c5904350189734c6859b" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2024-06-30 15:57.13 ---> using "65c3237f501f7c75f3828458ecf2342bc41c98aaef8c6a7fd82bf46a58cb258c" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q 3bcb45c36ed254e850b498bff678e3e5848b23e1"))
2024-06-30 15:57.13 ---> using "3d0bfbfa177ca2531fcfa9e2869627278a2c31cf290ac589bbf0639aba3b017c" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2024-06-30 15:57.13 ---> using "5dff26d510618c1d48fe6b00f268416e83e2cb4c80c378ed525d97eb709030a0" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.09' '4.09.1'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.09.1"} | "ocaml-system" {= "4.09.1"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved ocaml-config.1  (cached)
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-base-compiler.4.09.1  (cached)
-> installed ocaml-base-compiler.4.09.1
-> installed ocaml-config.1
-> installed ocaml.4.09.1
Done.
# Run eval $(opam env --switch=4.09) to update the current shell environment
2024-06-30 15:59.08 ---> saved as "94bee53fb3556e054887fcd618d76906ae1985d6ade3a1083f4edea9304098ee"

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [198 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-06-30-1411.31-F-2024-06-27-0211.32.pdiff [248 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-06-30-1411.31-F-2024-06-27-0211.32.pdiff [248 kB]
- Fetched 510 kB in 1s (341 kB/s)
- Reading package lists...
- 
2024-06-30 15:59.11 ---> saved as "94c7b571280acf8b6f479f248e9c028c24468b873f9106e2ca28c5617111faf6"

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"DkSDKFFIOCaml_StdExport-linux_x86_64.1.0.0~1\"\
               \nopam install -vy \"DkSDKFFIOCaml_StdExport-linux_x86_64.1.0.0~1\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"DkSDKFFIOCaml_StdExport-linux_x86_64.1.0.0~1\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
Nothing to do.
[NOTE] DkSDKFFIOCaml_StdExport-linux_x86_64.1.0.0~1 is not installed.

The following actions will be performed:
=== install 1 package
  - install DkSDKFFIOCaml_StdExport-linux_x86_64 1.0.0~1

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved DkSDKFFIOCaml_StdExport-linux_x86_64.1.0.0~1  (cached)
Processing  2/3: [DkSDKFFIOCaml_StdExport-linux_x86_64: tar xvfz]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "tar" "xvfz" "DkSDKFFIOCaml_StdExport.tar.gz" (CWD=/home/opam/.opam/4.09/.opam-switch/build/DkSDKFFIOCaml_StdExport-linux_x86_64.1.0.0~1)
- COPYRIGHT
- LICENSE-CC-BY-ND-4.0
- LICENSE-OSL-3.0
- README.md
- lib/libDkSDKFFIOCaml_StdStatic.a
- lib/libDkSDKFFIOCaml_StdShared.so
-> compiled  DkSDKFFIOCaml_StdExport-linux_x86_64.1.0.0~1
Processing  3/3: [DkSDKFFIOCaml_StdExport-linux_x86_64: install]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "install" "install" "-d" "/home/opam/.opam/4.09/lib/DkSDKFFIOCaml_StdExport-linux_x86_64" (CWD=/home/opam/.opam/4.09/.opam-switch/build/DkSDKFFIOCaml_StdExport-linux_x86_64.1.0.0~1)
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "install" "install" "lib/libDkSDKFFIOCaml_StdStatic.a" "/home/opam/.opam/4.09/lib/DkSDKFFIOCaml_StdExport-linux_x86_64/libDkSDKFFIOCaml_StdStatic.a" (CWD=/home/opam/.opam/4.09/.opam-switch/build/DkSDKFFIOCaml_StdExport-linux_x86_64.1.0.0~1)
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "install" "install" "lib/libDkSDKFFIOCaml_StdShared.so" "/home/opam/.opam/4.09/lib/DkSDKFFIOCaml_StdExport-linux_x86_64/libDkSDKFFIOCaml_StdShared.so" (CWD=/home/opam/.opam/4.09/.opam-switch/build/DkSDKFFIOCaml_StdExport-linux_x86_64.1.0.0~1)
-> installed DkSDKFFIOCaml_StdExport-linux_x86_64.1.0.0~1
Done.
# Run eval $(opam env) to update the current shell environment
2024-06-30 15:59.24 ---> saved as "5cd1cf06fe75aaf1d84b64f93b98d7f9c023851a1b0a1ca2e65482cdd0926994"
Job succeeded