OCamllabs icon Home|Differences with the last checks|Previous runs


Building on x86-bm-c19.sw.ocaml.org

(from ocaml/opam:debian-unstable)
2024-06-30 17:07.39 ---> using "0acd5aeaa8f7bc314514d9795d14a7f12ec72a6a5b11c5904350189734c6859b" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2024-06-30 17:07.39 ---> using "65c3237f501f7c75f3828458ecf2342bc41c98aaef8c6a7fd82bf46a58cb258c" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q 3bcb45c36ed254e850b498bff678e3e5848b23e1"))
2024-06-30 17:07.39 ---> using "3d0bfbfa177ca2531fcfa9e2869627278a2c31cf290ac589bbf0639aba3b017c" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2024-06-30 17:07.39 ---> using "5dff26d510618c1d48fe6b00f268416e83e2cb4c80c378ed525d97eb709030a0" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.13' '4.13.1'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.13.1"} | "ocaml-system" {= "4.13.1"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved ocaml-config.2  (cached)
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> installed host-arch-x86_64.1
-> installed host-system-other.1
-> installed ocaml-options-vanilla.1
-> retrieved ocaml-base-compiler.4.13.1  (cached)
-> installed ocaml-base-compiler.4.13.1
-> installed ocaml-config.2
-> installed ocaml.4.13.1
Done.
# Run eval $(opam env --switch=4.13) to update the current shell environment
2024-06-30 17:07.39 ---> using "d09e7069a0ded9f00261b455f4204147fc50f3456108c27b5b2d832a3d595a72" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [198 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-06-30-1411.31-F-2024-06-27-0211.32.pdiff [248 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-06-30-1411.31-F-2024-06-27-0211.32.pdiff [248 kB]
- Fetched 510 kB in 3s (165 kB/s)
- Reading package lists...
2024-06-30 17:07.39 ---> using "462a5b6771b2bb3006c9808053674320e5c3eb446943f92dfda475b131e97fc1" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"angstrom-unix.0.16.0\"\
               \nopam install -vy \"angstrom-unix.0.16.0\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"angstrom-unix.0.16.0\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] angstrom-unix.0.16.0 is not installed.

Nothing to do.
The following actions will be performed:
=== install 7 packages
  - install angstrom           0.16.0 [required by angstrom-unix]
  - install angstrom-unix      0.16.0
  - install bigstringaf        0.9.1  [required by angstrom]
  - install csexp              1.5.2  [required by dune-configurator]
  - install dune               3.16.0 [required by angstrom-unix]
  - install dune-configurator  3.16.0 [required by bigstringaf]
  - install ocaml-syntax-shims 1.0.0  [required by angstrom]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
Processing  1/19: [angstrom.0.16.0, angstrom-unix.0.16.0: extract]
Processing  2/19: [angstrom.0.16.0, angstrom-unix.0.16.0: extract] [bigstringaf.0.9.1: extract]
Processing  3/19: [angstrom.0.16.0, angstrom-unix.0.16.0: extract] [bigstringaf.0.9.1: extract] [csexp.1.5.2: extract]
-> retrieved bigstringaf.0.9.1  (cached)
Processing  3/19: [angstrom.0.16.0, angstrom-unix.0.16.0: extract] [csexp.1.5.2: extract]
Processing  4/19: [angstrom.0.16.0, angstrom-unix.0.16.0: extract] [csexp.1.5.2: extract] [dune.3.16.0, dune-configurator.3.16.0: extract]
-> retrieved angstrom.0.16.0, angstrom-unix.0.16.0  (cached)
Processing  4/19: [csexp.1.5.2: extract] [dune.3.16.0, dune-configurator.3.16.0: extract]
Processing  5/19: [csexp.1.5.2: extract] [dune.3.16.0, dune-configurator.3.16.0: extract] [ocaml-syntax-shims.1.0.0: extract]
-> retrieved csexp.1.5.2  (cached)
Processing  5/19: [dune.3.16.0, dune-configurator.3.16.0: extract] [ocaml-syntax-shims.1.0.0: extract]
-> retrieved ocaml-syntax-shims.1.0.0  (cached)
Processing  5/19: [dune.3.16.0, dune-configurator.3.16.0: extract]
-> retrieved dune.3.16.0, dune-configurator.3.16.0  (cached)
Processing  6/19: [dune: ocaml 31]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "ocaml" "boot/bootstrap.ml" "-j" "31" (CWD=/home/opam/.opam/4.13/.opam-switch/build/dune.3.16.0)
- ocamlc -output-complete-exe -w -24 -g -o .duneboot.exe -I boot unix.cma boot/libs.ml boot/duneboot.ml
- ./.duneboot.exe -j 31
- 

Processing  6/19: [dune: ./_boot/dune.exe build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "./_boot/dune.exe" "build" "dune.install" "--release" "--profile" "dune-bootstrap" "-j" "31" (CWD=/home/opam/.opam/4.13/.opam-switch/build/dune.3.16.0)
-> compiled  dune.3.16.0
-> installed dune.3.16.0
Processing  8/19: [csexp: dune build]
Processing  9/19: [csexp: dune build] [ocaml-syntax-shims: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "csexp" "-j" "31" "@install" (CWD=/home/opam/.opam/4.13/.opam-switch/build/csexp.1.5.2)
-> compiled  csexp.1.5.2
Processing  9/19: [ocaml-syntax-shims: dune build]
-> installed csexp.1.5.2
Processing 10/19: [ocaml-syntax-shims: dune build]
Processing 11/19: [dune-configurator: rm] [ocaml-syntax-shims: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ocaml-syntax-shims" "-j" "31" "@install" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ocaml-syntax-shims.1.0.0)
-> compiled  ocaml-syntax-shims.1.0.0
Processing 11/19: [dune-configurator: rm]
-> installed ocaml-syntax-shims.1.0.0
Processing 12/19: [dune-configurator: rm]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "rm" "-rf" "vendor/csexp" (CWD=/home/opam/.opam/4.13/.opam-switch/build/dune-configurator.3.16.0)
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "rm" "-rf" "vendor/pp" (CWD=/home/opam/.opam/4.13/.opam-switch/build/dune-configurator.3.16.0)
Processing 12/19: [dune-configurator: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "dune-configurator" "-j" "31" "@install" (CWD=/home/opam/.opam/4.13/.opam-switch/build/dune-configurator.3.16.0)
-> compiled  dune-configurator.3.16.0
-> installed dune-configurator.3.16.0
Processing 14/19: [bigstringaf: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "bigstringaf" "-j" "31" "@install" (CWD=/home/opam/.opam/4.13/.opam-switch/build/bigstringaf.0.9.1)
-> compiled  bigstringaf.0.9.1
-> installed bigstringaf.0.9.1
Processing 16/19: [angstrom: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "angstrom" "-j" "31" (CWD=/home/opam/.opam/4.13/.opam-switch/build/angstrom.0.16.0)
-> compiled  angstrom.0.16.0
-> installed angstrom.0.16.0
Processing 18/19: [angstrom-unix: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "angstrom-unix" "-j" "31" (CWD=/home/opam/.opam/4.13/.opam-switch/build/angstrom-unix.0.16.0)
-> compiled  angstrom-unix.0.16.0
-> installed angstrom-unix.0.16.0
Done.
# Run eval $(opam env) to update the current shell environment
2024-06-30 17:08.45 ---> saved as "06ee2c447ec97744c9deaf476f065659e8e06bfebb859849f5abc769d6bdac1e"
Job succeeded