OCamllabs icon Home|Differences with the last checks|Previous runs


Building on x86-bm-c2.sw.ocaml.org

(from ocaml/opam:debian-unstable)
2024-06-30 18:26.27 ---> using "0acd5aeaa8f7bc314514d9795d14a7f12ec72a6a5b11c5904350189734c6859b" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2024-06-30 18:26.27 ---> using "65c3237f501f7c75f3828458ecf2342bc41c98aaef8c6a7fd82bf46a58cb258c" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q 3bcb45c36ed254e850b498bff678e3e5848b23e1"))
2024-06-30 18:26.27 ---> using "3d0bfbfa177ca2531fcfa9e2869627278a2c31cf290ac589bbf0639aba3b017c" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2024-06-30 18:26.27 ---> using "5dff26d510618c1d48fe6b00f268416e83e2cb4c80c378ed525d97eb709030a0" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.14' '4.14.1'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.14.1"} | "ocaml-system" {= "4.14.1"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved ocaml-config.2  (cached)
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> installed host-arch-x86_64.1
-> installed host-system-other.1
-> installed ocaml-options-vanilla.1
-> retrieved ocaml-base-compiler.4.14.1  (cached)
-> installed ocaml-base-compiler.4.14.1
-> installed ocaml-config.2
-> installed ocaml.4.14.1
Done.
# Run eval $(opam env --switch=4.14) to update the current shell environment
2024-06-30 18:26.27 ---> using "4a1a8f2fba7884c91681a28b5e0a1bdf1a3e7bab62e7520889de9b1ffa1301bf" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [198 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-06-30-1411.31-F-2024-06-27-0211.32.pdiff [248 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2024-06-30-1411.31-F-2024-06-27-0211.32.pdiff [248 kB]
- Fetched 510 kB in 3s (190 kB/s)
- Reading package lists...
- 
2024-06-30 18:26.27 ---> using "6ab115f829d049070b887cd1f7bb73803058f09317296eb0ed0e8e3418efe07a" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"autofonce_m4.0.8\"\
               \nopam install -vy \"autofonce_m4.0.8\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"autofonce_m4.0.8\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
Nothing to do.
[NOTE] autofonce_m4.0.8 is not installed.

The following actions will be performed:
=== install 7 packages
  - install autofonce_m4   0.8
  - install autofonce_misc 0.8    [required by autofonce_m4]
  - install dune           3.16.0 [required by autofonce_m4]
  - install ez_file        0.3.0  [required by autofonce_m4]
  - install ocplib_stuff   0.4.0  [required by autofonce_m4]
  - install re             1.11.0 [required by ez_file]
  - install seq            base   [required by re]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
Processing  1/20: [autofonce_m4.0.8, autofonce_misc.0.8: extract]
Processing  2/20: [autofonce_m4.0.8, autofonce_misc.0.8: extract] [dune.3.16.0: extract]
Processing  3/20: [autofonce_m4.0.8, autofonce_misc.0.8: extract] [dune.3.16.0: extract] [ez_file.0.3.0: extract]
-> retrieved autofonce_m4.0.8, autofonce_misc.0.8  (cached)
Processing  3/20: [dune.3.16.0: extract] [ez_file.0.3.0: extract]
Processing  4/20: [dune.3.16.0: extract] [ez_file.0.3.0: extract] [ocplib_stuff.0.4.0: extract]
-> retrieved ez_file.0.3.0  (cached)
Processing  4/20: [dune.3.16.0: extract] [ocplib_stuff.0.4.0: extract]
Processing  5/20: [dune.3.16.0: extract] [ocplib_stuff.0.4.0: extract] [re.1.11.0: extract]
-> retrieved re.1.11.0  (cached)
Processing  5/20: [dune.3.16.0: extract] [ocplib_stuff.0.4.0: extract]
-> retrieved seq.base  (cached)
Processing  6/20: [dune.3.16.0: extract] [ocplib_stuff.0.4.0: extract]
Processing  7/20: [dune.3.16.0: extract] [ocplib_stuff.0.4.0: extract]
-> installed seq.base
Processing  8/20: [dune.3.16.0: extract] [ocplib_stuff.0.4.0: extract]
-> retrieved ocplib_stuff.0.4.0  (cached)
Processing  8/20: [dune.3.16.0: extract]
-> retrieved dune.3.16.0  (cached)
Processing  9/20: [dune: ocaml 39]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "ocaml" "boot/bootstrap.ml" "-j" "39" (CWD=/home/opam/.opam/4.14/.opam-switch/build/dune.3.16.0)
- ocamlc -output-complete-exe -w -24 -g -o .duneboot.exe -I boot unix.cma boot/libs.ml boot/duneboot.ml
- ./.duneboot.exe -j 39
- 

Processing  9/20: [dune: ./_boot/dune.exe build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "./_boot/dune.exe" "build" "dune.install" "--release" "--profile" "dune-bootstrap" "-j" "39" (CWD=/home/opam/.opam/4.14/.opam-switch/build/dune.3.16.0)
-> compiled  dune.3.16.0
-> installed dune.3.16.0
Processing 11/20: [ocplib_stuff: sh]
Processing 12/20: [ocplib_stuff: sh] [re: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "sh" "-c" "./scripts/before.sh build 'ocplib_stuff'" (CWD=/home/opam/.opam/4.14/.opam-switch/build/ocplib_stuff.0.4.0)
Processing 12/20: [ocplib_stuff: dune build] [re: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ocplib_stuff" "-j" "39" "@install" (CWD=/home/opam/.opam/4.14/.opam-switch/build/ocplib_stuff.0.4.0)
Processing 12/20: [ocplib_stuff: sh] [re: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "sh" "-c" "./scripts/after.sh build 'ocplib_stuff'" (CWD=/home/opam/.opam/4.14/.opam-switch/build/ocplib_stuff.0.4.0)
-> compiled  ocplib_stuff.0.4.0
Processing 12/20: [re: dune build]
Processing 13/20: [re: dune build] [ocplib_stuff: sh]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "re" "-j" "39" (CWD=/home/opam/.opam/4.14/.opam-switch/build/re.1.11.0)
-> compiled  re.1.11.0
Processing 13/20: [ocplib_stuff: sh]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "install" "sh" "-c" "./scripts/before.sh install 'ocplib_stuff'" (CWD=/home/opam/.opam/4.14/.opam-switch/build/ocplib_stuff.0.4.0)
-> installed ocplib_stuff.0.4.0
-> installed re.1.11.0
Processing 15/20: [ez_file: sh]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "sh" "-c" "./scripts/before.sh build 'ez_file'" (CWD=/home/opam/.opam/4.14/.opam-switch/build/ez_file.0.3.0)
Processing 15/20: [ez_file: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ez_file" "-j" "39" "@install" (CWD=/home/opam/.opam/4.14/.opam-switch/build/ez_file.0.3.0)
Processing 15/20: [ez_file: sh]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "sh" "-c" "./scripts/after.sh build 'ez_file'" (CWD=/home/opam/.opam/4.14/.opam-switch/build/ez_file.0.3.0)
-> compiled  ez_file.0.3.0
Processing 16/20: [ez_file: sh]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "install" "sh" "-c" "./scripts/before.sh install 'ez_file'" (CWD=/home/opam/.opam/4.14/.opam-switch/build/ez_file.0.3.0)
-> installed ez_file.0.3.0
Processing 17/20: [autofonce_misc: sh]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "sh" "-c" "./scripts/before.sh build 'autofonce_misc'" (CWD=/home/opam/.opam/4.14/.opam-switch/build/autofonce_misc.0.8)
Processing 17/20: [autofonce_misc: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "autofonce_misc" "-j" "39" "@install" (CWD=/home/opam/.opam/4.14/.opam-switch/build/autofonce_misc.0.8)
- (cd _build/default/src/autofonce_misc && /home/opam/.opam/4.14/bin/ocaml unix.cma version.mlt) > _build/default/src/autofonce_misc/version.ml
- fatal: not a git repository (or any parent up to mount point /)
- Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).
- fatal: not a git repository (or any parent up to mount point /)
- Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).
Processing 17/20: [autofonce_misc: sh]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "sh" "-c" "./scripts/after.sh build 'autofonce_misc'" (CWD=/home/opam/.opam/4.14/.opam-switch/build/autofonce_misc.0.8)
-> compiled  autofonce_misc.0.8
Processing 18/20: [autofonce_misc: sh]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "install" "sh" "-c" "./scripts/before.sh install 'autofonce_misc'" (CWD=/home/opam/.opam/4.14/.opam-switch/build/autofonce_misc.0.8)
-> installed autofonce_misc.0.8
Processing 19/20: [autofonce_m4: sh]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "sh" "-c" "./scripts/before.sh build 'autofonce_m4'" (CWD=/home/opam/.opam/4.14/.opam-switch/build/autofonce_m4.0.8)
Processing 19/20: [autofonce_m4: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "autofonce_m4" "-j" "39" "@install" (CWD=/home/opam/.opam/4.14/.opam-switch/build/autofonce_m4.0.8)
- (cd _build/default/src/autofonce_m4 && /home/opam/.opam/4.14/bin/ocaml unix.cma version.mlt) > _build/default/src/autofonce_m4/version.ml
- fatal: not a git repository (or any parent up to mount point /)
- Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).
- fatal: not a git repository (or any parent up to mount point /)
- Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).
Processing 19/20: [autofonce_m4: sh]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "sh" "-c" "./scripts/after.sh build 'autofonce_m4'" (CWD=/home/opam/.opam/4.14/.opam-switch/build/autofonce_m4.0.8)
-> compiled  autofonce_m4.0.8
Processing 20/20: [autofonce_m4: sh]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "install" "sh" "-c" "./scripts/before.sh install 'autofonce_m4'" (CWD=/home/opam/.opam/4.14/.opam-switch/build/autofonce_m4.0.8)
-> installed autofonce_m4.0.8
Done.
# Run eval $(opam env) to update the current shell environment
2024-06-30 18:27.21 ---> saved as "05d7afb41b1014c92463120886c600ac73301a52b2be4d5d2cfa317a5f6b5525"
Job succeeded