OCamllabs icon Home|Differences with the last checks|Previous runs


Building on x86-bm-c9.sw.ocaml.org

(from ocaml/opam:debian-unstable)
2024-06-30 18:18.13 ---> using "0acd5aeaa8f7bc314514d9795d14a7f12ec72a6a5b11c5904350189734c6859b" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2024-06-30 18:18.13 ---> using "65c3237f501f7c75f3828458ecf2342bc41c98aaef8c6a7fd82bf46a58cb258c" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q 3bcb45c36ed254e850b498bff678e3e5848b23e1"))
2024-06-30 18:18.13 ---> using "3d0bfbfa177ca2531fcfa9e2869627278a2c31cf290ac589bbf0639aba3b017c" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2024-06-30 18:18.13 ---> using "5dff26d510618c1d48fe6b00f268416e83e2cb4c80c378ed525d97eb709030a0" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '5.2' '5.2.0'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "5.2.0"} | "ocaml-system" {= "5.2.0"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved ocaml-config.3  (cached)
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> installed host-arch-x86_64.1
-> installed host-system-other.1
-> installed ocaml-options-vanilla.1
-> retrieved ocaml-base-compiler.5.2.0  (cached)
-> installed ocaml-base-compiler.5.2.0
-> installed ocaml-config.3
-> installed ocaml.5.2.0
-> installed base-domains.base
-> installed base-nnp.base
Done.
# Run eval $(opam env --switch=5.2) to update the current shell environment
2024-06-30 18:18.13 ---> using "94b269842f3dfb0b3e258d96ed8fd8903115e1a3e34c23c534e7fcc31621f08f" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [198 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Ign:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages [9940 kB]
- Fetched 10.2 MB in 3s (3301 kB/s)
- Reading package lists...
- 
2024-06-30 18:18.13 ---> using "91fb7e04ea7bdcb35e50fba309604fa43ac7fa6672935838eb7bdab577e0e0ad" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"atd.2.15.0\"\
               \nopam install -vy \"atd.2.15.0\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"atd.2.15.0\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
Nothing to do.
[NOTE] atd.2.15.0 is not installed.

The following actions will be performed:
=== install 11 packages
  - install atd         2.15.0
  - install cmdliner    1.3.0    [required by atd]
  - install dune        3.16.0   [required by atd]
  - install easy-format 1.3.4    [required by atd]
  - install menhir      20231231 [required by atd]
  - install menhirCST   20231231 [required by menhir]
  - install menhirLib   20231231 [required by menhir]
  - install menhirSdk   20231231 [required by menhir]
  - install re          1.11.0   [required by atd]
  - install seq         base     [required by re, yojson]
  - install yojson      2.2.2    [required by atd]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
Processing  1/30:
Processing  2/30:
Processing  3/30:
-> retrieved cmdliner.1.3.0  (cached)
Processing  4/30:
Processing  5/30: [cmdliner: make all]
-> retrieved easy-format.1.3.4  (cached)
Processing  6/30: [cmdliner: make all]
-> retrieved menhir.20231231, menhirCST.20231231, menhirLib.20231231, menhirSdk.20231231  (cached)
Processing  7/30: [cmdliner: make all]
-> retrieved atd.2.15.0  (cached)
-> retrieved seq.base  (cached)
Processing  8/30: [cmdliner: make all]
Processing  9/30: [cmdliner: make all]
Processing 10/30: [cmdliner: make all]
-> installed seq.base
Processing 11/30: [cmdliner: make all]
-> retrieved dune.3.16.0  (cached)
Processing 12/30: [cmdliner: make all] [dune: ocaml 31]
-> retrieved re.1.11.0  (cached)
-> retrieved yojson.2.2.2  (cached)
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "make" "all" "PREFIX=/home/opam/.opam/5.2" (CWD=/home/opam/.opam/5.2/.opam-switch/build/cmdliner.1.3.0)
- ocaml build.ml cma
- ocaml build.ml cmxa
- ocaml build.ml cmxs
-> compiled  cmdliner.1.3.0
Processing 12/30: [dune: ocaml 31]
Processing 13/30: [dune: ocaml 31] [cmdliner: make install]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "install" "make" "install" "LIBDIR=/home/opam/.opam/5.2/lib/cmdliner" "DOCDIR=/home/opam/.opam/5.2/doc/cmdliner" (CWD=/home/opam/.opam/5.2/.opam-switch/build/cmdliner.1.3.0)
- install -d "/home/opam/.opam/5.2/lib/cmdliner"
- install pkg/META _build/cmdliner.mli _build/cmdliner.cmi _build/cmdliner.cmti "/home/opam/.opam/5.2/lib/cmdliner"
- install cmdliner.opam "/home/opam/.opam/5.2/lib/cmdliner/opam"
- install _build/cmdliner.cma "/home/opam/.opam/5.2/lib/cmdliner"
- install _build/cmdliner.cmxa _build/cmdliner.a _build/cmdliner.cmx _build/cmdliner_arg.cmx _build/cmdliner_base.cmx _build/cmdliner_cline.cmx _build/cmdliner_cmd.cmx _build/cmdliner_docgen.cmx _build/cmdliner_eval.cmx _build/cmdliner_exit.cmx _build/cmdliner_info.cmx _build/cmdliner_manpage.cmx _build/cmdliner_msg.cmx _build/cmdliner_term.cmx _build/cmdliner_term_deprecated.cmx _build/cmdliner_trie.cmx \
-   "/home/opam/.opam/5.2/lib/cmdliner"
- install _build/cmdliner.cmxs "/home/opam/.opam/5.2/lib/cmdliner"
Processing 13/30: [dune: ocaml 31] [cmdliner: make install-doc]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "install" "make" "install-doc" "LIBDIR=/home/opam/.opam/5.2/lib/cmdliner" "DOCDIR=/home/opam/.opam/5.2/doc/cmdliner" (CWD=/home/opam/.opam/5.2/.opam-switch/build/cmdliner.1.3.0)
- install -d "/home/opam/.opam/5.2/doc/cmdliner/odoc-pages"
- install CHANGES.md LICENSE.md README.md "/home/opam/.opam/5.2/doc/cmdliner"
- install doc/index.mld doc/cli.mld doc/examples.mld doc/tutorial.mld \
-            doc/tool_man.mld "/home/opam/.opam/5.2/doc/cmdliner/odoc-pages"
-> installed cmdliner.1.3.0
Processing 13/30: [dune: ocaml 31]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "ocaml" "boot/bootstrap.ml" "-j" "31" (CWD=/home/opam/.opam/5.2/.opam-switch/build/dune.3.16.0)
- ocamlc -output-complete-exe -w -24 -g -o .duneboot.exe -I boot -I +unix unix.cma boot/libs.ml boot/duneboot.ml
- ./.duneboot.exe -j 31
- cd _boot && /home/opam/.opam/5.2/bin/ocamlopt.opt -c -g -no-alias-deps -w -49-6 -alert -unstable -I +unix -I +threads stdune.ml
- File "otherlibs/stdune/src/stdune.ml", line 1, characters 4-9:
- Warning 53 [misplaced-attribute]: the "alert" attribute cannot appear in this context
- 

Processing 13/30: [dune: ./_boot/dune.exe build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "./_boot/dune.exe" "build" "dune.install" "--release" "--profile" "dune-bootstrap" "-j" "31" (CWD=/home/opam/.opam/5.2/.opam-switch/build/dune.3.16.0)
-> compiled  dune.3.16.0
-> installed dune.3.16.0
Processing 15/30: [easy-format: dune build]
Processing 16/30: [easy-format: dune build] [menhirCST: dune build]
Processing 17/30: [easy-format: dune build] [menhirCST: dune build] [menhirLib: dune build]
Processing 18/30: [easy-format: dune build] [menhirCST: dune build] [menhirLib: dune build] [menhirSdk: dune build]
Processing 19/30: [easy-format: dune build] [menhirCST: dune build] [menhirLib: dune build] [menhirSdk: dune build] [re: dune build]
Processing 20/30: [easy-format: dune build] [menhirCST: dune build] [menhirLib: dune build] [menhirSdk: dune build] [re: dune build] [yojson: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "easy-format" "-j" "31" "@install" (CWD=/home/opam/.opam/5.2/.opam-switch/build/easy-format.1.3.4)
-> compiled  easy-format.1.3.4
Processing 20/30: [menhirCST: dune build] [menhirLib: dune build] [menhirSdk: dune build] [re: dune build] [yojson: dune build]
-> installed easy-format.1.3.4
Processing 21/30: [menhirCST: dune build] [menhirLib: dune build] [menhirSdk: dune build] [re: dune build] [yojson: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "menhirCST" "-j" "31" (CWD=/home/opam/.opam/5.2/.opam-switch/build/menhirCST.20231231)
-> compiled  menhirCST.20231231
Processing 21/30: [menhirLib: dune build] [menhirSdk: dune build] [re: dune build] [yojson: dune build]
-> installed menhirCST.20231231
Processing 22/30: [menhirLib: dune build] [menhirSdk: dune build] [re: dune build] [yojson: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "menhirSdk" "-j" "31" (CWD=/home/opam/.opam/5.2/.opam-switch/build/menhirSdk.20231231)
- (cd _build/default && /home/opam/.opam/5.2/bin/ocamlc.opt -w -40 -g -bin-annot -bin-annot-occurrences -I sdk/.menhirSdk.objs/byte -no-alias-deps -open MenhirSdk -o sdk/.menhirSdk.objs/byte/menhirSdk__Cmly_api.cmo -c -impl sdk/cmly_api.ml)
- File "sdk/cmly_api.ml", line 149, characters 8-24:
- 149 |     [@@@ocaml.deprecated "Please use [get_reductions]"]
-               ^^^^^^^^^^^^^^^^
- Warning 53 [misplaced-attribute]: the "ocaml.deprecated" attribute cannot appear in this context
- (cd _build/default && /home/opam/.opam/5.2/bin/ocamlopt.opt -w -40 -g -I sdk/.menhirSdk.objs/byte -I sdk/.menhirSdk.objs/native -intf-suffix .ml -no-alias-deps -open MenhirSdk -o sdk/.menhirSdk.objs/native/menhirSdk__Cmly_api.cmx -c -impl sdk/cmly_api.ml)
- File "sdk/cmly_api.ml", line 149, characters 8-24:
- 149 |     [@@@ocaml.deprecated "Please use [get_reductions]"]
-               ^^^^^^^^^^^^^^^^
- Warning 53 [misplaced-attribute]: the "ocaml.deprecated" attribute cannot appear in this context
-> compiled  menhirSdk.20231231
Processing 22/30: [menhirLib: dune build] [re: dune build] [yojson: dune build]
-> installed menhirSdk.20231231
Processing 23/30: [menhirLib: dune build] [re: dune build] [yojson: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "menhirLib" "-j" "31" (CWD=/home/opam/.opam/5.2/.opam-switch/build/menhirLib.20231231)
- (cd _build/default/lib/pack && ./pack.exe)
- Creating menhirLib.ml...
- Creating menhirLib.mli...
-> compiled  menhirLib.20231231
Processing 23/30: [re: dune build] [yojson: dune build]
-> installed menhirLib.20231231
Processing 24/30: [re: dune build] [yojson: dune build]
Processing 25/30: [menhir: dune build] [re: dune build] [yojson: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "re" "-j" "31" (CWD=/home/opam/.opam/5.2/.opam-switch/build/re.1.11.0)
- (cd _build/default && /home/opam/.opam/5.2/bin/ocamlc.opt -w -40 -w -50 -g -bin-annot -bin-annot-occurrences -I deprecated/.re_emacs.objs/byte -I /home/opam/.opam/5.2/lib/seq -I lib/.re.objs/byte -no-alias-deps -o deprecated/.re_emacs.objs/byte/re_emacs.cmo -c -impl deprecated/re_emacs.ml)
- File "deprecated/re_emacs.ml", line 1, characters 4-14:
- 1 | [@@@deprecated "Use Re.Emacs"]
-         ^^^^^^^^^^
- Warning 53 [misplaced-attribute]: the "deprecated" attribute cannot appear in this context
- (cd _build/default && /home/opam/.opam/5.2/bin/ocamlc.opt -w -40 -w -50 -g -bin-annot -bin-annot-occurrences -I deprecated/.re_glob.objs/byte -I /home/opam/.opam/5.2/lib/seq -I lib/.re.objs/byte -no-alias-deps -o deprecated/.re_glob.objs/byte/re_glob.cmo -c -impl deprecated/re_glob.ml)
- File "deprecated/re_glob.ml", line 1, characters 4-14:
- 1 | [@@@deprecated "Use Re.Glob"]
-         ^^^^^^^^^^
- Warning 53 [misplaced-attribute]: the "deprecated" attribute cannot appear in this context
- (cd _build/default && /home/opam/.opam/5.2/bin/ocamlc.opt -w -40 -w -50 -g -bin-annot -bin-annot-occurrences -I deprecated/.re_perl.objs/byte -I /home/opam/.opam/5.2/lib/seq -I lib/.re.objs/byte -no-alias-deps -o deprecated/.re_perl.objs/byte/re_perl.cmo -c -impl deprecated/re_perl.ml)
- File "deprecated/re_perl.ml", line 1, characters 4-14:
- 1 | [@@@deprecated "Use Re.Perl"]
-         ^^^^^^^^^^
- Warning 53 [misplaced-attribute]: the "deprecated" attribute cannot appear in this context
- (cd _build/default && /home/opam/.opam/5.2/bin/ocamlc.opt -w -40 -w -50 -g -bin-annot -bin-annot-occurrences -I deprecated/.re_pcre.objs/byte -I /home/opam/.opam/5.2/lib/seq -I lib/.re.objs/byte -no-alias-deps -o deprecated/.re_pcre.objs/byte/re_pcre.cmo -c -impl deprecated/re_pcre.ml)
- File "deprecated/re_pcre.ml", line 1, characters 4-14:
- 1 | [@@@deprecated "Use Re.Pcre"]
-         ^^^^^^^^^^
- Warning 53 [misplaced-attribute]: the "deprecated" attribute cannot appear in this context
- (cd _build/default && /home/opam/.opam/5.2/bin/ocamlc.opt -w -40 -w -50 -g -bin-annot -bin-annot-occurrences -I deprecated/.re_posix.objs/byte -I /home/opam/.opam/5.2/lib/seq -I lib/.re.objs/byte -no-alias-deps -o deprecated/.re_posix.objs/byte/re_posix.cmo -c -impl deprecated/re_posix.ml)
- File "deprecated/re_posix.ml", line 1, characters 4-14:
- 1 | [@@@deprecated "Use Re.Posix"]
-         ^^^^^^^^^^
- Warning 53 [misplaced-attribute]: the "deprecated" attribute cannot appear in this context
- (cd _build/default && /home/opam/.opam/5.2/bin/ocamlc.opt -w -40 -w -50 -g -bin-annot -bin-annot-occurrences -I deprecated/.re_str.objs/byte -I /home/opam/.opam/5.2/lib/seq -I lib/.re.objs/byte -no-alias-deps -o deprecated/.re_str.objs/byte/re_str.cmo -c -impl deprecated/re_str.ml)
- File "deprecated/re_str.ml", line 1, characters 4-14:
- 1 | [@@@deprecated "Use Re.Str"]
-         ^^^^^^^^^^
- Warning 53 [misplaced-attribute]: the "deprecated" attribute cannot appear in this context
- (cd _build/default && /home/opam/.opam/5.2/bin/ocamlopt.opt -w -40 -w -50 -g -I deprecated/.re_glob.objs/byte -I deprecated/.re_glob.objs/native -I /home/opam/.opam/5.2/lib/seq -I lib/.re.objs/byte -I lib/.re.objs/native -intf-suffix .ml -no-alias-deps -o deprecated/.re_glob.objs/native/re_glob.cmx -c -impl deprecated/re_glob.ml)
- File "deprecated/re_glob.ml", line 1, characters 4-14:
- 1 | [@@@deprecated "Use Re.Glob"]
-         ^^^^^^^^^^
- Warning 53 [misplaced-attribute]: the "deprecated" attribute cannot appear in this context
- (cd _build/default && /home/opam/.opam/5.2/bin/ocamlopt.opt -w -40 -w -50 -g -I deprecated/.re_emacs.objs/byte -I deprecated/.re_emacs.objs/native -I /home/opam/.opam/5.2/lib/seq -I lib/.re.objs/byte -I lib/.re.objs/native -intf-suffix .ml -no-alias-deps -o deprecated/.re_emacs.objs/native/re_emacs.cmx -c -impl deprecated/re_emacs.ml)
- File "deprecated/re_emacs.ml", line 1, characters 4-14:
- 1 | [@@@deprecated "Use Re.Emacs"]
-         ^^^^^^^^^^
- Warning 53 [misplaced-attribute]: the "deprecated" attribute cannot appear in this context
- (cd _build/default && /home/opam/.opam/5.2/bin/ocamlopt.opt -w -40 -w -50 -g -I deprecated/.re_pcre.objs/byte -I deprecated/.re_pcre.objs/native -I /home/opam/.opam/5.2/lib/seq -I lib/.re.objs/byte -I lib/.re.objs/native -intf-suffix .ml -no-alias-deps -o deprecated/.re_pcre.objs/native/re_pcre.cmx -c -impl deprecated/re_pcre.ml)
- File "deprecated/re_pcre.ml", line 1, characters 4-14:
- 1 | [@@@deprecated "Use Re.Pcre"]
-         ^^^^^^^^^^
- Warning 53 [misplaced-attribute]: the "deprecated" attribute cannot appear in this context
- (cd _build/default && /home/opam/.opam/5.2/bin/ocamlopt.opt -w -40 -w -50 -g -I deprecated/.re_perl.objs/byte -I deprecated/.re_perl.objs/native -I /home/opam/.opam/5.2/lib/seq -I lib/.re.objs/byte -I lib/.re.objs/native -intf-suffix .ml -no-alias-deps -o deprecated/.re_perl.objs/native/re_perl.cmx -c -impl deprecated/re_perl.ml)
- File "deprecated/re_perl.ml", line 1, characters 4-14:
- 1 | [@@@deprecated "Use Re.Perl"]
-         ^^^^^^^^^^
- Warning 53 [misplaced-attribute]: the "deprecated" attribute cannot appear in this context
- (cd _build/default && /home/opam/.opam/5.2/bin/ocamlopt.opt -w -40 -w -50 -g -I deprecated/.re_posix.objs/byte -I deprecated/.re_posix.objs/native -I /home/opam/.opam/5.2/lib/seq -I lib/.re.objs/byte -I lib/.re.objs/native -intf-suffix .ml -no-alias-deps -o deprecated/.re_posix.objs/native/re_posix.cmx -c -impl deprecated/re_posix.ml)
- File "deprecated/re_posix.ml", line 1, characters 4-14:
- 1 | [@@@deprecated "Use Re.Posix"]
-         ^^^^^^^^^^
- Warning 53 [misplaced-attribute]: the "deprecated" attribute cannot appear in this context
- (cd _build/default && /home/opam/.opam/5.2/bin/ocamlopt.opt -w -40 -w -50 -g -I deprecated/.re_str.objs/byte -I deprecated/.re_str.objs/native -I /home/opam/.opam/5.2/lib/seq -I lib/.re.objs/byte -I lib/.re.objs/native -intf-suffix .ml -no-alias-deps -o deprecated/.re_str.objs/native/re_str.cmx -c -impl deprecated/re_str.ml)
- File "deprecated/re_str.ml", line 1, characters 4-14:
- 1 | [@@@deprecated "Use Re.Str"]
-         ^^^^^^^^^^
- Warning 53 [misplaced-attribute]: the "deprecated" attribute cannot appear in this context
-> compiled  re.1.11.0
Processing 25/30: [menhir: dune build] [yojson: dune build]
-> installed re.1.11.0
Processing 26/30: [menhir: dune build] [yojson: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "yojson" "-j" "31" "@install" (CWD=/home/opam/.opam/5.2/.opam-switch/build/yojson.2.2.2)
-> compiled  yojson.2.2.2
Processing 26/30: [menhir: dune build]
-> installed yojson.2.2.2
Processing 27/30: [menhir: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "menhir" "-j" "31" (CWD=/home/opam/.opam/5.2/.opam-switch/build/menhir.20231231)
- (cd _build/default/lib/pack && ./pack.exe)
- Creating menhirLib.ml...
- Creating menhirLib.mli...
- (cd _build/default/src/stage2 && .bin/menhir --exn-carries-state --no-pager --require-aliases --strict parser.mly --compare-errors parserMessages.auto.messages --compare-errors parserMessages.messages) > _build/default/src/stage2/parserMessages.check
- Read 99 sample input sentences and 99 error messages.
- Read 99 sample input sentences and 47 error messages.
- (cd _build/default && src/stage2/.bin/menhir --exn-carries-state --no-pager --require-aliases --strict -lg 1 -la 1 -lc 1 -v src/stage2/parser.mly --base src/stage2/parser --infer-read-reply src/stage2/parser__mock.mli.inferred)
- Grammar has 56 nonterminal symbols, among which 1 start symbols.
- Grammar has 37 terminal symbols.
- Grammar has 129 productions.
- Built an LR(0) automaton with 199 states.
- The grammar is not SLR(1) -- 7 states have a conflict.
- The construction mode is no-pager.
- Built an LR(1) automaton with 308 states.
- One shift/reduce conflict was silently solved.
- Extra reductions on error were added in 50 states.
- Priority played a role in 0 of these states.
- 156 out of 308 states have a default reduction.
- 108 out of 308 states are represented.
- 44 out of 96 symbols keep track of their start position.
- 39 out of 96 symbols keep track of their end position.
- The StackLang code contains 4113 instructions in 277 blocks.
- The StackLang code comprises 5 mutually recursive groups.
- (cd _build/default/src/stage2 && .bin/menhir --exn-carries-state --no-pager --require-aliases --strict parser.mly --compile-errors parserMessages.messages) > _build/default/src/stage2/parserMessages.ml
- Read 99 sample input sentences and 47 error messages.
-> compiled  menhir.20231231
-> installed menhir.20231231
Processing 29/30: [atd: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "atd" "-j" "31" "@install" (CWD=/home/opam/.opam/5.2/.opam-switch/build/atd.2.15.0)
-> compiled  atd.2.15.0
-> installed atd.2.15.0
Done.
# Run eval $(opam env) to update the current shell environment
2024-06-30 18:19.30 ---> saved as "25218a9f2ff6bde5524e07f737e6d4f2b0c916c42dfaf1fc81f714b29bedbd78"
Job succeeded